Bug 112703 - Problem with Sans and Monospace in Persian locale
Problem with Sans and Monospace in Persian locale
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pango (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-29 02:49 EST by Hedayat Vatankhah
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-09 15:01:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
An screenshot from my gnome in persian using Sans font (260.20 KB, image/png)
2004-01-04 02:32 EST, Hedayat Vatankhah
no flags Details

  None (edit)
Description Hedayat Vatankhah 2003-12-29 02:49:56 EST
From Bugzilla Helper: 
 
Description of problem: 
In Persian Locale, Sans and Monospace fonts (For English characters) 
doesn't appear correctly (They appear very large and ugly). But 
fonts like Luxi Sans and Luxi Mono appear nice. It should be solved 
because most of Persian fonts doesn't have any English characters 
and system use Sans and Monospace for them. 
 
 
Version-Release number of selected component (if applicable): 
pango-1.2.5-1.1 
 
How reproducible: 
Always 
 
Steps to Reproduce: 
1.Just run a program(like gedit) in Persian locale (Sans or a 
Persian font without English letters should be used).  
 
Actual Results:  English letters of that program will appear ugly 
and large. 
 
Additional info: 
 
There is a bug in fontconfig in Fedora which is solved now but this 
problem still exist (After installing new fontconfig and glib 
packages).
Comment 1 Roozbeh Pournader 2003-12-30 05:09:43 EST
Hedayat, please a) attach a screenshot, b) give "exact" steps to
reproduce, like: Run "LANG=fa ...", select this menu, click on that, ...
Comment 2 Hedayat Vatankhah 2004-01-04 02:32:29 EST
Created attachment 96757 [details]
An screenshot from my gnome in persian using Sans font
Comment 3 Hedayat Vatankhah 2004-01-04 02:47:08 EST
These are steps: 
1. Make sure that you havn't any Persian font which has English 
letters(Like Windows Times font) and choose Sans font (or a Persian 
font) for applications. 
2. In the login screen, go to Language menu and select Persian. Then 
login to gnome and run a program to see what happens. 
OR 
2. While system language is not Persian, run this command in a gnome 
terminal: 
(LANG=fa_IR.UTF-8; gedit) 
Comment 4 Roozbeh Pournader 2004-01-04 08:19:37 EST
I get what you mean now. The font that is being displayed is a bitmap
font that happens to have the Persian glyphs in them. To avoid that, I
personally remove those fonts from my computer, but I guess pango 1.3
is fixing the bug. Owen?

Workaround:

cd /usr/share/fonts/bitmap-fonts/
mv 10x20.pcf 9x15B.pcf 9x15.pcf console8x16.pcf ~/backup
fc-cache
Comment 5 Owen Taylor 2004-08-02 18:25:38 EDT
Yes, I think this should work better with Pango-1.4 or newer. 
(Though Pango-1.4.0 in fc2 is a bit buggy in this regard.)
Confirmation would be good.

Note You need to log in before you can comment on or make changes to this bug.