Bug 1127033 - Fedora-server installation doesn't prompt for creation of user after installation
Summary: Fedora-server installation doesn't prompt for creation of user after installa...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: comps
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Stephen Gallagher
QA Contact:
URL:
Whiteboard: RejectedBlocker
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-06 02:02 UTC by Mike Ruckman
Modified: 2015-05-04 19:23 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-12 20:54:31 UTC


Attachments (Terms of Use)

Description Mike Ruckman 2014-08-06 02:02:46 UTC
Description of problem:
Fedora Server doesn't prompt for the creation of a new user after installation. Proposing as a blocker for violating the "Expected installed system boot behavior": "A working mechanism to create a user account must be clearly presented during installation and/or first boot of the installed system."

This might be desired functionality - if so, we should revise the alpha criteria to reflect this.

Version-Release number of selected component (if applicable):
20140805 boot.iso

How reproducible:
Always

Steps to Reproduce:
1. Install from 20140805 Boot.iso
2. Select all defaults
3. Set root password, but don't create a user
4. Reboot system

Actual results:
Presented with console login prompt. Can log in as root.

Expected results:
Prompted to create a user on first boot.

Additional info:
This works as expected with an installation of GNOME.

Comment 1 Adam Williamson (Fedora) 2014-08-06 07:23:30 UTC
-1 blocker. The criterion is:

"A working mechanism to create a user account must be clearly presented during installation and/or first boot of the installed system."

note "and/or" - it is satisfied so long as the installer 'clearly presents' a mechanism, which it does.

I can't quite recall right now whether this is as designed or not, but I'd say definitely not a blocker.

Can you check if the 'initial-setup' package is installed as part of the installation?

Comment 2 Mike Ruckman 2014-08-06 17:32:37 UTC
I was aware of the "and/or" in the criteria - but thought this might be an edge case. I'd rather propose a blocker that isn't, than not propose one that is :)

$rpm -q initial-setup shows it as not installed.

Comment 3 Mike Ruckman 2014-08-06 17:45:39 UTC
Discussed at the 2014-08-06 Blocker Review meeting. Rejected as a blocker because: There is no clear violation of Alpha Criteria. If this isn't desired functionality, re-propose with Server criteria.

Comment 4 Vratislav Podzimek 2014-08-12 11:27:11 UTC
Whether the initial-setup is installed or not is a question of comps contents.

Comment 5 Jaroslav Reznik 2015-03-03 16:11:03 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22

Comment 6 Stephen Gallagher 2015-03-12 20:54:31 UTC
Server installations must have a user (root or otherwise) created during installation. There exists no reliable method for doing so post-install, as Server systems are presumed to be headless and remotely accessed.


Note You need to log in before you can comment on or make changes to this bug.