This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 112704 - [RFE] TLS/SSL support compiled into sendmail on RHEL 2.1
[RFE] TLS/SSL support compiled into sendmail on RHEL 2.1
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: sendmail (Show other bugs)
2.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Florian La Roche
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-29 03:47 EST by Oliver Jones
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-16 11:13:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oliver Jones 2003-12-29 03:47:08 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
SSL/STARTTLS support not included with sendmail on RHEL 2.1.

I would rate having SSL/TLS support built into sendmail as a
_requirement_ for enterprise deployments.

Please issue an official errata adding TLS support to sendmail.

Version-Release number of selected component (if applicable):
sendmail-8.11.6-28.72

How reproducible:
Always

Steps to Reproduce:
[root] unity:~/bin# sendmail -d0.1 -bv
Version 8.11.6
 Compiled with: LDAPMAP MAP_REGEX LOG MATCHGECOS MIME7TO8 MIME8TO7
                NAMED_BIND NETINET NETINET6 NETUNIX NEWDB NIS QUEUE
SASL SCANF
                SMTP TCPWRAPPERS USERDB


Actual Results:  STARTTLS is not listed in "Compiled with".

Expected Results:  STARTTLS should be comiled in.

Additional info:

Now I'm going to have to go build my own variant of sendmail... grrrr.

Good guide to doing this:
http://www.ists.dartmouth.edu/IRIA/knowledge_base/linuxinfo/sendmail-ssh-how-to.htm
Comment 1 Suzanne Hillman 2004-01-06 11:56:06 EST
Internal RFE bug #112954 entered, will be considered for future releases.
Comment 2 Oliver Jones 2004-01-06 16:45:29 EST
All I did here was get the RH 7.3 RPM (latest errata release) tweak
the .spec a tiny bit and recompile.  Havn't had any problems yet. 
Obviously something like this would need to go through the RHEL QA
department before it was released by RH but it doesn't sound to me
like a huge change.  Tho I must admit that there are a number of
improvements and changes to the structure of /etc/mail/sendmail.mc in
RH7.3 over RHEL 2.1 so perhaps the "upgrade" path isn't entirely seamless.

Ie, it's probably not really a entirely fire and forget errata.
Comment 3 Suzanne Hillman 2004-08-16 11:13:31 EDT
This is not something that is going to be done for RHEL2.1, as it
looks like it would be too big a change for an update release.

Note You need to log in before you can comment on or make changes to this bug.