Bug 1127112 - nova.conf virt_type not discussed
Summary: nova.conf virt_type not discussed
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation
Version: 5.0 (RHEL 7)
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
: 5.0 (RHEL 7)
Assignee: Summer Long
QA Contact: Don Domingo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-06 08:07 UTC by Joe Antkowiak
Modified: 2017-05-12 03:03 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-18 00:08:03 UTC


Attachments (Terms of Use)

Description Joe Antkowiak 2014-08-06 08:07:24 UTC
Description of problem:
I believe this should be a documentation bug but wasn't sure what to open it under.

The manual install guide for RH OSP5 does not specifically talk about the virt_type parameter for nova.conf, and by default is qemu when following this setup method.  On all-in-one or nested/VM deployments this is ok or even preferred, but for running a production multi-node non-nested deployment, kvm virt_type should be used, should it not?

This is not referenced anywhere in the current docs, could result in a less-than-optimal production deployment.  We experienced a considerable performance increase with instances when this was switched to the kvm virt_type (and installing the relevant libvirt kvm packages)


Version-Release number of selected component (if applicable):
RHEL7, OSP5


How reproducible:
100%

Comment 2 Don Domingo 2014-08-11 01:54:27 UTC
Reassigning to Summer Long, who is in charge of all Compute content.

Joe, usage of the virt_type parameter (and, by extension, Hypervisors config) is explained better in:

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux_OpenStack_Platform/5/html/Configuration_Reference_Guide/section_compute-hypervisors.html

We'll look into how we can highlight that content better. Thanks!

Comment 3 Joe Antkowiak 2014-08-11 02:07:30 UTC
Thanks Don.

Two quick add'l points to make though:

1. I think people will by default first follow the installation guide, which goes into a lot of other choice detail/tradeoffs on other topics like which MQ and which DB to use, but I would consider the use of KVM vs QEMU a far more important decision to make.  I expect a good portion of people will deploy following only the configuration guide and leave a lot at default, which will drop them into an inefficient deployment.

2. The configuration reference guide link you provided actually references:

2.10.2. KVM
KVM is configured as the default hypervisor for Compute.
NOTE
[snip]
To enable KVM explicitly, add the following configuration options to the /etc/nova/nova.conf file:
[snip]

But -- the default that gets explicitly set in the nova.conf file by the RH OSP5  nova package installs via yum actually sets the virt_type = qemu

I think this will get missed in either or both documents and result in a sub-par installation.  A lot of customers are starting up POCs of RH OSP now (we're helping a few) and this could result in a lower-performing RH OSP stack vs what is getting deployed via other distributions...

Just my 2 cents :)

-Joe

Comment 4 Summer Long 2014-08-26 04:10:42 UTC
Hi Joe, 
I did a basic manual install of Compute, and it didn't reset the virt_type away from kvm. Perhaps the package has been updated since you last tried an install?
My version is: openstack-nova-compute-2014.1.1-4.el7ost.noarch

For RHELOSP-Installer deployments (production env), was told that the config would be set to the best defaults for whatever component combinations were given. So that shouldn't be an issue either.

On the other hand, the PackStack install did reset to qemu. Because PackStack is intended for PoC environments, and a look-ma-no-hands installation, asking customers to futz with low-level config isn't ideal. Perhaps I should raise a bug to get the PackStack folk to take out the qemu change? Is there any good reason to stay with qemu?

thanks for your patience, Summer

Comment 5 Summer Long 2014-09-01 03:24:05 UTC
Am setting this to ON_QA; Don, does this sound right to you? Close this and ask dev for a PackStack change?

Comment 6 Joe Antkowiak 2014-09-04 14:10:48 UTC
I will run through another compute node build with the latest package versions and see if it has changed.  I was not using packstack or any other deployment tools.

Comment 7 Joe Antkowiak 2014-09-04 14:55:48 UTC
Installed:
  openstack-nova-compute.noarch 0:2014.1.2-1.el7ost

[root@osp5-comptest ~]# grep "virt_type=" /etc/nova/nova.conf
#virt_type=kvm

It looks like the parameter is now defined as KVM in 1.2-1 but still commented.  So, it is better, but I would take it a step further and uncomment this in the default config.

Up to you guys though, hope this helps!

Comment 8 Summer Long 2014-09-14 23:23:43 UTC
Thanks Joe. The commented-out value is the default, so that will work for the user. Or are you saying that you want the comment removed so that the KVM value is made explicit and obvious?

Comment 9 Summer Long 2014-10-20 05:40:55 UTC
Leaving on QA, waiting for Joe's reply.

Comment 10 Summer Long 2014-11-18 00:08:03 UTC
Joe looks to have moved on. Closing, the default is KVM.

Comment 11 Summer Long 2017-05-12 03:03:27 UTC
lol


Note You need to log in before you can comment on or make changes to this bug.