Bug 112712 - samba-3.0.0-14.3E backtrace found in logwatch report
samba-3.0.0-14.3E backtrace found in logwatch report
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: samba (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Simo Sorce
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-29 12:09 EST by Bernd Bartmann
Modified: 2007-11-30 17:06 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:31:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logwatch report containing samba backtrace (6.41 KB, text/plain)
2003-12-29 12:10 EST, Bernd Bartmann
no flags Details
samba-3.0.0-14.3E PANIC backtrace (/var/log/messages excerpt) (2.30 KB, text/plain)
2004-01-07 08:46 EST, Didier
no flags Details
/var/log/messages smb_panic working day excerpt (8.60 KB, text/plain)
2004-01-20 10:20 EST, Didier
no flags Details

  None (edit)
Description Bernd Bartmann 2003-12-29 12:09:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
While looking at the daily logwatch report email I noticed a backtrace
from samba. I'll attach the logwatch report.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. monitor logwatch
2.
3.
    

Additional info:
Comment 1 Bernd Bartmann 2003-12-29 12:10:07 EST
Created attachment 96726 [details]
logwatch report containing samba backtrace
Comment 2 Didier 2004-01-07 08:40:55 EST
With samba 3, we encounter several (anything between 10 and 20) of
these panic logs a day, on a moderately loaded server (approx. 50
users on-line) ; most recent backtrace in attachment.
Comment 3 Didier 2004-01-07 08:46:00 EST
Created attachment 96800 [details]
samba-3.0.0-14.3E PANIC backtrace (/var/log/messages excerpt)
Comment 4 Didier 2004-01-07 08:50:37 EST
Could this be correlated to bug #112424 ? 
We have mainly Win98/ME and Win2000 clients (with some sparse mobile
WinXP clients).
Comment 5 Bernd Bartmann 2004-01-07 09:31:49 EST
In my case the clients are only WinXP Pro and Home Edition.
Comment 6 Jay Fenlason 2004-01-16 23:56:23 EST
I've put RPMs of samba-3.0.2rc1 on 
http://people.redhat.com/fenlason/.samba .  Can you try them and see if 
they resolve your problem.  Note that these are un-qa'd packages of a 
release that is not intended for production use.  If they solve your 
problem, I will attempt to get samba-3.0.2 included in the next quarterly 
update of Red Hat Enterprise Linux 3. 
Comment 7 Didier 2004-01-17 13:22:19 EST
3.0.2-0rc1 applied, stress test on monday (> 100 users) ; I'll check
whether this fixes our problems with R/O shared MS Excel files too.
Comment 8 Bernd Bartmann 2004-01-18 08:16:35 EST
Installed samba-3.0.2-0rc1.3E but just got a backtrace again:

Jan 18 14:15:48 picard smbd[31478]: [2004/01/18 14:15:48, 0]
lib/fault.c:fault_report(36)
Jan 18 14:15:48 picard smbd[31478]:  
===============================================================
Jan 18 14:15:48 picard smbd[31478]: [2004/01/18 14:15:48, 0]
lib/fault.c:fault_report(37)
Jan 18 14:15:48 picard smbd[31478]:   INTERNAL ERROR: Signal 11 in pid
31478 (3.0.2rc1-0rc1.3E)
Jan 18 14:15:48 picard smbd[31478]:   Please read the appendix Bugs of
the Samba HOWTO collection
Jan 18 14:15:48 picard smbd[31478]: [2004/01/18 14:15:48, 0]
lib/fault.c:fault_report(39)
Jan 18 14:15:48 picard smbd[31478]:  
===============================================================
Jan 18 14:15:48 picard smbd[31478]: [2004/01/18 14:15:48, 0]
lib/util.c:smb_panic(1422)
Jan 18 14:15:48 picard smbd[31478]:   PANIC: internal error
Jan 18 14:15:48 picard smbd[31478]: [2004/01/18 14:15:48, 0]
lib/util.c:smb_panic(1430)
Jan 18 14:15:48 picard smbd[31478]:   BACKTRACE: 15 stack frames:
Jan 18 14:15:48 picard smbd[31478]:    #0 smbd(smb_panic+0x13f)
[0x801a638f]
Jan 18 14:15:48 picard smbd[31478]:    #1 smbd [0x80191eb8]
Jan 18 14:15:48 picard smbd[31478]:    #2 /lib/tls/libc.so.6 [0xb725bc08]
Jan 18 14:15:48 picard smbd[31478]:    #3 /lib/tls/libc.so.6 [0xb72a5769]
Jan 18 14:15:48 picard smbd[31478]:    #4
/lib/tls/libc.so.6(malloc+0x8d) [0xb72a4b0d]
Jan 18 14:15:48 picard smbd[31478]:    #5 smbd(Realloc+0x100) [0x801a5380]
Jan 18 14:15:48 picard smbd[31478]:    #6 smbd [0x80074ef2]
Jan 18 14:15:48 picard smbd[31478]:    #7 smbd(reply_trans2+0x8a1)
[0x8007aa41]
Jan 18 14:15:48 picard smbd[31478]:    #8 smbd [0x80090860]
Jan 18 14:15:48 picard smbd[31478]:    #9 smbd [0x80090a73]
Jan 18 14:15:48 picard smbd[31478]:    #10 smbd(process_smb+0xa6)
[0x80090cc6]
Jan 18 14:15:48 picard smbd[31478]:    #11 smbd(smbd_process+0x192)
[0x80091a42]
Jan 18 14:15:48 picard smbd[31478]:    #12 smbd(main+0x505) [0x8021d615]
Jan 18 14:15:48 picard smbd[31478]:    #13
/lib/tls/libc.so.6(__libc_start_main+0xf8) [0xb7249748]              
                                                                     
             
Jan 18 14:15:48 picard smbd[31478]:    #14 smbd [0x80035b12]
Jan 18 14:15:48 picard smbd[31478]:
Comment 9 Didier 2004-01-20 10:20:43 EST
Created attachment 97123 [details]
/var/log/messages smb_panic working day excerpt

Backtraces did not disappear ; however, they seem to be relatively sparsely
distributed across a working day, and not directly related to server load ; as
you can tell from the attached log, one occured at 18:22, when server load is
really low.
Comment 10 Jay Fenlason 2004-02-04 16:26:27 EST
I've built new rpms from 3.0.2rc2 and placed them at
http://people.redhat.com/fenlason/.samba/  If the problem persists
with them, please file a bug report at https://bugzilla.samba.org
Comment 11 Didier 2004-02-13 11:24:37 EST
Is there any chance of supplying a 3.0.2final rpm build ?
Comment 12 Bernd Bartmann 2004-02-16 09:15:45 EST
After a week of running 3.0.2rc2 successfully today I found a
backtrace in my logs again:

lib/access.c:check_access(328) : 2 Time(s)
lib/fault.c:fault_report(36) 
=============================================================== : 1
Time(s)
lib/fault.c:fault_report(37)  INTERNAL ERROR: Signal 11 in pid 27535
(3.0.2rc2-2rc2.3E)  Please read the appendix Bugs of the Samba HOWTO
collection : 1 Time(s)
lib/fault.c:fault_report(39) 
=============================================================== : 1
Time(s)
lib/util.c:smb_panic(1422)  PANIC: internal error : 1 Time(s)
lib/util.c:smb_panic(1430)  BACKTRACE: 15 stack frames:   #0
smbd(smb_panic+0x13f) [0x801a5f9f]   #1 smbd [0x80191a98]   #2
/lib/tls/libc.so.6 [0xb7259c08]   #3 /lib/tls/libc.so.6 [0xb72a3769] 
 #4 /lib/tls/libc.so.6(malloc+0x8d) [0xb72a2b0d]   #5
smbd(Realloc+0x100) [0x801a4f90]   #6 smbd [0x80074882]   #7
smbd(reply_trans2+0x8a1) [0x8007a3d1]   #8 smbd [0x800901f0]   #9 smbd
[0x80090403]   #10 smbd(process_smb+0xa6) [0x80090656]   #11
smbd(smbd_process+0x192) [0x800913d2]   #12 smbd(main+0x505)
[0x8021d255]   #13 /lib/tls/libc.so.6(__libc_start_main+0xf8)
[0xb7247748]   #14 smbd [0x80035a32] : 1 Time(s)
lib/util_sock.c:get_peer_addr(948)  getpeername failed. Error was
Transport endpoint is not connected : 7 Time(s)
lib/util_sock.c:get_peer_addr(948)  getpeername failed. Error was
Transport endpoint is not connected  Connection denied from 0.0.0.0 :
2 Time(s)
param/loadparm.c:lp_do_parameter(3057)  Ignoring unknown parameter
"character set" : 1 Time(s)
param/loadparm.c:map_parameter(2413)  Unknown parameter encountered:
"character set" : 1 Time(s)
rpc_server/srv_util.c:get_domain_user_groups(372) 
get_domain_user_groups: primary gid of user [bart] is not a Domain
group !  get_domain_user_groups: You should fix it, NT doesn't like
that : 4 Time(s)
smbd/process.c:process_smb(883) : 2 Time(s)
smbd/server.c:open_sockets_smbd(342)  Reloading services after SIGHUP
: 1 Time(s)
Comment 13 Didier 2004-02-18 17:11:09 EST
samba-3.0.2-6.3E installed ; as I am out of the office for a week,
I'll be unable to provide feedback.
Comment 14 Didier 2004-03-08 04:25:35 EST
FYI : since having upgraded to samba-3.0.2-6.3E three weeks ago, we
have not encountered one panic.

Comment 15 Dennis Wagelaar 2004-08-04 09:03:04 EDT
This bug (exact same backtrace) also occurs on Fedora Core 1 with
samba-3.0.4-1.FC1, but for one user only, which so happens to also be
named "Bart"?? The client OS is Windows XP Pro SP 2.
Comment 16 Sylvain 2005-02-04 04:30:33 EST
Hello,

i've got exactly the same problem on my red hat 3.0 ES
i'm running samba 3.0.0-14

And there's problems on the network, it's going up and down...

i couldn't find any update, but the rpm source, and i don't want to 
compile on the server.

Could any one tell me where i can find the rpm to update my samba, 
please?

here's my log...

Jan 31 08:02:05 intra smbd[12514]: [2005/01/31 08:02:05, 0] 
lib/fault.c:fault_report(37)
Jan 31 08:02:05 intra smbd[12514]:   INTERNAL ERROR: Signal 11 in pid 
12514 (3.0.0-14.3E)
Jan 31 08:02:05 intra smbd[12514]:   Please read the appendix Bugs of 
the Samba HOWTO collection
Jan 31 08:02:05 intra smbd[12514]: [2005/01/31 08:02:05, 0] 
lib/fault.c:fault_report(39)
Jan 31 08:02:05 intra smbd[12514]:   
===============================================================
Jan 31 08:02:05 intra smbd[12514]: [2005/01/31 08:02:05, 0] 
lib/util.c:smb_panic(1422)
Jan 31 08:02:05 intra smbd[12514]:   PANIC: internal error
Jan 31 08:02:05 intra smbd[12514]: [2005/01/31 08:02:05, 0] 
lib/util.c:smb_panic(1429)
Jan 31 08:02:05 intra smbd[12514]:   BACKTRACE: 23 stack frames:
Jan 31 08:02:05 intra smbd[12514]:    #0 smbd(smb_panic+0x11c) 
[0x81bbedc]
Jan 31 08:02:05 intra smbd[12514]:    #1 smbd [0x81aa652]
Jan 31 08:02:05 intra smbd[12514]:    #2 /lib/tls/libc.so.6 
[0xb7263be8]
Jan 31 08:02:05 intra smbd[12514]:    #3 /lib/tls/libc.so.6 
[0xb72aca59]
Jan 31 08:02:05 intra smbd[12514]:    #4 /lib/tls/libc.so.6
(malloc+0x8d) [0xb72abdfd]
Jan 31 08:02:05 intra smbd[12514]:    #5 smbd(Realloc+0xd7) 
[0x81bb0a7]
Jan 31 08:02:05 intra smbd[12514]:    #6 smbd
(convert_string_allocate+0x417) [0x81a8487]
Jan 31 08:02:05 intra smbd[12514]:    #7 smbd
(push_ucs2_allocate+0x49) [0x81a8cf9]
Jan 31 08:02:05 intra smbd[12514]:    #8 smbd(unix_strupper+0x24) 
[0x81a85c4]
Jan 31 08:02:05 intra smbd[12514]:    #9 smbd(strupper_m+0x42) 
[0x81b5002]
Jan 31 08:02:05 intra smbd[12514]:    #10 smbd [0x80d056a]
Jan 31 08:02:05 intra smbd[12514]:    #11 smbd [0x80d0fe2]
Jan 31 08:02:05 intra smbd[12514]:    #12 smbd(mangle_map+0x82) 
[0x80cef02]
Jan 31 08:02:05 intra smbd[12514]:    #13 smbd [0x80ab0af]
Jan 31 08:02:05 intra smbd[12514]:    #14 smbd [0x80ac07c]
Jan 31 08:02:05 intra smbd[12514]:    #15 smbd(reply_trans2+0x69c) 
[0x80b3e4c]
Jan 31 08:02:05 intra smbd[12514]:    #16 smbd [0x80c7286]
Jan 31 08:02:05 intra smbd[12514]:    #17 smbd [0x80c7459]
Jan 31 08:02:05 intra smbd[12514]:    #18 smbd(process_smb+0x8f) 
[0x80c766f]
Jan 31 08:02:05 intra smbd[12514]:    #19 smbd(smbd_process+0x167) 
[0x80c82a7]
Jan 31 08:02:06 intra smbd[12514]:    #20 smbd(main+0x4bf) [0x822407f]
Jan 31 08:02:06 intra smbd[12514]:    #21 /lib/tls/libc.so.6
(__libc_start_main+0xf8) [0xb7251748]
Jan 31 08:02:06 intra smbd[12514]:    #22 smbd(ldap_msgfree+0x69) 
[0x8076ba1]
Jan 31 08:02:06 intra smbd[12514]:
Jan 31 08:05:32 intra smbd[12527]: [2005/01/31 08:05:32, 0] 
lib/util_sock.c:get_socket_addr(919)
Jan 31 08:05:32 intra smbd[12527]:   getpeername failed. Error was 
Noeud final de transport n'est pas connecté

Best Regards

Sylvain
Comment 17 RHEL Product and Program Management 2007-10-19 15:31:52 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.