Bug 112713 - rpm-4.2.2-0.7 won't shut up about prelink problems
rpm-4.2.2-0.7 won't shut up about prelink problems
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: prelink (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
:
: 103739 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-29 12:52 EST by Jonathan Kamens
Modified: 2007-04-18 13:00 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-03 03:39:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2003-12-29 12:52:51 EST
jik:~$ rpm -q rpm
rpm-4.2.2-0.7
jik:~$ rpm -q net-snmp
net-snmp-5.1-3
jik:~$ rpm -q prelink
prelink-0.3.0-17
jik:~$ sudo rpm --verify net-snmp
prelink: /usr/sbin/snmpd: at least one of file's dependencies has 
changed since prelinking
S.?.....   /usr/sbin/snmpd
prelink: /usr/sbin/snmptrapd: at least one of file's dependencies has 
changed since prelinking
S.?.....   /usr/sbin/snmptrapd
jik:~$ sudo prelink /usr/sbin/snmpd /usr/sbin/snmptrapd
prelink: /usr/sbin/snmptrapd: Cannot prelink against non-PIC shared 
library /usr/lib/librpmdb-4.2.so
prelink: /usr/sbin/snmpd: Cannot prelink against non-PIC shared 
library /usr/lib/librpmdb-4.2.so
jik:~$ sudo rpm --verify net-snmp
prelink: /usr/sbin/snmpd: at least one of file's dependencies has 
changed since prelinking
S.?.....   /usr/sbin/snmpd
prelink: /usr/sbin/snmptrapd: at least one of file's dependencies has 
changed since prelinking
S.?.....   /usr/sbin/snmptrapd
jik:~$
Comment 1 Jeff Johnson 2003-12-30 07:46:14 EST
Not rpm that is chatty, rather prelink -u.
Comment 2 Jakub Jelinek 2003-12-30 07:53:02 EST
See ftp://people.redhat.com/prelink/prelink.pdf for some details (e.g. plans what to do about at least one of file's dependencies has changed error with lower security).
It is a rpm bug that librpmdb-4.2.so is non-PIC though.
Jeff, once you fix that, please reassign the bug to me again.
Comment 3 Jeff Johnson 2003-12-30 10:07:23 EST
OK, -fPIC on all platforms, not just where mandatory
(x86_64/s390/s390x). Will be in 4.2.2-0.9 and later
when built.

Pong. I'm really not sure what is planned after reading your
(otherwise excellent) prelink draft.
Comment 4 Jakub Jelinek 2003-12-30 10:42:38 EST
One thing planned is less secure verify mode, which will not bail
if there are changed dependencies, but instead just verify that
all but the prelink info are ok (when dependencies are changed, prelinking
info is never used).

This would make the above case quiet.

Things to think about are:
1) whether it is desirable to prelink -u automatically programs/shared libraries
which have been prelinked successfully before but cannot be prelinked
against the changed dependencies
2) what to do about orphaned shared libraries, which were prelinked because
some prelinked program required them, but that program has been removed
since then and there are no users of that shared library any more.
As prelink only tracks executables and shared libraries those binaries
depend on (transitively), such orphaned libraries are not tracked and
thus left prelinked, although their dependencies might have changed
since then.
In both 1) and 2) ATM this can be cured by manual prelink -u on the files
in question, but the question is whether and how to do it automatically.
Comment 5 Caolan McNamara 2004-05-03 16:23:05 EDT
*** Bug 103739 has been marked as a duplicate of this bug. ***
Comment 6 Bill Nottingham 2006-08-07 22:04:52 EDT
'Red Hat Raw Hide' refers to the development tree for Red Hat Linux.
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues were not resolved in a more
timely manner. However, we do want to make sure that important 
don't slip through the cracks. If these issues are still present
in a current release, such as Fedora Core 5, please move these
bugs to that product and version. Note that any remaining Red Hat
Raw Hide bugs will be closed as 'CANTFIX' on September 30, 2006.
Thanks again for your help.
Comment 7 Jonathan Kamens 2006-09-03 03:39:52 EDT
This was resolved at some point.

Note You need to log in before you can comment on or make changes to this bug.