Bug 112720 - reboot locks FC{1,2,3} and RHAS4 kernel
reboot locks FC{1,2,3} and RHAS4 kernel
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jason Baron
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-29 15:37 EST by Eugene Kanter
Modified: 2013-03-06 00:56 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-06 10:31:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eugene Kanter 2003-12-29 15:37:37 EST
Description of problem:

kernel locks solid during anaconda hardware probe, just after X detection.


How reproducible:

always.

Same behavior in Red Hat 9. Attached disk with Red Hat 9 to this
system - kudzu locked the kernel exactly the same way. Does anaconda
share hardware detection code with kudzu?

System is COMPAQ 1600. Has been working fine, running Red Hat 7.3
# lspci -vvvn
00:00.0 Class 0600: 8086:7192 (rev 02)
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR+ FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort+ >SERR- <PERR-
        Latency: 64
        Region 0: Memory at <unassigned> (32-bit, prefetchable)
[size=256M]

00:0b.0 Class 0300: 1013:00b8 (rev 45)
        Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Region 0: Memory at c4000000 (32-bit, prefetchable) [size=32M]
        Region 1: Memory at c6eff000 (32-bit, non-prefetchable) [size=4K]
        Expansion ROM at <unassigned> [disabled] [size=32K]

00:0d.0 Class 0604: 1011:0022 (rev 03)
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR+ FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 64, cache line size 08
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=64
        I/O behind bridge: 00002000-00002fff
        Memory behind bridge: c6f00000-c6ffffff
        Prefetchable memory behind bridge:
00000000fff00000-0000000000000000
        BridgeCtl: Parity+ SERR+ NoISA+ VGA- MAbort- >Reset- FastB2B-

00:0e.0 Class 0880: 0e11:a0f0
        Subsystem: 0e11:b0f3
        Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop-
ParErr+ Stepping- SERR+ FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Interrupt: pin A routed to IRQ 0
        Region 0: I/O ports at 1800 [size=256]
        Region 1: Memory at c6efef00 (32-bit, non-prefetchable) [size=256]

00:14.0 Class 0601: 8086:7110 (rev 02)
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0

00:14.1 Class 0101: 8086:7111 (rev 01) (prog-if 80 [Master])
        Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 64
        Region 4: I/O ports at f100 [size=16]

00:14.2 Class 0c03: 8086:7112 (rev 01)
        Control: I/O- Mem- BusMaster- SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Interrupt: pin D routed to IRQ 0
        Region 4: I/O ports at 1000 [disabled] [size=32]

00:14.3 Class 0680: 8086:7113 (rev 02)
        Control: I/O- Mem- BusMaster- SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Interrupt: pin ? routed to IRQ 9

01:07.0 Class 0280: 0e11:ae43 (rev 10)
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr+ Stepping- SERR+ FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 64, cache line size 08
        Interrupt: pin A routed to IRQ 30
        Region 0: I/O ports at 2c00 [size=16]
        Region 1: Memory at c6ffdcf0 (32-bit, non-prefetchable) [size=16]
        Expansion ROM at <unassigned> [disabled] [size=64K]

01:09.0 Class 0100: 1000:000f (rev 14)
        Subsystem: 0e11:7004
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop-
ParErr+ Stepping- SERR+ FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 255 (4250ns min, 16000ns max), cache line size 08
        Interrupt: pin A routed to IRQ 23
        Region 0: I/O ports at 2000 [size=256]
        Region 1: Memory at c6ffdf00 (32-bit, non-prefetchable) [size=256]
        Region 2: Memory at c6fff000 (32-bit, non-prefetchable) [size=4K]

01:09.1 Class 0100: 1000:000f (rev 14)
        Subsystem: 0e11:7004
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop-
ParErr+ Stepping- SERR+ FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 255 (4250ns min, 16000ns max), cache line size 08
        Interrupt: pin B routed to IRQ 22
        Region 0: I/O ports at 2400 [size=256]
        Region 1: Memory at c6ffde00 (32-bit, non-prefetchable) [size=256]
        Region 2: Memory at c6ffe000 (32-bit, non-prefetchable) [size=4K]

01:0a.0 Class 0200: 10ec:8139 (rev 10)
        Subsystem: 10ec:8139
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr+ Stepping- SERR+ FastB2B-
        Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 64 (8000ns min, 20000ns max)
        Interrupt: pin A routed to IRQ 16
        Region 0: I/O ports at 2800 [size=256]
        Region 1: Memory at c6ffdd00 (32-bit, non-prefetchable) [size=256]
        Capabilities: [50] Power Management version 2
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA
PME(D0-,D1+,D2+,D3hot+,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
Comment 1 Eugene Kanter 2003-12-29 15:38:57 EST
Adding Bill as kudzu specialist.
Comment 2 Jeremy Katz 2003-12-29 16:28:11 EST
anaconda links with libkudzu :)
Comment 3 Eugene Kanter 2003-12-29 17:16:58 EST
Should this bug be changed from anaconda to kudzu?
Comment 4 Bill Nottingham 2003-12-29 17:52:00 EST
If you strace kudzu, where does it lock?
Comment 5 Eugene Kanter 2003-12-30 09:09:35 EST
I do not have working disk with Red Hat 9 right now. Would you please
make me Fedora kudzu (static?) for test on Red Hat 7.3?
Comment 6 Eugene Kanter 2003-12-30 16:44:29 EST
statically compiled kudzu from Fedora Core 1 does not lock Red Hat 7.3
kernel.
knoppix 3.1 locks kernel on Autoconfiguring Devices stage.
Comment 7 Eugene Kanter 2003-12-31 13:59:29 EST
Booted ADIOS 2.00 in runlevel 1.

strace kudzu
......
open("/dev/psaux",O_RDWR|O_NONBLOCK

PS/2 mouse is attached and working in 7.3
Comment 8 Bill Nottingham 2003-12-31 22:01:40 EST
Kernel problem with your chipset, it appears. Note that this will in
some respect go away with 2.6, as there's no need to do the PS/2 probe
there.
Comment 9 Eugene Kanter 2004-05-27 23:29:40 EDT
I am able to install FC1 and FC2 which use 2.6 kernel however there
still is a problem:

the system can  not reboot - kernel locks solid. there are no error
messages whatsoever.

Please provide an advice and/or instrumented kernel which will output
debugging information upon attempting a reboot. I do not understand
what has happened since Red Hat 7.3 kernel which works flawlessly on
this system.
Comment 10 Eugene Kanter 2004-09-29 19:12:09 EDT
Doing more tests with 2.4 kernels and probing. Disabling USB probing
and USB module load restores normal kernel functionality.

However latest FC3T2 2.6 kernel still does not reboot and has problems
accessing onboard ethernet adapter. 2.4 kernel has exactly the same
problem accessing onboard ethernet adapter if usb module is loaded.

Moover latest FC3T2 kernel fails to reboot COMPAQ DESKPRO 6000. This
always worked on all previous FC and RedHat releases.
Comment 11 Eugene Kanter 2004-11-16 13:08:38 EST
No changes in RHAS4 beta2. Reboot is not possible. I performed a
default install, kernel locked upon reboot.
Comment 12 Dave Jones 2005-04-21 20:17:43 EDT
Was this fixed in the final release ?
Comment 13 Eugene Kanter 2005-04-27 12:04:11 EDT
Tested final release RHAS v4. Kernel used in boot image locks the machine if
reboot requested any time during the installation.

After installation the system can be rebooted by any variant of reboot command.

Do not know if this is related or not but disconnecting and reconnecting
keyboard will lock boot image kernel 100%. Have not yet tested installed kernel.
I have never seen any other type hardware lock the kernel when keyboard is
disconnected.
Comment 14 Eugene Kanter 2005-04-27 12:07:04 EDT
Latest FC3 kernel still fails to reboot COMPAQ DESKPRO 6000. Poweroff is working
properly.
Comment 15 Dave Jones 2005-06-27 16:02:28 EDT
Any improvement with the U1 kernel ?
Comment 16 Eugene Kanter 2005-07-17 18:55:03 EDT
I am now running latest FC4 on the deskpro 6000. Before the very latest kernel
update yesterday reboot was still not possible. I'll check as soon as I can get
to  the console. The compaq 1600 running RHEL v4 is on FC3 kernel because of Bug
139949. If U1 kernel fixes the bug - I'll try it. Otherwise I have to stay with FC3.
Comment 17 Jason Baron 2006-03-16 16:38:22 EST
that bug is now marked resolved. CAn you try the latest kernel then?
Comment 18 Eugene Kanter 2006-03-20 18:47:46 EST
I am working on installing latest RHEL kernel to replace FC3 kernel. I'll update
as soon as I am done.
Comment 19 Eugene Kanter 2006-03-29 14:35:33 EST
Latest RHELv4 and FC3 kernels do not exibit reboot problems.
However there still (related?) hard lock problems present:

1.
during the boot sequence pressing NumLock keyboard key anytime BEFORE
"initializing hardware audio network ...[OK]"
console message NumLock keyboard indicator correctly goes on and off.

pressing NumLock anytime AFTER the kernel locks solid. No messages on VGA console.

2.
kernel locks solid if PS/2 keyboard is unplugged from the server.
Comment 20 Eugene Kanter 2006-04-27 10:52:57 EDT
I just realized that I posted incorrect information about reboot problem.

Since original kernel-smp-2.6.9-5.EL experienced well known symbios driver
issues I have been using kernel-smp-2.6.11-1.21_FC3 which had no problem
rebooting Compaq ProLiant 1600. But since I upgraded to kernel-smp-2.6.9-34.EL
reboot problems surfaced again.

Shutdown sequence is fine but reboot does not happen - kernel seems to lock
attmpting to reboot. System stays powered with last line "rebooting" still on
the screen.
Comment 21 Jason Baron 2007-03-01 15:42:49 EST
hmmm, can you please try the latest rhel4 kernels and report back:
http://people.redhat.com/~jbaron/rhel4/

If the kernel 'locks' please tell me where and if there are any messages on the
console.

thanks.
Comment 22 Eugene Kanter 2007-03-04 19:27:33 EST
I can't try arbitrary kernels because this is a production system currently
running latest RHELv4 kernel. I am using nousb option for this Compaq 1600
server for last several months and have no issues. If I remember correctly last
working kernel which did not require nousb option was one from 7.3. There are no
log entries whatsoever when kernel is locked.

Here is hardware info. Despite the fact that USB is present here the box itself
has no USB connector.

# lspci -nvvv
00:00.0 Class 0600: 8086:7192 (rev 02)
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR+ FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort+ >SERR- <PERR-
        Latency: 64
        Region 0: Memory at <unassigned> (32-bit, prefetchable)

00:0b.0 Class 0300: 1013:00b8 (rev 45)
        Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
        Region 0: Memory at c4000000 (32-bit, prefetchable) [size=32M]
        Region 1: Memory at c6eff000 (32-bit, non-prefetchable) [size=4K]

00:0d.0 Class 0604: 1011:0022 (rev 03)
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR+ FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
        Latency: 64, Cache Line Size 08
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=64
        I/O behind bridge: 00003000-00003fff
        Memory behind bridge: c6f00000-c6ffffff
        Prefetchable memory behind bridge: 00000000fff00000-0000000000000000
        Secondary status: 66Mhz- FastB2B+ ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort+ <SERR- <PERR-
        BridgeCtl: Parity+ SERR+ NoISA+ VGA- MAbort- >Reset- FastB2B-

00:0e.0 Class 0880: 0e11:a0f0
        Subsystem: 0e11:b0f3
        Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr+
Stepping- SERR+ FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
        Interrupt: pin A routed to IRQ 113
        Region 0: I/O ports at 1800 [size=256]
        Region 1: Memory at c6efef00 (32-bit, non-prefetchable) [size=256]

00:0f.0 Class 0200: 10ec:8139 (rev 10)
        Subsystem: 10ec:8139
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr+
Stepping- SERR+ FastB2B-
        Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
        Latency: 64 (8000ns min, 16000ns max)
        Interrupt: pin A routed to IRQ 153
        Region 0: I/O ports at 2000 [size=256]
        Region 1: Memory at c6efee00 (32-bit, non-prefetchable) [size=256]
        Capabilities: [50] Power Management version 2
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA
PME(D0-,D1+,D2+,D3hot+,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-

00:14.0 Class 0601: 8086:7110 (rev 02)
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
        Latency: 0

00:14.1 Class 0101: 8086:7111 (rev 01) (prog-if 80 [Master])
        Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
        Latency: 64
        Region 4: I/O ports at f100 [size=16]

00:14.2 Class 0c03: 8086:7112 (rev 01)
        Control: I/O- Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
        Interrupt: pin D routed to IRQ 50
        Region 4: I/O ports at 1000 [disabled] [size=32]

00:14.3 Class 0680: 8086:7113 (rev 02)
        Control: I/O- Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
        Interrupt: pin ? routed to IRQ 9

01:07.0 Class 0280: 0e11:ae43 (rev 10)
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr+
Stepping- SERR+ FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
        Latency: 64, Cache Line Size 08
        Interrupt: pin A routed to IRQ 233
        Region 0: I/O ports at 3c00 [size=16]
        Region 1: Memory at c6ffdcf0 (32-bit, non-prefetchable) [size=16]

01:09.0 Class 0100: 1000:000f (rev 14)
        Subsystem: 0e11:7004
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr+
Stepping- SERR+ FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
        Latency: 255 (4250ns min, 16000ns max), Cache Line Size 08
        Interrupt: pin A routed to IRQ 185
        Region 0: I/O ports at 3000 [size=256]
        Region 1: Memory at c6ffdf00 (32-bit, non-prefetchable) [size=256]
        Region 2: Memory at c6fff000 (32-bit, non-prefetchable) [size=4K]

01:09.1 Class 0100: 1000:000f (rev 14)
        Subsystem: 0e11:7004
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr+
Stepping- SERR+ FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
        Latency: 255 (4250ns min, 16000ns max), Cache Line Size 08
        Interrupt: pin B routed to IRQ 177
        Region 0: I/O ports at 3400 [size=256]
        Region 1: Memory at c6ffde00 (32-bit, non-prefetchable) [size=256]
        Region 2: Memory at c6ffe000 (32-bit, non-prefetchable) [size=4K]

01:0a.0 Class 0200: 10ec:8139 (rev 10)
        Subsystem: 10ec:8139
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr+
Stepping- SERR+ FastB2B-
        Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
        Latency: 64 (8000ns min, 20000ns max)
        Interrupt: pin A routed to IRQ 129
        Region 0: I/O ports at 3800 [size=256]
        Region 1: Memory at c6ffdd00 (32-bit, non-prefetchable) [size=256]
        Capabilities: [50] Power Management version 2
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA
PME(D0-,D1+,D2+,D3hot+,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-

Comment 23 Eugene Kanter 2009-04-10 17:23:31 EDT
Solution for this particular hardware is to pass nousb to the kernel

Note You need to log in before you can comment on or make changes to this bug.