Bug 1127208 - ModemManager has unsatisfied dependencies in fc21 build
Summary: ModemManager has unsatisfied dependencies in fc21 build
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: ModemManager
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lubomir Rintel
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-06 11:46 UTC by Peter H. Jones
Modified: 2016-03-21 15:40 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-21 15:40:36 UTC


Attachments (Terms of Use)

Description Peter H. Jones 2014-08-06 11:46:22 UTC
Description of problem:
Unsatisfied dependencies

Version-Release number of selected component (if applicable):
ModemManager-1.2.0-3.fc21.x86_64

How reproducible:
In daily build log at
https://kojipkgs.fedoraproject.org//work/tasks/7311/7247311/mock_output.log

Actual results:
failed build

Expected results:
Normal build

Additional info:
There is also an unsatisfied dependency for libgadu .

Relevant part of abovementioned log file is:
"Retrieving http://kojipkgs.fedoraproject.org/mash/bleed/x86_64/repodata/repomd.xml ...OK
Retrieving http://kojipkgs.fedoraproject.org/mash/bleed/x86_64/repodata/79eaf7bbc837328088d403ab81ca47e23b1e80b4e9f3cf2e6ea9fedadd7b13cc-primary.sqlite.bz2  ...OK
Error creating Live CD : Failed to build transaction : libgadu-1.12.0-1.fc21.x86_64 requires libprotobuf-c.so.0()(64bit)
ModemManager-1.2.0-3.fc21.x86_64 requires libmbim-glib.so.0()(64bit)
Unmounting directory /var/tmp/imgcreate-ZRFf3x/install_root
"

Comment 1 Jaroslav Reznik 2015-03-03 16:11:06 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22

Comment 2 Fedora Admin XMLRPC Client 2015-08-18 14:54:11 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 3 Lubomir Rintel 2016-03-21 15:40:36 UTC
I'm quite sure ModemManager has been rebuilt against newer mbim since and the problem is now gone.


Note You need to log in before you can comment on or make changes to this bug.