Bug 112721 - Kernel mismatches for provisioning system with ES 2.1 installer
Kernel mismatches for provisioning system with ES 2.1 installer
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
unspecified
All Linux
high Severity high
: ---
: ---
Assigned To: Chip Turner
Fanny Augustin
:
Depends On:
Blocks: 108937
  Show dependency treegraph
 
Reported: 2003-12-29 15:41 EST by Rackspace Bugzilla
Modified: 2007-08-06 14:58 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-04 11:24:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rackspace Bugzilla 2003-12-29 15:41:32 EST
Description of problem:
Well after messing arround for a while, I was able to get the
provisioning system to initiate the kickstart system within the RHN
interface for a ES 2.1 box. 

Issue - as expected the
auto-kickstart-ks-redhat-ent-linux-i386-es-2.1-0.7-3 rpm gets
installed and lilo is modified with the additional information to boot
of the kickstart kernel along with its append statements for the ks
config file. System reboots 3 minutes later, queries the satelite
server for the ks.cfg file and then try's to grab the netstg1.img.
Loads it into memory and then anaconda stops with an error saying that
the kernels do not match. 

Checking - this does indeed seem to be the fact. 
1 - The auto-kickstart-ks-redhat-ent-linux-i386-es-2.1-0.7-3 rpm has
2.4.9-e.24BOOT kernel modules within the modules.cgz within the
initrd.img file. 
2 - On the Satellite server itself the modules.cgz file within the
netstg1.img file contains 2.4.9-e.12BOOT modules within it. 

This miss match will always cause anaconda to fail and abort a
kickstart process. Please resolve if you want me to test and play with
the provissioning system fully ! :)

Version-Release number of selected component (if applicable):


How reproducible:
Kick box with ES 2.1, register to the beta 3 satellite rhn server with 
Red Hat Enterprise Linux ES (v. 2.1 for i386)
Red Hat Network Provisioning Beta for RHEL 2.1 ES (i386) 

- attempt to use the kickstart process. 

Additional info:

I also attempted to re-kick the same ES 2.1 box with the AS 2.1 up2
channel - this also failed, this was due to the fact that there is no
/var/satellite/rhn/kickstart/ks-redhat-advanced-server-i386-qu2/ dir
on the satellite server, only :

[root@rhsatellite kickstart]# pwd
/var/satellite/rhn/kickstart
[root@rhsatellite kickstart]# ls -1
ks-redhat-ent-linux-i386-es-2.1
ks-rhel-i386-as-3
ks-rhel-i386-es-3
[root@rhsatellite kickstart]# 

Not 100% this is related, but on the satellite sync reports it says 0
packages avaliable for ks-redhat-advanced-server-i386-qu2 (as shown
below).

12:31:20 Processing errata data complete
12:31:20 
12:31:20 Processing kickstart tree data
12:31:23 Fetching kickstart files for
'ks-redhat-ent-linux-i386-es-2.1': 156
12:31:23 Fetch complete: 0/0/156 (success/failed/matched)
12:31:23 Fetching kickstart files for 'ks-rhel-i386-as-3': 165
12:31:23 Fetch complete: 0/0/165 (success/failed/matched)
12:31:24 Fetching kickstart files for 'ks-rhel-i386-es-3': 165
12:31:24 Fetch complete: 0/0/165 (success/failed/matched)
12:31:24 Fetching kickstart files for
'ks-redhat-advanced-server-i386-qu2': 0
12:31:24 Fetch complete: 0/0/0 (success/failed/matched)
12:31:24 
12:31:24 Processing kickstart tree data complete

I will be sending direct email to Greg DeKoenigsberg & Joe deBlaquiere
 in regards to this. 

Thanks
Cliff.
Comment 1 Robin Norwood 2003-12-29 18:15:49 EST
I think chip is in charge of building this package.
Comment 2 Greg DeKoenigsberg 2004-01-12 19:05:38 EST
Jamo,

Can you replicate and provide more info?
Comment 3 Matt Jamison 2004-01-13 11:14:36 EST
assigning to robin.  here is the important data:

Checking - this does indeed seem to be the fact. 
1 - The auto-kickstart-ks-redhat-ent-linux-i386-es-2.1-0.7-3 rpm has
2.4.9-e.24BOOT kernel modules within the modules.cgz within the
initrd.img file. 
2 - On the Satellite server itself the modules.cgz file within the
netstg1.img file contains 2.4.9-e.12BOOT modules within it. 
Comment 4 Matt Jamison 2004-01-13 16:23:24 EST
[root@jmotest2 tmp]# rpm -qa |grep auto
auto-kickstart-ks-redhat-ent-linux-i386-ws-2.1-0.7-4
auto-kickstart-0.7-4

the initrd.img has 2.4.9-e.24BOOT  

hope thats what you're looking for.
Comment 5 Chip Turner 2004-01-22 14:17:44 EST
this should be fixed with the auto-kickstart 1.1 packages, which are
in production
Comment 6 Matt Jamison 2004-02-04 11:24:11 EST
fixed.

Note You need to log in before you can comment on or make changes to this bug.