Bug 1127210 - mysql55-mysql-server's dependency on perl-DBD-MySQL does allow to uninstall unsupported mysql-5.0
Summary: mysql55-mysql-server's dependency on perl-DBD-MySQL does allow to uninstall u...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: mysql55-mysql
Version: 5.11
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Honza Horak
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-06 11:50 UTC by Honza Horak
Modified: 2014-08-06 12:05 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-06 12:05:44 UTC


Attachments (Terms of Use)

Description Honza Horak 2014-08-06 11:50:30 UTC
Description of problem:
mysql55-mysql-server requires perl-DBD-MySQL (probably because mysqlhotcopy), which in turn requires mysql-5.0, that is no maintained any more by upstream.

We need to find out if there is no other utility that would require it, since we could then use a work-around with `rpm --nodeps` to get rid of unsupported mysql-5.0 (upstream does not support this version any more). 

Steps to Reproduce:
1. yum install mysql55-mysql-server
2. yum remove mysql

Actual results:
mysql55-mysql-server is uninstalled

Expected results:
mysql55-mysql-server remains

Additional info:
Please, notice that this bug probably won't be solved by any update, since RHEL-5 is in a late stage, but might server for documentation purposes.

Comment 1 RHEL Product and Program Management 2014-08-06 12:05:44 UTC
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.


Note You need to log in before you can comment on or make changes to this bug.