Bug 1127219 - bundle files page shows 0 files selected always
Summary: bundle files page shows 0 files selected always
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Provisioning, UI
Version: JON 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: DR02
: JON 3.3.0
Assignee: RHQ Project Maintainer
QA Contact: Mike Foley
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-06 12:18 UTC by Armine Hovsepyan
Modified: 2015-09-03 00:03 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-10 07:56:19 UTC
Type: Bug


Attachments (Terms of Use)

Description Armine Hovsepyan 2014-08-06 12:18:36 UTC
Description of problem:
bundle files page shows 0 files selected always

Version-Release number of selected component (if applicable):
jon 3.3 dr1

How reproducible:
always

Steps to Reproduce:
1.  Install and start JBoss ON 3.1.2 system.
2.  Import platform resource.
3.  Create new compatible resource group called _All Platforms_:

    *   *Name*: `All Platforms`
    *   *Select Members*: _add all resources from platform category_
    
4.  Create jon-31-bundle-manyFiles bundle archive containing 300 files:

        mkdir -p jon-31-bundle-manyFiles
        pushd jon-31-bundle-manyFiles
        mkdir -p files

        cat >deploy.xml <<EOF
<?xml version="1.0"?>
<project name="manyFiles"
         default="main"
         xmlns:rhq="antlib:org.rhq.bundle">
  <target name="main" />

  <rhq:bundle name="Many Files Test Bundle"
              version="1.0"
              description="A sample bundle consisting of 300 files">
    <rhq:deployment-unit name="files"
                         manageRootDir="false">
EOF

        for file in {001..300}; do
            echo "This is File #${file}." >"files/file-${file}.txt"
            echo '      <rhq:file name="files/file-'"${file}"'.txt" destinationFile="files/file-'"${file}"'.txt" replace="true" />' >>deploy.xml
        done

        cat >>deploy.xml <<EOF
    </rhq:deployment-unit>
  </rhq:bundle>
</project>
EOF

        zip -qr ../jon-31-bundle-manyFiles.zip .
        popd

5.  From JBoss ON UI, create bundle using jon-31-bundle-manyFiles bundle archive.
6.  Navigate to the bundle's file list.
7. click on any file

Actual results:
no file is selected
300 rows 0 selected is shown

Expected results:
file is selected
number of selected rows is changed

Additional info:
very low severity BZ, since there is no operation for selected files

Comment 1 Jay Shaughnessy 2014-09-09 17:56:24 UTC
I think this is working as expected.  The rows highlight as you hover, but don't actually stay selected, there is no row selection supported here.  Do you disagree?

Comment 2 Armine Hovsepyan 2014-09-10 07:56:19 UTC
I would expect no '0 rows selected' message at all, but If that's what is expected, I'm fine with it. Closing as not-a-bug.
Thank you.


Note You need to log in before you can comment on or make changes to this bug.