Bug 1127237 - [abrt] icedtea-web-1.5-2.fc20: Uncaught exception java.lang.StringIndexOutOfBoundsException in method java.lang.String.substring()
Summary: [abrt] icedtea-web-1.5-2.fc20: Uncaught exception java.lang.StringIndexOutOfB...
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: icedtea-web
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: jiri vanek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:e44ab008b4afd13244f5e9edd4b...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-06 12:48 UTC by jshumake
Modified: 2014-10-21 11:30 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-21 11:30:40 UTC


Attachments (Terms of Use)
File: backtrace (610 bytes, text/plain)
2014-08-06 12:48 UTC, jshumake
no flags Details
File: environ (2.78 KB, text/plain)
2014-08-06 12:48 UTC, jshumake
no flags Details
File: jvm_environment (1.99 KB, text/plain)
2014-08-06 12:48 UTC, jshumake
no flags Details

Description jshumake 2014-08-06 12:48:04 UTC
Description of problem:
This error happens when closing elluminate

Version-Release number of selected component:
icedtea-web-1.5-2.fc20

Additional info:
reporter:       libreport-2.2.3
cmdline:        java -agentpath:/usr/lib64/libabrt-java-connector.so=abrt=on -splash:/usr/share/icedtea-web/javaws_splash.png -Xbootclasspath/a:/usr/share/icedtea-web/netx.jar:/usr/share/java/js.jar:/usr/share/java/tagsoup.jar -Xms8m -classpath /usr/lib/jvm/jre-openjdk/lib/rt.jar -Dicedtea-web.bin.name=javaws.itweb -Dicedtea-web.bin.location=/usr/bin/javaws.itweb net.sourceforge.jnlp.runtime.Boot /var/tmp/meeting-5.jnlp
executable:     /usr/share/icedtea-web/netx.jar
java_executable: /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.65-2.5.1.3.fc20.x86_64/jre-abrt/bin/java
kernel:         3.15.6-200.fc20.x86_64
pid:            10511
runlevel:       N 5
uid:            1000
java_custom_debug_info: net.sourceforge.jnlp.runtime.JNLPRuntime.getHistory =  file:/var/tmp/meeting-5.jnlp 

Truncated backtrace:
Exception in thread "JNLPRuntimeShutdownHookThread" java.lang.StringIndexOutOfBoundsException: String index out of range: -1
	at java.lang.String.substring(String.java:1911) [jar:file:/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.65-2.5.1.3.fc20.x86_64/jre/lib/rt.jar!/java/lang/String.class]
	at net.sourceforge.jnlp.cache.CacheUtil.cleanCache(CacheUtil.java:613) [jar:file:/usr/share/icedtea-web/netx.jar!/net/sourceforge/jnlp/cache/CacheUtil.class]
	at net.sourceforge.jnlp.runtime.JNLPRuntime$1.run(JNLPRuntime.java:780) [jar:file:/usr/share/icedtea-web/netx.jar!/net/sourceforge/jnlp/runtime/JNLPRuntime$1.class]

Comment 1 jshumake 2014-08-06 12:48:07 UTC
Created attachment 924470 [details]
File: backtrace

Comment 2 jshumake 2014-08-06 12:48:10 UTC
Created attachment 924471 [details]
File: environ

Comment 3 jshumake 2014-08-06 12:48:13 UTC
Created attachment 924472 [details]
File: jvm_environment

Comment 4 jiri vanek 2014-08-06 14:31:46 UTC
the issue happens on second code line of:

/*
                 * This will get me the root directory specific to this cache item.
                 * Example:
                 *  cacheDir = /home/user1/.icedtea/cache
                 *  file.getPath() = /home/user1/.icedtea/cache/0/http/www.example.com/subdir/a.jar
                 *  rStr first becomes: /0/http/www.example.com/subdir/a.jar
                 *  then rstr becomes: /home/user1/.icedtea/cache/0
                 */
String rStr = file.getPath().substring(cacheDir.length());
                rStr = cacheDir + rStr.substring(0, rStr.indexOf(File.separatorChar, 1));

I'm wondering what kind of input it recievs. I have never seen thi error, and I'm running elluminate regurally.

Comment 8 jiri vanek 2014-09-03 13:13:54 UTC
The issue seems no longer reproducible with head. jshumake, are you able to verify ?

Comment 9 jiri vanek 2014-09-17 15:53:40 UTC
Hi! I'm not able to reproduce the issue

May you please point me how to do so?

Comment 10 jshumake 2014-10-06 11:44:26 UTC
Confirmed still happening:

XDG_VTNR=1
XSUNTRANSPORT=shmem
ORBIT_SOCKETDIR=/var/tmp/orbit-jshumake
SSH_AGENT_PID=2234
XDG_SESSION_ID=1
KDE_MULTIHEAD=false
HOSTNAME=localhost.localdomain
IMSETTINGS_INTEGRATE_DESKTOP=yes
GPG_AGENT_INFO=/home/jshumake/.gnupg/S.gpg-agent:2278:1
XDG_MENU_PREFIX=kde4-
SHELL=/bin/bash
TERM=dumb
HISTSIZE=1000
GTK2_RC_FILES=/etc/gtk-2.0/gtkrc:/home/jshumake/.gtkrc-2.0:/home/jshumake/.gtkrc-2.0-kde4:/home/jshumake/.kde/share/config/gtkrc-2.0
TMPDIR=/var/tmp
XRE_PROFILE_NAME=
GS_LIB=
GTK_RC_FILES=/etc/gtk/gtkrc:/home/jshumake/.gtkrc:/home/jshumake/.kde/share/config/gtkrc
GNOME_KEYRING_CONTROL=/run/user/1000/keyring-Dg9Ith
QTDIR=/usr/lib64/qt-3.3
QTINC=/usr/lib64/qt-3.3/include
KDE_FULL_SESSION=true
MOZILLA_FIVE_HOME=/usr/lib64/firefox
IMSETTINGS_MODULE=none
QT_GRAPHICSSYSTEM_CHECKED=1
NSS_SSL_CBC_RANDOM_IV=1
USER=jshumake
XRE_PROFILE_LOCAL_PATH=
LD_LIBRARY_PATH=/usr/lib64/firefox:/usr/lib64/firefox/plugins:/usr/lib64/firefox
XRE_START_OFFLINE=
SSH_AUTH_SOCK=/tmp/ssh-U3or6ONJEZSp/agent.2100
LIBPATH=/usr/lib64/firefox:/usr/lib64/firefox
USERNAME=jshumake
SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/2346,unix/unix:/tmp/.ICE-unix/2346
GNOME_DISABLE_CRASH_DIALOG=1
MOZ_APP_LAUNCHER=/usr/bin/firefox
MOZ_PLUGIN_PATH=/usr/lib64/mozilla/plugins:/usr/lib64/firefox/plugins
PATH=/usr/lib64/qt-3.3/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/home/jshumake/.local/bin:/home/jshumake/bin
DESKTOP_SESSION=kde-plasma
MAIL=/var/spool/mail/jshumake
FONTCONFIG_PATH=/etc/fonts:/usr/lib64/firefox/res/Xft
QT_IM_MODULE=xim
PWD=/home/jshumake
XMODIFIERS=@im=none
KDE_SESSION_UID=1000
GNOME_KEYRING_PID=2098
LANG=en_US.UTF-8
GDM_LANG=en_US.UTF-8
XRE_PROFILE_PATH=
KDEDIRS=/usr
XSUNSMESIZE=512
GDMSESSION=kde-plasma
SSH_ASKPASS=/usr/bin/ksshaskpass
HISTCONTROL=ignoredups
XDG_SEAT=seat0
HOME=/home/jshumake
SHLVL=2
KDE_SESSION_VERSION=4
XCURSOR_THEME=Adwaita
DYLD_LIBRARY_PATH=/usr/lib64/firefox:/usr/lib64/firefox
LOGNAME=jshumake
QTLIB=/usr/lib64/qt-3.3/lib
MOZ_GRE_CONF=/etc/gre.d/gre64.conf
MOZ_LAUNCHED_CHILD=
XDG_DATA_DIRS=/usr/share/kde-settings/kde-profile/default/share:/usr/local/share:/usr/share
DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-h9h03fYw9S,guid=af49fbd50098495240299a055430a6ec
NO_EM_RESTART=
'LESSOPEN=||/usr/bin/lesspipe.sh %s'
SHLIB_PATH=/usr/lib64/firefox:/usr/lib64/firefox
MOZ_CRASHREPORTER_RESTART_ARG_1=--sm-config-prefix
WINDOWPATH=1
MOZ_CRASHREPORTER_RESTART_ARG_0=/usr/bin/firefox
XRE_BINARY_PATH=
XDG_RUNTIME_DIR=/run/user/1000
DISPLAY=:0.0
MOZ_CRASHREPORTER_RESTART_ARG_3=--sm-client-id
QT_PLUGIN_PATH=/home/jshumake/.kde/lib64/kde4/plugins/:/usr/lib64/kde4/plugins/
MOZ_CRASHREPORTER_RESTART_ARG_2=/firefox-oEFNX4/
XDG_CURRENT_DESKTOP=KDE
GTK_IM_MODULE=gtk-im-context-simple
MOZ_CRASHREPORTER_RESTART_ARG_5=--screen
'MOZ_CRASHREPORTER_DATA_DIRECTORY=/home/jshumake/.mozilla/firefox/Crash Reports'
XUL_APP_FILE=
NO_AT_BRIDGE=1
MOZ_CRASHREPORTER_RESTART_ARG_4=1028c1d320b210000141158198200000026280042
MOZ_CRASHREPORTER_STRINGS_OVERRIDE=/usr/lib64/firefox/browser/crashreporter-override.ini
MOZ_CRASHREPORTER_RESTART_ARG_7=
XAUTHORITY=/tmp/kde-jshumake/xauth-1000-_0
MOZ_CRASHREPORTER_RESTART_ARG_6=0

Comment 11 jiri vanek 2014-10-07 13:28:21 UTC
Ok. Please one more info needed. What are exact steps to reproduce this?  I was trying various combiantions,especially the link in c#5 but no never got the exception.

One more thing is - is this exception fatal?

Comment 12 jshumake 2014-10-07 19:29:55 UTC
The steps for me to reproduce are:
Open an elluminate link
Wait for the application to download
Wait for the application to open
Close the application using the "x" in the upper right OR close using "exit" in the file dropdown.

My apologies I don't completely understand what you mean by "fatal exception", nothing in the error logs describes this as fatal, is there something I need to do to understand whether or not this error is fatal?

Comment 13 jiri vanek 2014-10-08 09:24:39 UTC
Fatal - if it somehow cause some troubles - eg not saved session, some leaking resources, unexpected termination of eluminate, kept connections, persistent jvm  or similar.

Comment 14 jshumake 2014-10-08 12:32:43 UTC
This error is not fatal, as far as I can tell.

Comment 15 jiri vanek 2014-10-21 11:30:40 UTC
I'm really not bale to reproduce this. As it is not fatal, closing.


Note You need to log in before you can comment on or make changes to this bug.