Bug 1127288 - Provisioning RHEL OSP5 on RHEL 7 with rhel-osp-installer in non-HA failed when provisioning the neutron network controller
Summary: Provisioning RHEL OSP5 on RHEL 7 with rhel-osp-installer in non-HA failed whe...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-puppet-modules
Version: 5.0 (RHEL 7)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: z1
: Installer
Assignee: Ivan Chavero
QA Contact: Alexander Chuzhoy
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-06 14:25 UTC by Eduard Barrera
Modified: 2018-12-09 18:17 UTC (History)
7 users (show)

Fixed In Version: openstack-puppet-modules-2014.1-21.8.el7ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-01 13:26:09 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1350 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Bug Fix Advisory 2014-10-01 17:22:34 UTC

Description Eduard Barrera 2014-08-06 14:25:39 UTC
his is raised for Customer Host Europe in Cologne, Germany. They are part of the OpenStack High Touch Beta Program.

Provisioning RHEL OSP5 on RHEL 7 with rhel-osp-installer in non-HA configuration. The deployment fails when provisioning the neutron network controller.

"puppet agent -t" fails here:
-------------------------
Debug: /Stage[main]/Neutron::Agents::Ovs/Neutron_plugin_ovs[AGENT/veth_mtu]: Nothing to manage: no ensure and the resource doesn't exist
Debug: Executing '/usr/bin/ovs-vsctl br-exists br-int'
Debug: Executing '/usr/bin/systemctl is-active neutron-ovs-cleanup'
Debug: Executing '/usr/bin/systemctl is-enabled neutron-ovs-cleanup'
Debug: Executing '/usr/bin/ovs-vsctl br-exists br-ex'
Debug: Executing '/usr/bin/ovs-vsctl br-get-external-id br-ex'
Debug: Executing '/usr/bin/ovs-vsctl list-ports br-ex'
Debug: Executing '/usr/bin/ovs-vsctl list-ports br-ex'
Debug: Executing '/usr/sbin/ip addr show em3'
Debug: Executing '/usr/sbin/ip addr show em3'
Error: Could not set 'present' on ensure: no implicit conversion of nil into String at 7:/etc/puppet/environments/production/modules/neutron/manifests/plugins/ovs/port.pp
Error: Could not set 'present' on ensure: no implicit conversion of nil into String at 7:/etc/puppet/environments/production/modules/neutron/manifests/plugins/ovs/port.pp
Wrapped exception:
no implicit conversion of nil into String
Error: /Stage[main]/Neutron::Agents::Ovs/Neutron::Plugins::Ovs::Port[br-ex:em3]/Vs_port[em3]/ensure: change from absent to present failed: Could not set 'present' on ensure: no implicit conversion of nil into String at 7:/etc/puppet/environments/production/modules/neutron/manifests/plugins/ovs/port.pp
Debug: Executing '/usr/bin/systemctl is-active firewalld'
Debug: Executing '/usr/bin/systemctl is-enabled firewalld'
Debug: Executing '/usr/bin/systemctl is-active neutron-dhcp-agent'
Debug: Executing '/usr/bin/systemctl is-enabled neutron-dhcp-agent'
-------------------------

We saw that /etc/syscontrol/network-scripts/ifcfg-br-ex does not get created.

WORKAROUND:
============

1) manually create /etc/sysconfig/network-scripts/ifcfg-br-ex like this:

-------------------------
DEVICE=br-ex
DEVICETYPE=ovs
TYPE=OVSBridge
BOOTPROTO=static
IPADDR=x.x.x.x
NETMASK=x.x.x.x
ONBOOT=yes
-------------------------

2) manually adjust if cfg-em3 (which is the interface used for external connectivity):
-------------------------
DEVICE=em3
ONBOOT=yes
IPV6INIT=no
HWADDR=XX:XX:XX:XX:XX:XX
TYPE=OVSPort
DEVICETYPE=ovs
OVSBOOTPROTO=none
OVS_BRIDGE=br-ex
-------------------------

After that, puppet finished successfully and the deployment succeeded.

Comment 4 Alexander Chuzhoy 2014-08-06 21:20:56 UTC
Which network type was chosen?
What's the build ID?


Didn't happen to me.

Comment 5 Omri Hochman 2014-08-06 22:23:47 UTC
I'm not sure, but I think it might be duplicate of: https://bugzilla.redhat.com/show_bug.cgi?id=1122142

Comment 6 Alex Stellwag 2014-08-07 06:43:19 UTC
I don't think it's a duplicate because we've been using GRE at the customer, no VxLAN.

Comment 7 Eduard Barrera 2014-08-07 08:34:08 UTC
HOSTNAME: foreman01.poc
       OS: redhat
  RELEASE: Red Hat Enterprise Linux Server release 6.5 (Santiago)
  FOREMAN: 1.6-develop
     RUBY: ruby 1.8.7 (2011-06-30 patchlevel 352) [x86_64-linux]
   PUPPET: 3.6.2

rhel-osp-installer-0.1.6-5.el6ost.noarch
foreman-installer-1.5.0-0.6.RC2.el6ost.noarch
openstack-foreman-installer-2.0.16-1.el6ost.noarch
foreman-1.6.0.21-2.el6sat.noarch
foreman-postgresql-1.6.0.21-2.el6sat.noarch
foreman-proxy-1.6.0.8-1.el6sat.noarch
foreman-mysql2-1.6.0.21-2.el6sat.noarch
rubygem-foreman_api-0.1.11-4.el6sat.noarch
foreman-installer-1.5.0-0.6.RC2.el6ost.noarch
openstack-foreman-installer-2.0.16-1.el6ost.noarch
ruby193-rubygem-foreman_discovery-1.3.0-2.el6sat.noarch
foreman-selinux-1.6.0.3-2.el6sat.noarch
foreman-discovery-image-6.5-20140620.2.el6sat.noarch
ruby193-rubygem-foreman-tasks-0.6.4-2.el6sat.noarch
ruby193-rubygem-foreman_openstack_simplify-0.0.6-8.el6ost.noarch
ruby193-rubygem-staypuft-0.1.22-1.el6ost.noarch
This is the information I could extract from the sosreport.

Collecting plugin information
Foreman plugin: foreman-tasks, 0.6.4, Ivan Nečas, The goal of this plugin is to unify the way of showing task statuses across the Foreman instance.
It defines Task model for keeping the information about the tasks and Lock for assigning the tasks
to resources. The locking allows dealing with preventing multiple colliding tasks to be run on the
same resource. It also optionally provides Dynflow infrastructure for using it for managing the tasks.
Foreman plugin: foreman_discovery, 1.3.0, Greg Sutcliffe, MaaS Discovery Plugin engine for Foreman 
Foreman plugin: foreman_openstack_simplify, 0.0.6, Jiri Stransky, Plugin for Foreman that simplifies the UI for purposes of OpenStack install
Foreman plugin: staypuft, 0.1.22, Staypuft team, OpenStack Foreman Installer Plugin

$ cat puppet_manifests_tree
COMMAND> find /etc/puppet/modules -exec ls -ld {} +

drwxr-xr-x. 2 root root 4096 Jul 11 22:18 /etc/puppet/modules
[ebarrera@ebarrera foreman-debug]$ cat version_puppet
COMMAND> puppet --version
3.6.2

Alex can you the build number ?

Comment 8 Jason Guiditta 2014-09-10 13:46:23 UTC
The described problem sounds to me like something that was solved in the vswitch module in a recent release of openstack-puppet-modules.  Moving to that component for verification of whether I am correct.

Comment 9 Ivan Chavero 2014-09-11 20:37:48 UTC
The latest OPM RPM (openstack-puppet-modules-2014.1-21.8.el7ost) has fixed this issue

Comment 12 Alexander Chuzhoy 2014-09-15 19:49:00 UTC
Verified:rhel-osp-installer-0.3.4-3.el6ost.noarch


Note: the bug report says:
We saw that /etc/syscontrol/network-scripts/ifcfg-br-ex does not get created.
I assume that the intention is to /etc/sysconfig/network-scripts/ifcfg-br-ex


The reported issue doesn't reproduce. The deployment has completed successfully and I have the file created on my networker:
cat /etc/sysconfig/network-scripts/ifcfg-br-ex
ONBOOT=yes
PEERDNS=no
PEERROUTES=no
DEVICE=br-ex
DEVICETYPE=ovs
OVSBOOTPROTO="dhcp"
TYPE=OVSBridge
OVSDHCPINTERFACES=ens8
OVS_EXTRA="set bridge br-ex other-config:hwaddr=52:54:00:9f:05:48"

Comment 14 errata-xmlrpc 2014-10-01 13:26:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1350.html


Note You need to log in before you can comment on or make changes to this bug.