Bug 1127358 - ERROR [org.jboss.as.server] (Controller Boot Thread) JBAS015956: Caught exception during boot
Summary: ERROR [org.jboss.as.server] (Controller Boot Thread) JBAS015956: Caught excep...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Core Server
Version: JON 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: DR02
: JON 3.3.0
Assignee: RHQ Project Maintainer
QA Contact: Mike Foley
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-06 18:16 UTC by Matt Mahoney
Modified: 2014-09-09 17:59 UTC (History)
2 users (show)

Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-09 17:59:30 UTC
Type: Bug


Attachments (Terms of Use)
Server.log (1.43 MB, text/plain)
2014-08-06 18:16 UTC, Matt Mahoney
no flags Details

Description Matt Mahoney 2014-08-06 18:16:56 UTC
Created attachment 924555 [details]
Server.log

Description of problem:
Error in server.log file after clean install and server start:

ERROR [org.jboss.as.server] (Controller Boot Thread) JBAS015956: Caught exception during boot: org.jboss.as.controller.persistence.ConfigurationPersistenceException: JBAS014676: Failed to parse configuration
        at org.jboss.as.controller.persistence.XmlConfigurationPersister.load(XmlConfigurationPersister.java:141) [jboss-as-controller-7.4.0.Final-redhat-19.jar:7.4.0.Final-redhat-19]
        at org.jboss.as.server.ServerService.boot(ServerService.java:321) [jboss-as-server-7.4.0.Final-redhat-19.jar:7.4.0.Final-redhat-19]
        at org.jboss.as.controller.AbstractControllerService$1.run(AbstractControllerService.java:254) [jboss-as-controller-7.4.0.Final-redhat-19.jar:7.4.0.Final-redhat-19]
        at java.lang.Thread.run(Thread.java:744) [rt.jar:1.7.0_45]
Caused by: java.io.FileNotFoundException: /home/hudson/jon-server-3.3.0.DR01/jbossas/standalone/configuration/standalone.xml (No such file or directory)
        at java.io.FileInputStream.open(Native Method) [rt.jar:1.7.0_45]
        at java.io.FileInputStream.<init>(FileInputStream.java:146) [rt.jar:1.7.0_45]
        at org.jboss.as.controller.persistence.XmlConfigurationPersister.load(XmlConfigurationPersister.java:129) [jboss-as-controller-7.4.0.Final-redhat-19.jar:7.4.0.Final-redhat-19]
        ... 3 more


Version-Release number of selected component (if applicable):
JON 3.3 DR01

How reproducible:


Steps to Reproduce:
1. Install and start JON
2.
3.

Actual results:
Errors in server.log after clean install/start.

Expected results:
Should be zero silent errors in server.log


Additional info:

Comment 1 John Mazzitelli 2014-08-29 20:20:43 UTC
I don't see how this could happen. We don't use standalone.xml. JON Server runs with standalone-full.xml. Why is the server trying to read standalone.xml?

Comment 2 Jay Shaughnessy 2014-09-09 17:59:30 UTC
This looks like it was started -c standalone.xml.  I don't think this is a real problem.


Note You need to log in before you can comment on or make changes to this bug.