Bug 112738 - libc.so:4: syntax error
Summary: libc.so:4: syntax error
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: glibc   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
: 112757 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-12-30 14:08 UTC by Kaj J. Niemi
Modified: 2016-11-24 15:18 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-31 12:04:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kaj J. Niemi 2003-12-30 14:08:23 UTC
Description of problem:

/usr/bin/ld:/usr/lib/gcc-lib/i386-redhat-linux/3.3.2/../../../libc.so:
file format not recognized; treating as linker script
/usr/bin/ld:/usr/lib/gcc-lib/i386-redhat-linux/3.3.2/../../../libc.so:4:
syntax error
collect2: ld returned 1 exit status

File contents are the following:

% cat /usr/lib/libc.so
/* GNU ld script
   Use the shared library, but some functions are only in
   the static library, so try that secondarily.  */
*** BUG in libc/scripts/output-format.sed *** elf32-i386,elf32-i386
GROUP ( /lib/libc.so.6 /usr/lib/libc_nonshared.a )

While on a gcc-2.3.2-101.1 system they're:

/* GNU ld script
   Use the shared library, but some functions are only in
   the static library, so try that secondarily.  */
OUTPUT_FORMAT(elf32-i386)
GROUP ( /lib/libc.so.6 /usr/lib/libc_nonshared.a )


Version-Release number of selected component (if applicable):
glibc-devel-2.3.3-2, glibc-2.3.3-2

How reproducible:
Always

Additional info:

Comment 1 Kaj J. Niemi 2003-12-30 14:15:42 UTC
The contents of /usr/lib/libc.so are "normal" with glibc-2.3.3-1 as well:

/* GNU ld script
   Use the shared library, but some functions are only in
   the static library, so try that secondarily.  */
OUTPUT_FORMAT(elf32-i386)
GROUP ( /lib/libc.so.6 /usr/lib/libc_nonshared.a )



Comment 2 Jakub Jelinek 2003-12-30 19:30:29 UTC
This is a regex bug introduced already in glibc-2.3.3-1.
See http://sources.redhat.com/ml/libc-hacker/2003-12/msg00103.html
glibc just needs to be rebuilt while either glibc older than 2003-11-18
or glibc with this patch is installed on the system.

Comment 3 Jakub Jelinek 2003-12-30 19:30:58 UTC
*** Bug 112757 has been marked as a duplicate of this bug. ***

Comment 4 Kaj J. Niemi 2003-12-30 19:41:29 UTC
Uh, okay. Are you going to build a glibc where this has been fixed for
rawhide to replace 2.3.3-2 that's there now? If not, I'll see if I
have the time to try out the patch on a few test systems.

Thanks.

Comment 5 Kaj J. Niemi 2003-12-31 12:04:33 UTC
Fixed in 2.3.3-3. Resolving as RAWHIDE


Note You need to log in before you can comment on or make changes to this bug.