Bug 1127385 - RHS 3.0 ISO (pre-release) does not recognize HP B120i RAID controller used for boot disk mirroring
Summary: RHS 3.0 ISO (pre-release) does not recognize HP B120i RAID controller used fo...
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: distribution
Version: rhgs-3.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: ---
Assignee: Sreenath G
QA Contact: storage-qa-internal@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-06 19:26 UTC by Veda Shankar
Modified: 2018-04-16 07:25 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-16 07:25:22 UTC


Attachments (Terms of Use)
Screen capture while trying to use the patch driver at boot time. (188.34 KB, image/tiff)
2014-08-06 19:26 UTC, Veda Shankar
no flags Details

Description Veda Shankar 2014-08-06 19:26:13 UTC
Created attachment 924578 [details]
Screen capture while trying to use the patch driver at boot time.

Description of problem:
When booting the HP SL4540 server with RHS ISO, both 2.1u2 & 3.0 (pre-release), don't recognize the B120i RAID controller.  The B120i allows you to create a RAID1 config for the 2 boot disk drives and hence is important to avoid SFOF.

HP has provided a device driver for RHEL 6 and the following URL documents how to patch this driver at boot time.

http://h20566.www2.hp.com/portal/site/hpsc/template.PAGE/public/psi/swdDetails/?sp4ts.oid=5293151&spf_p.tpst=swdMain&spf_p.prp_swdMain=wsrp-navigationalState%3Didx%253D0%257CswItem%253DMTX_9aa84c9100f34106874ecf1457%257CswEnvOID%253D4103%257CitemLocale%253D%257CswLang%253D%257Cmode%253D3%257Caction%253DdriverDocument&javax.portlet.begCacheTok=com.vignette.cachetoken&javax.portlet.endCacheTok=com.vignette.cachetoken

In a recent test, we found that the stock RHEL 6.4 is able to make use of the patched driver and recognize the RAID1 boot volume.  On the contrary, both the RHS 2.1 and RHS 3.0 ISO throw an error message (attached) and fail to utilize the patched driver.
  

Version-Release number of selected component (if applicable):


How reproducible:

Every time.

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Bala.FA 2014-08-08 06:42:26 UTC
RHS 3.0 is based on RHEL 6 mainline (6.5 now) and RHS 2.1u2 is based on RHEL 6.3.z.

Is the driver available for RHEL 6 mainline and 6.3.z?

Comment 3 Bala.FA 2014-08-08 06:47:02 UTC
I see RHEL 6.5 and RHEL 6.3.z drivers in the link.  Please try with appropriate driver.

Comment 4 Rejy M Cyriac 2014-08-08 07:25:59 UTC
(In reply to Bala.FA from comment #2)
> RHS 3.0 is based on RHEL 6 mainline (6.5 now) and RHS 2.1u2 is based on RHEL
> 6.3.z.
> 
> Is the driver available for RHEL 6 mainline and 6.3.z?

I think you meant RHEL 6 mainline and 6.4.z , as RHS 3.0 is based on RHEL 6 mainline and RHSS 2.1 is based on RHEL 6.4.z.

Comment 5 Veda Shankar 2014-08-08 07:29:21 UTC
Please see comments from Gary Case below.  If you have questions on how this is supposed to work, please consult "Gary Case" gcase@redhat.com and "John Shortt" jshortt@redhat.com.

Bottom line - I am NOT able to insert an external driver (using USB) during the OS install boot process.  This works on stock RHEL6 and RHS ISO should behave the same way.

John, I think this is what we in the past referred to as "fakeraid", 
where the BIOS is doing the work and there's no hardware dedicated to 
doing the RAID operations. From looking at the hpvsa.ko module that HP 
provides, the PCI IDs listed there match up with the following:

alias:          pci:v00001590d00000047sv00001590sd00000047bc*sc*i*


alias:          pci:v00001590d00000045sv00001590sd00000045bc*sc*i*


alias:          pci:v00008086d00001D04sv00001590sd00000048bc*sc*i*
C600/X79 series chipset SATA RAID Controller

alias:          pci:v00008086d00008C04sv00001590sd00000084bc*sc*i*
8 Series/C220 Series Chipset Family SATA Controller 1 [RAID mode]

alias:          pci:v00008086d00008C06sv00001590sd00000084bc*sc*i*
8 Series/C220 Series Chipset Family SATA Controller 1 [RAID mode]

alias:          pci:v00008086d00001C04sv00001590sd0000006Cbc*sc*i*
6 Series/C200 Series Chipset Family SATA RAID Controller

Sayan, I don't see an hpvsa.ko module in RHEL 6.5 or even in Fedora 20, 
which leads me to believe we don't ship one. I'll let John provide the 
definitive answer.

-Gary

Comment 7 Ben Turner 2014-08-13 18:28:45 UTC
Hi all.  Just to further clarify things here:

-The hpvsa driver is not provided with RHEL, to get the b120i's RAID functionality you need to:

install with:

# linux dd blacklist=ahci

If you don't blacklist the ahci driver these disks show up as 2 devices sda and sdb.  When you blacklist ahci and use the driver disk these show up as a single block device as expected.

-This works fine on vanilla 6.5:

[root@g60ds-2 ~]# lsmod | grep hpvsa
hpvsa                2548743  2 
[root@g60ds-2 ~]# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 6.5 (Santiago)

-The driver disk just contains and RPM for the hpvsa kmod.  When I unpack the RPM I see:

$ rpm2cpio kmod-hpvsa-1.2.8-160.rhel6u5.x86_64.rpm | cpio -idmv
./etc/depmod.d/hpvsa.conf
./lib/modules/2.6.32-431.el6.x86_64
./lib/modules/2.6.32-431.el6.x86_64/extra
./lib/modules/2.6.32-431.el6.x86_64/extra/hpvsa
./lib/modules/2.6.32-431.el6.x86_64/extra/hpvsa/hpvsa.ko

-If I hit ctrl+alt+f2 during the installer and it looks like RHS 3.0 is running the 2.6.32-431.el6 kernel.  I wonder if the kernel version being off is the reason this is failing?

Comment 8 Ben Turner 2014-08-13 18:29:56 UTC
I'm sorry, in my last update RHS 3.0 is running the:

2.6.32-431.32.3.el6 kernel

There is a typo in my last update.

Comment 9 Rejy M Cyriac 2014-08-14 06:14:07 UTC
(In reply to Ben Turner from comment #8)
> I'm sorry, in my last update RHS 3.0 is running the:
> 
> 2.6.32-431.32.3.el6 kernel
> 
> There is a typo in my last update.

I see that the latest RHSS ISO compose for RHS 3.0 - RHSS-3.0-20140805.0-RHS-x86_64-DVD1 - has the 2.6.32-431.23.3.el6 kernel, which is also the highest available kernel version for RHEL 6 in production.

Comment 10 Dave Sullivan 2015-01-20 15:58:53 UTC
I'm not 100% positive but I believe our rescue disk/iso has the same problem.

Comment 11 Dave Sullivan 2015-01-28 16:11:13 UTC
So rescue disk has same problem.

To work around you'd blacklist=ahci and then follow here

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/6/html/Installation_Guide/rescuemode_drivers.html

I really don't like this because an operational support person may not know the bios array controller was set to dynamic b120i controller and would most likely not know about hpvsa.

So very possible to boot into resuce mode see two devices and start working on them independently with something like e2fsck.

Can someone tell me why we wouldn't just want to set the bios to ahci controller and use native md raid support?

Then there would be no problems here for RHS 3 ISO or linux rescue iso.

There seems to be quite a few negatives relative to using hpvsa, notes above plus maintenance burden.

Thoughts?

Comment 13 Rick Beldin 2015-05-13 15:42:13 UTC
hpvsa seen as a possible migration path for customers to hpsa devices. 

Out of the factory, raid mode (hpvsa) is default.  Extra steps needed by customer (going to RBSU) to disable. 

This is similar to: 1207831


Note You need to log in before you can comment on or make changes to this bug.