Bug 11274 - Squid cache to be re-initialised every time squid startup script is run
Summary: Squid cache to be re-initialised every time squid startup script is run
Status: CLOSED DUPLICATE of bug 11087
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: squid (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-05-07 07:45 UTC by Peter Hallgarten
Modified: 2014-03-17 02:13 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-16 16:46:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Peter Hallgarten 2000-05-07 07:45:33 UTC
The bug causes the squid cache to be re-initialised every time squid
startup script is run.

This fault has been caused by an addition to the cache line of the cache
type in /etc/squid/squid.conf in the latest version of squid.
ie. cache_dir ufs /var/spool/squid 2048 16 256

The cache directory is now in position 3.

The setion of the /etc/rc.d/init.d/squid as installed:
# determine which one is the cache_swap directory
CACHE_SWAP=`sed -e 's/#.*//g' /etc/squid/squid.conf | \
        grep cache_dir | sed -e 's/cache_dir//' | \
        cut -d ' ' -f 2'

The setion of the /etc/rc.d/init.d/squid as required to fix the fault
(changed -f 2 to -f 2 at the end of the CACHE_SWAP variable):
# determine which one is the cache_swap directory
CACHE_SWAP=`sed -e 's/#.*//g' /etc/squid/squid.conf | \
        grep cache_dir | sed -e 's/cache_dir//' | \
        cut -d ' ' -f 3`

Comment 1 Bill Nottingham 2000-05-16 16:46:59 UTC
*** This bug has been marked as a duplicate of 11087 ***


Note You need to log in before you can comment on or make changes to this bug.