Bug 1127407 - WARN [InventoryManager.discovery-1] (org.rhq.enterprise.agent.FailoverFailureCallback)- {AgentMain.too-many-failover-attempts}
Summary: WARN [InventoryManager.discovery-1] (org.rhq.enterprise.agent.FailoverFailur...
Keywords:
Status: CLOSED DUPLICATE of bug 1127414
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Agent
Version: JON 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: DR02
: JON 3.3.0
Assignee: RHQ Project Maintainer
QA Contact: Mike Foley
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-06 20:16 UTC by Matt Mahoney
Modified: 2014-08-26 11:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-26 11:37:43 UTC
Type: Bug


Attachments (Terms of Use)
agent.log (465.70 KB, text/plain)
2014-08-06 20:16 UTC, Matt Mahoney
no flags Details

Description Matt Mahoney 2014-08-06 20:16:16 UTC
Created attachment 924588 [details]
agent.log

Description of problem:
Warning in agent.log file after clean install and server start.

WARN  [InventoryManager.discovery-1] (org.rhq.enterprise.agent.FailoverFailureCallback)- {AgentMain.too-many-failover-attempts}Too many failover attempts have been made [1]. Exception that triggered the failover: [org.jboss.remoting.CannotConnectException: Can not connect http client invoker after 1 attempt(s)]
WARN  [InventoryManager.discovery-1] (org.rhq.enterprise.agent.AgentMain)- {AgentMain.failover-failed}Failed to failover to another server. Cause: org.jboss.remoting.CannotConnectException: Can not connect http client invoker after 1 attempt(s)
WARN  [InventoryManager.discovery-1] (rhq.core.pc.inventory.AutoDiscoveryExecutor)- Exception caught while executing server discovery scan.
WARN  [InventoryManager.discovery-1] (rhq.core.pc.inventory.RuntimeDiscoveryExecutor)- Exception caught while executing runtime discovery scan rooted at [platform].

VVersion-Release number of selected component (if applicable):
JON 3.3 DR01

How reproducible:


Steps to Reproduce:
1. Install and start JON.
2.
3.

Actual results:
Warnings in agent.log after clean install/start.

Expected results:
Should be zero silent Warnings in server.log

Additional info:

Comment 1 Heiko W. Rupp 2014-08-26 11:37:43 UTC

*** This bug has been marked as a duplicate of bug 1127414 ***


Note You need to log in before you can comment on or make changes to this bug.