Bug 112745 - __mkfontdir wrong in scripts
Summary: __mkfontdir wrong in scripts
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: openoffice.org   
(Show other bugs)
Version: 3.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-12-30 15:13 UTC by Florian La Roche
Modified: 2007-11-30 22:06 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-10 20:18:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Florian La Roche 2003-12-30 15:13:46 UTC
Description of problem:
Please look at rpm -qf --scripts openoffice* and look at
%__mkfontdir which does not exist in our rpm macros.
Error is not noticed due to being written to /dev/null. ;-)


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Dan Williams 2003-12-30 18:25:22 UTC
Does the following loop appropriate?  How come this doesn't get 
defined on RHEL3?  I'm also assuming its defined on Fedora, but that 
I don't know and will have to check when I get back into the office.

Index: openoffice.org.spec
===================================================================
RCS file: /cvs/pkgs/rpms/openoffice.org/openoffice.org.spec,v
retrieving revision 1.78
diff -u -r1.78 openoffice.org.spec
--- openoffice.org.spec 19 Dec 2003 05:17:31 -0000      1.78
+++ openoffice.org.spec 30 Dec 2003 18:24:57 -0000
@@ -668,6 +668,10 @@
 ##################################
 %post
 {
+  # RHEL3 doesn't define %__mkfontdir [112745]
+  %if %{build_taroon}
+    %define __mkfontdir umask 133;/usr/X11R6/bin/mkfontdir
+  %endif
   %__mkfontdir %{_libdir}/openoffice/share/fonts/truetype
   /usr/sbin/chkfontpath -q -a %{_libdir}/openoffice/share/fonts/
truetype
 } &> /dev/null || :


Comment 2 Dan Williams 2004-02-10 20:18:21 UTC
closing as will no longer apply with 1.1.0 in U2


Note You need to log in before you can comment on or make changes to this bug.