Bug 1127501 - uniconvertor does not work
Summary: uniconvertor does not work
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: uniconvertor
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pavel Alexeev
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-07 02:03 UTC by Elliott Sales de Andrade
Modified: 2016-09-30 09:19 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-18 16:49:31 UTC


Attachments (Terms of Use)

Description Elliott Sales de Andrade 2014-08-07 02:03:56 UTC
Description of problem:
uniconvertor --help lists the following "Allowed output formats":
     AI  - Adobe Illustrator files (postscript based)
     SVG - Scalable Vector Graphics files
     CGM - Computer Graphics Metafile files
     WMF - Windows Metafile files
     SK  - Sketch/Skencil files
     SK1 - sK1 vector graphics files
     PDF - Portable Document Format
     PS  - PostScript
     PLT - HPGL for cutting plotter files

but only PLT works. But then of course, the loader doesn't work for CDR.

Version-Release number of selected component (if applicable):
uniconvertor-2.0-0.4.svn362.fc20.x86_64

Steps to Reproduce:
1. Download this CorelDraw file https://github.com/obspy/docs/blob/master/posters/2012_egu/obspy.cdr
2. Try to convert to any other formats:

for ext in ai svg cgm wmf sk sk1 pdf ps eps plt; do
  echo $ext
  uniconvertor -verbose obspy.cdr obspy.$ext
done 

Actual results:

For almost every extension, something like the following is output:
JOB    | Translation of "obspy.cdr" into "obspy.svg"
INFO   | Start to search saver by file extension svg
ERROR  | Saver is not found for svg file format
ERROR  | Output file format of 'obspy.svg' is unsupported.
STOP   | Translation is interrupted


For the plt extension, it goes a little further:
JOB    | Translation of "obspy.cdr" into "obspy.plt"
INFO   | Start to search saver by file extension plt
OK     | Saver is found for extension plt
INFO   | Start to search for loader by file extension cdr
WARNING| Loader is not found or not suitable for obspy.cdr
INFO   | Start to search loader by file content
ERROR  | Loader is not found for obspy.cdr
ERROR  | Input file format of 'obspy.cdr' is unsupported.
STOP   | Translation is interrupted


Expected results:
File is converted into the formats that are claimed to be supported.

Comment 1 Pavel Alexeev 2014-08-18 16:49:31 UTC
Thank you for the bugreport and willing make free software better.

Information about supported formats statically present in source unfortunately.
Meantime now it seems indeed not so manu save formats supported:

$ cat /usr/lib64/python2.7/site-packages/uc2/formats/data.py | grep 'SAVER'
SIMPLE_SAVERS = []
MODEL_SAVERS = [PDXF, PLT, ]
EXPERIMENTAL_SAVERS = [SK1, RIFF, CDR]
SAVER_FORMATS = SIMPLE_SAVERS + MODEL_SAVERS

By fact only two: PDXF, PLT and 3 experimental.

I have mailed to author suggestion to obtain supported formats data on the fly and questions about current supported exports.

I could now only hope on answer. And when some changed update uniconvertor.

Comment 2 Pavel Alexeev 2014-08-20 07:39:46 UTC
X5 and X6 versions of CDR format should be available in future versions of uniconvertor.

Comment 3 Oleg 2015-02-26 08:36:06 UTC
Time passes, and uniconvertor still does not work. Details:
[oleg@o ~]$ dnf info uniconvertor
Using metadata from Thu Feb 26 09:40:13 2015
Установленные пакеты
Name        : uniconvertor
Архитектура : x86_64
Epoch       : 0
Версия      : 2.0
Release     : 0.6.svn362.fc21
Размер      : 4.0 M
Repo        : @System
Summary     : Universal vector graphics translator
URL         : http://sk1project.org/modules.php?name=Products&product=uniconvertor
License     : LGPLv2+ and GPLv2+ and MIT
Description : UniConvertor is a universal vector graphics translator.
            : It uses sK1 engine to convert one format to another.

[oleg@o Загрузки]$ uniconvertor -verbose Adobe.cdr test.svg

JOB    | Translation of "Adobe.cdr" into "test.svg"
INFO   | Start to search saver by file extension svg
ERROR  | Saver is not found for svg file format
ERROR  | Output file format of 'test.svg' is unsupported.
STOP   | Translation is interrupted

The import CDR in sK1 works fine. Import CDR Inkscape does not work. As far as I understand, all these programs import CDR is carried out using a utility uniconvertor.

Comment 4 Dmitrij S. Kryzhevich 2015-08-14 04:45:15 UTC
This bug exist and was not fixed in upstream.
My details:

$ uniconvertor  *dxf _111_o.pdf -verbose

JOB    | Translation of "v-135.dxf" into "_111_o.pdf"
INFO   | Start to search saver by file extension pdf
ERROR  | Saver is not found for pdf file format
ERROR  | Output file format of '_111_o.pdf' is unsupported.
STOP   | Translation is interrupted

$ uniconvertor  *dxf _111_o.plt -verbose

JOB    | Translation of "v-135.dxf" into "_111_o.plt"
INFO   | Start to search saver by file extension plt
OK     | Saver is found for extension plt
INFO   | Start to search for loader by file extension dxf
WARNING| Loader is not found or not suitable for v-135.dxf
INFO   | Start to search loader by file content
ERROR  | Loader is not found for v-135.dxf
ERROR  | Input file format of 'v-135.dxf' is unsupported.
STOP   | Translation is interrupted

And I'm not sure this bug really has an "upstream" resolution as it is not fixed there.

Comment 5 Skippy 2016-09-30 09:19:55 UTC
There was no related bug report upstream (now : https://sourceforge.net/p/uniconvertor/bugs/5/).

Furthermore it seems the source hasn't been updated since 2008-03-26.  I guess this package should be considered as obsolete.


Note You need to log in before you can comment on or make changes to this bug.