This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 112755 - (NS83820) Updated initscripts package causes kernel panic/halt when using NetGear GA621 NIC (ns83820 driver)
(NS83820) Updated initscripts package causes kernel panic/halt when using Net...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel (Show other bugs)
2.1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: David Miller
Brian Brock
:
Depends On:
Blocks: 106472 107565
  Show dependency treegraph
 
Reported: 2003-12-30 12:03 EST by Eric Sisler
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:23:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Eric Sisler 2003-12-30 12:03:54 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a)
Gecko/20021207 Phoenix/0.5

Description of problem:
The updated initscripts package from RHBA-2003:341-09 causes a kernel
panic and halt when running 'ifup eth0'.

It doesn't matter if I bring the interface up manually after boot or
configure it to come up on boot - it causes the panic/halt every time.

The network card is a NetGear GA621 Gigabit fiber card, using the
ns83820 driver.

If I leave all other packages updated (including ethtool, which is
also included in RHBA-2003:341-09) and revert to
initscripts-6.47.2-1.1, the problem goes away.

Version-Release number of selected component (if applicable):
initscripts-6.47.6-1

How reproducible:
Always

Steps to Reproduce:
1. boot the box with the updated initscripts package
2. bring the interface up with 'ifup eth0' -OR- configure the
interface to come up automatically on boot.

Additional info:
Comment 1 Bill Nottingham 2003-12-30 13:55:44 EST
What happens if you comment out the call to ethtool in /sbin/ifup?
Comment 2 Eric Sisler 2003-12-31 16:16:46 EST
Works great, less filling.  ;-)  ethtool was called/evaluated in three
places, I commented them out.  Oddly enough, if run ifdown I must
unload the module before running ifup again.  Or rather, ifup runs and
the interface appears to be up, but I have no connectivity.  I don't
know if this is because of the fiber interface or not, but it seemed
odd to me.

BTW - this server isn't in production yet, so if any official errata
RPM is forthcoming, it doesn't need to be right away - at least not
for me.

Happy New Year!
Comment 3 Bill Nottingham 2003-12-31 22:03:43 EST
Assinging to kernel, appears to be a driver bug.
Comment 5 Jeff Garzik 2004-01-12 13:37:47 EST
I am not sure I understand the response to Bill...  did commenting out
the calls to ethtool in 'ifup' fix the problem?
Comment 6 Eric Sisler 2004-01-13 09:46:49 EST
Yes, commenting out the calls to ethtool in 'ifup' fixed the problem.
 Sorry if this wasn't clear from my previous comment.  I haven't tried
ifup with ethtool enabled using the recently released 2.4.9-e.35
kernel, but I can if you like.  (I was using 2.4.9-e.34 when I
reported the problem.)
Comment 7 Tim Burke 2004-01-14 14:43:40 EST
Please retry with the new set of U1 errata which is being released
very soon.
Comment 8 Eric Sisler 2004-01-23 11:39:09 EST
Do you mean U3 errata?  The box is running RHEL ES v2.1, not v3 and
IIRC, update-2 for v2.1 has been out for some time.  BTW - I am
experiencing problems running vmware-gsx server on this box when using
the GA621/ns83820 card/driver, but if I install a somewhat older GA620
card (using the acenic driver) the problem goes away.  Let me know if
details will help.

Thanks!
Comment 9 Eric Sisler 2004-02-19 17:42:36 EST
Still experiencing the same problem with a clean install of U3 (with
or without errata updates installed).

-Eric
Comment 10 David Miller 2004-02-23 16:56:26 EST
To be honest there is nothing at all suspicious or buggy in
the ns83820 ethtool ioctl handling, in fact it is quite simple
code only handling two ethtool commands.

Can you get an OOPS log from when the bug triggers and attach
it to this report?

Thanks.
Comment 11 RHEL Product and Program Management 2007-10-19 15:23:27 EDT
This bug is filed against RHEL2.1, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products.  Since
this bug does not meet that criteria, it is now being closed.

For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/

If you feel this bug is indeed mission critical, please contact your
support representative.  You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.