Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 1127554 - sm-notify: "-v hostname" doesn't work
sm-notify: "-v hostname" doesn't work
Status: CLOSED DUPLICATE of bug 995484
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: nfs-utils (Show other bugs)
6.6
All Linux
high Severity high
: rc
: ---
Assigned To: Steve Dickson
Yongcheng Yang
: Reopened
Depends On: 995484
Blocks: 1172231 1127560
  Show dependency treegraph
 
Reported: 2014-08-07 02:23 EDT by Yin.JianHong
Modified: 2015-11-05 11:33 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 995484
: 1127560 (view as bug list)
Environment:
Last Closed: 2015-11-02 15:28:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Yin.JianHong 2014-08-07 02:32:02 EDT
Test pass in latest distro RHEL-6.6-20140716.0.
  https://beaker.engineering.redhat.com/jobs/696686
    nfs-utils(1)-M.1.1-:/commands/utils/sm-notify@RHEL-6.6-20140716.0@2014-07-17_15:05:39..    PASS

But test fail today in same distro
  https://beaker.engineering.redhat.com/jobs/714450
    [20140807_13:00] nfs-utils M.1.1 \1/commands/utils/sm-notify@RHEL-6.6-20140716.0..    FAIL

Test fail also,  in  Beta-1.1  RHEL-6.6-20140731.1
  https://beaker.engineering.redhat.com/jobs/714451
    J:714451 	[20140807_13:01] nfs-utils M.1.1 \1/commands/utils/sm-notify@RHEL-6.6-20140731.1.     FAIL


always get errro log: "Network is unreachable",(but can ping the hostname)

::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
:: [   LOG    ] :: /CoreOS/nfs-utils/commands/utils/sm-notify-server-Test:
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
{Info} wait client mount finish ...
/CoreOS/nfs-utils/commands/utils/sm-notify_client_ready
[01:13:37 root@ ~~]# flock /tmp/tfile ls -l /tmp/tfile
-rw-r--r--. 1 nfsnobody nfsnobody 0 Aug  7 01:13 /tmp/tfile
:: [   PASS   ] :: Running 'flock /tmp/tfile ls -l /tmp/tfile' (Expected 0, got 0)
--------------------------------------------------------------------------------
[01:13:37 root@ ~~]# ls /var/lib/nfs/statd/sm
ibm-z10-10.rhts.eng.bos.redhat.com
:: [   PASS   ] :: Running 'ls /var/lib/nfs/statd/sm' (Expected 0, got 0)
--------------------------------------------------------------------------------
[01:13:37 root@ ~~]# cat /var/lib/nfs/statd/state|hexdump -C
00000000  00 00 00 03                                       |....|
00000004
:: [   PASS   ] :: Running 'cat /var/lib/nfs/statd/state|hexdump -C' (Expected 0, got 0)
--------------------------------------------------------------------------------
[01:13:37 root@ ~~]# cat /proc/sys/fs/nfs/nsm_local_state
3
:: [   PASS   ] :: Running 'cat /proc/sys/fs/nfs/nsm_local_state' (Expected 0, got 0)
--------------------------------------------------------------------------------
[01:13:37 root@ ~~]# sm-notify -v ibm-z10-56.rhts.eng.bos.redhat.com -d -f
sm-notify: Version 1.2.3 starting
sm-notify: Canonical name for my_name 'ibm-z10-56.rhts.eng.bos.redhat.com': ibm-z10-56.rhts.eng.bos.redhat.com
sm-notify: Retired record for mon_name ibm-z10-10.rhts.eng.bos.redhat.com
sm-notify: Added host ibm-z10-10.rhts.eng.bos.redhat.com to notify list
sm-notify: Effective UID, GID: 29, 29
sm-notify: Sending PMAP_GETPORT for 100024, 1, udp
sm-notify: nsm_rpc_sendto: sendto failed: Network is unreachable
sm-notify: Host ibm-z10-10.rhts.eng.bos.redhat.com due in 2 seconds
sm-notify: Sending PMAP_GETPORT for 100024, 1, udp
sm-notify: nsm_rpc_sendto: sendto failed: Network is unreachable
sm-notify: Host ibm-z10-10.rhts.eng.bos.redhat.com due in 4 seconds
sm-notify: Sending PMAP_GETPORT for 100024, 1, udp
sm-notify: nsm_rpc_sendto: sendto failed: Network is unreachable
sm-notify: Host ibm-z10-10.rhts.eng.bos.redhat.com due in 8 seconds
sm-notify: Sending PMAP_GETPORT for 100024, 1, udp
sm-notify: nsm_rpc_sendto: sendto failed: Network is unreachable
sm-notify: Host ibm-z10-10.rhts.eng.bos.redhat.com due in 16 seconds
sm-notify: Sending PMAP_GETPORT for 100024, 1, udp
sm-notify: nsm_rpc_sendto: sendto failed: Network is unreachable
sm-notify: Host ibm-z10-10.rhts.eng.bos.redhat.com due in 32 seconds
sm-notify: Sending PMAP_GETPORT for 100024, 1, udp
sm-notify: nsm_rpc_sendto: sendto failed: Network is unreachable
sm-notify: Host ibm-z10-10.rhts.eng.bos.redhat.com due in 64 seconds
sm-notify: Sending PMAP_GETPORT for 100024, 1, udp
sm-notify: nsm_rpc_sendto: sendto failed: Network is unreachable
sm-notify: Host ibm-z10-10.rhts.eng.bos.redhat.com due in 120 seconds

MARK-LWD-LOOP -- 2014-08-07 01:15:44 --
sm-notify: Sending PMAP_GETPORT for 100024, 1, udp
sm-notify: nsm_rpc_sendto: sendto failed: Network is unreachable
sm-notify: Host ibm-z10-10.rhts.eng.bos.redhat.com due in 120 seconds
sm-notify: Sending PMAP_GETPORT for 100024, 1, udp
sm-notify: nsm_rpc_sendto: sendto failed: Network is unreachable
sm-notify: Host ibm-z10-10.rhts.eng.bos.redhat.com due in 120 seconds

MARK-LWD-LOOP -- 2014-08-07 01:20:43 --
sm-notify: Sending PMAP_GETPORT for 100024, 1, udp
sm-notify: nsm_rpc_sendto: sendto failed: Network is unreachable
sm-notify: Host ibm-z10-10.rhts.eng.bos.redhat.com due in 120 seconds
sm-notify: Sending PMAP_GETPORT for 100024, 1, udp
sm-notify: nsm_rpc_sendto: sendto failed: Network is unreachable
sm-notify: Host ibm-z10-10.rhts.eng.bos.redhat.com due in 120 seconds

MARK-LWD-LOOP -- 2014-08-07 01:25:44 --
sm-notify: Sending PMAP_GETPORT for 100024, 1, udp
sm-notify: nsm_rpc_sendto: sendto failed: Network is unreachable
sm-notify: Host ibm-z10-10.rhts.eng.bos.redhat.com due in 120 seconds
sm-notify: Sending PMAP_GETPORT for 100024, 1, udp
sm-notify: nsm_rpc_sendto: sendto failed: Network is unreachable
sm-notify: Host ibm-z10-10.rhts.eng.bos.redhat.com due in 120 seconds
sm-notify: Unable to notify ibm-z10-10.rhts.eng.bos.redhat.com, giving up
:: [   FAIL   ] :: Running 'sm-notify -v ibm-z10-56.rhts.eng.bos.redhat.com -d -f' (Expected 0, got 1)
Comment 3 Steve Dickson 2014-08-11 10:08:50 EDT
(In reply to Yin.JianHong from comment #1)
> Test pass in latest distro RHEL-6.6-20140716.0.
>   https://beaker.engineering.redhat.com/jobs/696686
>    
> nfs-utils(1)-M.1.1-:/commands/utils/sm-notify@RHEL-6.6-20140716.0@2014-07-
> 17_15:05:39..    PASS
> 
> But test fail today in same distro
>   https://beaker.engineering.redhat.com/jobs/714450
>     [20140807_13:00] nfs-utils M.1.1
> \1/commands/utils/sm-notify@RHEL-6.6-20140716.0..    FAIL
> 
> Test fail also,  in  Beta-1.1  RHEL-6.6-20140731.1
>   https://beaker.engineering.redhat.com/jobs/714451
>     J:714451 	[20140807_13:01] nfs-utils M.1.1
> \1/commands/utils/sm-notify@RHEL-6.6-20140731.1.     FAIL
> 
> 
> always get errro log: "Network is unreachable",(but can ping the hostname)
This is probably an a firewall issue... Please investigate why
that error is occurring...
Comment 4 Yin.JianHong 2014-08-11 23:09:29 EDT
(In reply to Steve Dickson from comment #3)
> (In reply to Yin.JianHong from comment #1)
> > Test pass in latest distro RHEL-6.6-20140716.0.
> >   https://beaker.engineering.redhat.com/jobs/696686
> >    
> > nfs-utils(1)-M.1.1-:/commands/utils/sm-notify@RHEL-6.6-20140716.0@2014-07-
> > 17_15:05:39..    PASS
> > 
> > But test fail today in same distro
> >   https://beaker.engineering.redhat.com/jobs/714450
> >     [20140807_13:00] nfs-utils M.1.1
> > \1/commands/utils/sm-notify@RHEL-6.6-20140716.0..    FAIL
> > 
> > Test fail also,  in  Beta-1.1  RHEL-6.6-20140731.1
> >   https://beaker.engineering.redhat.com/jobs/714451
> >     J:714451 	[20140807_13:01] nfs-utils M.1.1
> > \1/commands/utils/sm-notify@RHEL-6.6-20140731.1.     FAIL
> > 
> > 
> > always get errro log: "Network is unreachable",(but can ping the hostname)
> This is probably an a firewall issue... Please investigate why
> that error is occurring...

the iptables was closed in the test case,,
Comment 6 Yongcheng Yang 2015-05-07 03:17:56 EDT
Always failed with ppc64 machines

[02:47:05 root@ ~~]# ping -c 5 $SERVER
PING ibm-p720-01-lp5.rhts.eng.bos.redhat.com (10.16.67.101) 56(84) bytes of data.
64 bytes from ibm-p720-01-lp5.rhts.eng.bos.redhat.com (10.16.67.101): icmp_seq=1 ttl=64 time=0.021 ms
64 bytes from ibm-p720-01-lp5.rhts.eng.bos.redhat.com (10.16.67.101): icmp_seq=2 ttl=64 time=0.032 ms
64 bytes from ibm-p720-01-lp5.rhts.eng.bos.redhat.com (10.16.67.101): icmp_seq=3 ttl=64 time=0.025 ms
64 bytes from ibm-p720-01-lp5.rhts.eng.bos.redhat.com (10.16.67.101): icmp_seq=4 ttl=64 time=0.024 ms
64 bytes from ibm-p720-01-lp5.rhts.eng.bos.redhat.com (10.16.67.101): icmp_seq=5 ttl=64 time=0.024 ms

--- ibm-p720-01-lp5.rhts.eng.bos.redhat.com ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 3998ms
rtt min/avg/max/mdev = 0.021/0.025/0.032/0.004 ms
:: [   PASS   ] :: Running 'ping -c 5 $SERVER' (Expected 0, got 0)
--------------------------------------------------------------------------------
[02:47:09 root@ ~~]# sm-notify -v $SERVER -d -f
sm-notify: Version 1.2.3 starting
sm-notify: Canonical name for my_name 'ibm-p720-01-lp5.rhts.eng.bos.redhat.com': ibm-p720-01-lp5.rhts.eng.bos.redhat.com
sm-notify: Retired record for mon_name ibm-p740-01-lp1.rhts.eng.bos.redhat.com
sm-notify: Added host ibm-p740-01-lp1.rhts.eng.bos.redhat.com to notify list
sm-notify: Effective UID, GID: 29, 29
sm-notify: Sending PMAP_GETPORT for 100024, 1, udp
sm-notify: nsm_rpc_sendto: sendto failed: Network is unreachable
sm-notify: Host ibm-p740-01-lp1.rhts.eng.bos.redhat.com due in 2 seconds
sm-notify: Sending PMAP_GETPORT for 100024, 1, udp
sm-notify: nsm_rpc_sendto: sendto failed: Network is unreachable
sm-notify: Host ibm-p740-01-lp1.rhts.eng.bos.redhat.com due in 4 seconds
sm-notify: Sending PMAP_GETPORT for 100024, 1, udp
sm-notify: nsm_rpc_sendto: sendto failed: Network is unreachable
sm-notify: Host ibm-p740-01-lp1.rhts.eng.bos.redhat.com due in 8 seconds
sm-notify: Sending PMAP_GETPORT for 100024, 1, udp
sm-notify: nsm_rpc_sendto: sendto failed: Network is unreachable
sm-notify: Host ibm-p740-01-lp1.rhts.eng.bos.redhat.com due in 16 seconds
sm-notify: Sending PMAP_GETPORT for 100024, 1, udp
sm-notify: nsm_rpc_sendto: sendto failed: Network is unreachable
sm-notify: Host ibm-p740-01-lp1.rhts.eng.bos.redhat.com due in 32 seconds
sm-notify: Sending PMAP_GETPORT for 100024, 1, udp
sm-notify: nsm_rpc_sendto: sendto failed: Network is unreachable
sm-notify: Host ibm-p740-01-lp1.rhts.eng.bos.redhat.com due in 64 seconds
sm-notify: Sending PMAP_GETPORT for 100024, 1, udp
sm-notify: nsm_rpc_sendto: sendto failed: Network is unreachable
sm-notify: Host ibm-p740-01-lp1.rhts.eng.bos.redhat.com due in 120 seconds
sm-notify: Sending PMAP_GETPORT for 100024, 1, udp
sm-notify: nsm_rpc_sendto: sendto failed: Network is unreachable
sm-notify: Host ibm-p740-01-lp1.rhts.eng.bos.redhat.com due in 120 seconds
sm-notify: Sending PMAP_GETPORT for 100024, 1, udp
sm-notify: nsm_rpc_sendto: sendto failed: Network is unreachable
sm-notify: Host ibm-p740-01-lp1.rhts.eng.bos.redhat.com due in 120 seconds
sm-notify: Sending PMAP_GETPORT for 100024, 1, udp
sm-notify: nsm_rpc_sendto: sendto failed: Network is unreachable
sm-notify: Host ibm-p740-01-lp1.rhts.eng.bos.redhat.com due in 120 seconds
sm-notify: Sending PMAP_GETPORT for 100024, 1, udp
sm-notify: nsm_rpc_sendto: sendto failed: Network is unreachable
sm-notify: Host ibm-p740-01-lp1.rhts.eng.bos.redhat.com due in 120 seconds
sm-notify: Sending PMAP_GETPORT for 100024, 1, udp
sm-notify: nsm_rpc_sendto: sendto failed: Network is unreachable
sm-notify: Host ibm-p740-01-lp1.rhts.eng.bos.redhat.com due in 120 seconds
sm-notify: Sending PMAP_GETPORT for 100024, 1, udp
sm-notify: nsm_rpc_sendto: sendto failed: Network is unreachable
sm-notify: Host ibm-p740-01-lp1.rhts.eng.bos.redhat.com due in 120 seconds
sm-notify: Unable to notify ibm-p740-01-lp1.rhts.eng.bos.redhat.com, giving up
:: [   FAIL   ] :: Running 'sm-notify -v $SERVER -d -f' (Expected 0, got 1)

Additional Info:
https://beaker.engineering.redhat.com/jobs/949984

The same test can success with RHEL-6 in x86_64 machines, but failed with RHEL-7 on both x86_64 and ppc64
Comment 10 Steve Dickson 2015-10-21 17:28:21 EDT
(In reply to Yongcheng Yang from comment #6)
> Always failed with ppc64 machines
> 
> [02:47:05 root@ ~~]# ping -c 5 $SERVER
> PING ibm-p720-01-lp5.rhts.eng.bos.redhat.com (10.16.67.101) 56(84) bytes of
> data.
> 64 bytes from ibm-p720-01-lp5.rhts.eng.bos.redhat.com (10.16.67.101):
> icmp_seq=1 ttl=64 time=0.021 ms
> 64 bytes from ibm-p720-01-lp5.rhts.eng.bos.redhat.com (10.16.67.101):
> icmp_seq=2 ttl=64 time=0.032 ms
> 64 bytes from ibm-p720-01-lp5.rhts.eng.bos.redhat.com (10.16.67.101):
> icmp_seq=3 ttl=64 time=0.025 ms
> 64 bytes from ibm-p720-01-lp5.rhts.eng.bos.redhat.com (10.16.67.101):
> icmp_seq=4 ttl=64 time=0.024 ms
> 64 bytes from ibm-p720-01-lp5.rhts.eng.bos.redhat.com (10.16.67.101):
> icmp_seq=5 ttl=64 time=0.024 ms
> 
> --- ibm-p720-01-lp5.rhts.eng.bos.redhat.com ping statistics ---
> 5 packets transmitted, 5 received, 0% packet loss, time 3998ms
> rtt min/avg/max/mdev = 0.021/0.025/0.032/0.004 ms
> :: [   PASS   ] :: Running 'ping -c 5 $SERVER' (Expected 0, got 0)
> -----------------------------------------------------------------------------
> ---
> [02:47:09 root@ ~~]# sm-notify -v $SERVER -d -f
> sm-notify: Version 1.2.3 starting
> sm-notify: Canonical name for my_name
> 'ibm-p720-01-lp5.rhts.eng.bos.redhat.com':
> ibm-p720-01-lp5.rhts.eng.bos.redhat.com
> sm-notify: Retired record for mon_name
> ibm-p740-01-lp1.rhts.eng.bos.redhat.com
> sm-notify: Added host ibm-p740-01-lp1.rhts.eng.bos.redhat.com to notify list
> sm-notify: Effective UID, GID: 29, 29
> sm-notify: Sending PMAP_GETPORT for 100024, 1, udp
> sm-notify: nsm_rpc_sendto: sendto failed: Network is unreachable
This looks to me as a firewall issue....
Comment 11 Steve Dickson 2015-11-02 15:28:02 EST

*** This bug has been marked as a duplicate of bug 995484 ***
Comment 12 Tom Coughlan 2015-11-05 11:33:33 EST
Removing from the 68FileAndStorageRPL.

Note You need to log in before you can comment on or make changes to this bug.