Bug 1127560 - sm-notify: "-v hostname" doesn't work [RHEL-7]
sm-notify: "-v hostname" doesn't work [RHEL-7]
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: nfs-utils (Show other bugs)
7.1
All Linux
high Severity high
: rc
: ---
Assigned To: Steve Dickson
Yongcheng Yang
: Reopened
Depends On: 995484 1127554
Blocks:
  Show dependency treegraph
 
Reported: 2014-08-07 03:10 EDT by Yin.JianHong
Modified: 2015-06-11 10:34 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1127554
Environment:
Last Closed: 2015-06-11 10:34:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Yin.JianHong 2014-08-07 03:14:08 EDT
Test in RHEL-7 also FAIL;

https://beaker.engineering.redhat.com/jobs/714441
J:714441 	[20140807_12:31] nfs-utils M.1.1 \1/commands/utils/sm-notify@RHEL-7.0-20140507.0.. -    FAIL

-----------------
same err msg:
...
MARK-LWD-LOOP -- 2014-08-07 00:53:28 --
sm-notify: Sending PMAP_GETPORT for 100024, 1, udp
sm-notify: nsm_rpc_sendto: sendto failed: Network is unreachable
sm-notify: Added host ibm-z10-29.rhts.eng.bos.redhat.com to notify list
sm-notify: Host ibm-z10-29.rhts.eng.bos.redhat.com due in 120 seconds
sm-notify: Sending PMAP_GETPORT for 100024, 1, udp
sm-notify: nsm_rpc_sendto: sendto failed: Network is unreachable
sm-notify: Added host ibm-z10-29.rhts.eng.bos.redhat.com to notify list
sm-notify: Host ibm-z10-29.rhts.eng.bos.redhat.com due in 120 seconds
sm-notify: Unable to notify ibm-z10-29.rhts.eng.bos.redhat.com, giving up
:: [   FAIL   ] :: Running 'sm-notify -v ibm-z10-69.rhts.eng.bos.redhat.com -d -f' (Expected 0, got 1)
------------------
Comment 3 Steve Dickson 2014-09-17 13:23:05 EDT
commit 37add3662de0339a75d3bed86a4235fc7efaf18d
Author: Chuck Lever <chuck.lever@oracle.com>
Date:   Fri Apr 19 13:13:57 2013 -0400

    sm-notify: "-v hostname" doesn't work when IPV6_SUPPORT is enabled
Comment 4 Yongcheng Yang 2015-05-07 03:11:32 EDT
Still failed with latest RHEL-7, and maybe it's a different issue of comment #3

MARK-LWD-LOOP -- 2015-05-07 02:34:06 --
sm-notify: Sending PMAP_GETPORT for 100024, 1, udp
sm-notify: nsm_rpc_sendto: sendto failed: Network is unreachable
sm-notify: Added host hp-dl380pgen8-02-vm-12.lab.bos.redhat.com to notify list
sm-notify: Host hp-dl380pgen8-02-vm-12.lab.bos.redhat.com due in 120 seconds
sm-notify: Sending PMAP_GETPORT for 100024, 1, udp
sm-notify: nsm_rpc_sendto: sendto failed: Network is unreachable
sm-notify: Added host hp-dl380pgen8-02-vm-12.lab.bos.redhat.com to notify list
sm-notify: Host hp-dl380pgen8-02-vm-12.lab.bos.redhat.com due in 120 seconds

MARK-LWD-LOOP -- 2015-05-07 02:39:05 --
sm-notify: Unable to notify hp-dl380pgen8-02-vm-12.lab.bos.redhat.com, giving up
:: [   FAIL   ] :: Running 'sm-notify -v $SERVER -d -f' (Expected 0, got 1)



Additional Info:
The test failed on both ppc64 and x86_64 machines:
https://beaker.engineering.redhat.com/jobs/949935
https://beaker.engineering.redhat.com/jobs/949936

But the same test on x86_64 with RHEL-6 can pass, on ppc64 with RHEL-6 always fail
Comment 5 Steve Dickson 2015-06-11 10:34:00 EDT
(In reply to Yongcheng Yang from comment #4)
> Still failed with latest RHEL-7, and maybe it's a different issue of comment
> #3
> 
> MARK-LWD-LOOP -- 2015-05-07 02:34:06 --
> sm-notify: Sending PMAP_GETPORT for 100024, 1, udp
> sm-notify: nsm_rpc_sendto: sendto failed: Network is unreachable
> sm-notify: Added host hp-dl380pgen8-02-vm-12.lab.bos.redhat.com to notify
> list
> sm-notify: Host hp-dl380pgen8-02-vm-12.lab.bos.redhat.com due in 120 seconds
> sm-notify: Sending PMAP_GETPORT for 100024, 1, udp
> sm-notify: nsm_rpc_sendto: sendto failed: Network is unreachable
This looks like more of a network problem than an sm-notify problem.

> sm-notify: Added host hp-dl380pgen8-02-vm-12.lab.bos.redhat.com to notify
> list
> sm-notify: Host hp-dl380pgen8-02-vm-12.lab.bos.redhat.com due in 120 seconds
Since the debug output shows the correct host, we know the -v
argument is working.
 
> 
> MARK-LWD-LOOP -- 2015-05-07 02:39:05 --
> sm-notify: Unable to notify hp-dl380pgen8-02-vm-12.lab.bos.redhat.com,
> giving up
> :: [   FAIL   ] :: Running 'sm-notify -v $SERVER -d -f' (Expected 0, got 1)
It appears the reason this is failing is not because there 
is something wrong with the -v argument, its because the host
your trying to notify is on a unreachable network.

Note You need to log in before you can comment on or make changes to this bug.