Bug 1127604 - [RFE] Host/Hostgroup provisioning template relation too complex and inconsistent with other provisioning settings
Summary: [RFE] Host/Hostgroup provisioning template relation too complex and inconsist...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning Templates
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks: 1122832
TreeView+ depends on / blocked
 
Reported: 2014-08-07 08:46 UTC by Peter Vreman
Modified: 2019-08-12 14:02 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-04 19:08:54 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 23877 None None None 2018-06-11 10:28:18 UTC

Description Peter Vreman 2014-08-07 08:46:46 UTC
Description of problem:
Defining which Provisioning template will be used for a hostgroup or host is not possible directly from the host/hostgroup part. This is also inconsistent with the other provisioning settings like OS and Partition table.

Currently the template association with hostgroup is only visible in the second tab of the provisioning templates menu. Also this association is has a redundant element because a hostgroup can have only 1 environment being set.

Proposal is to define the provisioning template in the host/hostgroup provisioning tab.  With the default being populated after selecting the OS.
This makes it also consistent with selecting the provisioning template like it is on the OS configuration. Although that also does not seem to be working always.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:
Provisioning template can be defined per host or hostgroup

Additional info:

Comment 1 RHEL Product and Program Management 2014-08-07 09:13:50 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 4 Og Maciel 2017-04-17 18:37:36 UTC
This is an older bug which I do not envision being addressed in the near term. I am closing this out. If you believe doing so is an issue, please feel free to re-open and provide additional business information. Thank you.

Comment 5 Christian Marineau 2018-02-09 17:22:17 UTC
I am re-opening this bug because the fact that Kickstart Templates are only tied at the Operating System level and can't be override at the Host Group Level forces the user to create advanced logical OR custom Operating System to be able to use different Kickstart Templates for different situation.

By Example they might have to create an Operating system for different kind of role:
  RedHat 7.4
  RedHat_Web 7.4
  RedHat_DB 7.4

Also, this leads into a situation where their provisioned hosts using these custom Operating System are no longer tied with the proper Operating System after the provisioning. So the user need to follow this KCS/BZ:
  https://access.redhat.com/solutions/3189362
  https://bugzilla.redhat.com/show_bug.cgi?id=1429033

Thanks

-Christian

Comment 8 Ondřej Pražák 2018-06-11 10:28:15 UTC
Created redmine issue http://projects.theforeman.org/issues/23877 from this bug

Comment 9 Bryan Kearney 2018-09-04 18:57:46 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and we do not expect this to be implemented in the product in the foreseeable future. We are therefore closing this out as WONTFIX. If you have any concerns about this, please feel free to contact Rich Jerrido or Bryan Kearney. Thank you.

Comment 10 Bryan Kearney 2018-09-04 19:08:54 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and we do not expect this to be implemented in the product in the foreseeable future. We are therefore closing this out as WONTFIX. If you have any concerns about this, please feel free to contact Rich Jerrido or Bryan Kearney. Thank you.


Note You need to log in before you can comment on or make changes to this bug.