Bug 1127666 - Folks has unsatisfied dependencies after evolution-data-server bump
Summary: Folks has unsatisfied dependencies after evolution-data-server bump
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: folks
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Brian Pepple
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1127850 1128348 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-07 10:20 UTC by Vadim Rutkovsky
Modified: 2014-08-11 21:35 UTC (History)
6 users (show)

Fixed In Version: folks-0.9.7.1-4.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-11 21:35:48 UTC


Attachments (Terms of Use)
include dummy backend and fix build (1.53 KB, patch)
2014-08-11 08:55 UTC, David King
no flags Details | Diff

Description Vadim Rutkovsky 2014-08-07 10:20:58 UTC
Description of problem:
Folks fails to install in latest  rawhide

Version-Release number of selected component (if applicable):
folks-0.9.6-5.fc21.x86_64

How reproducible:
Always

Steps to Reproduce:
1. yum install @desktop

Actual results:
Error: Package: 1:folks-0.9.6-5.fc21.x86_64 (fedora-rawhide)
    Requires: libebackend-1.2.so.7()(64bit)
Error: Package: 1:folks-0.9.6-5.fc21.x86_64 (fedora-rawhide)
    Requires: libebook-1.2.so.14()(64bit)
Error: Package: 1:folks-0.9.6-5.fc21.x86_64 (fedora-rawhide)
    Requires: libcamel-1.2.so.49()(64bit)
Error: Package: 1:folks-0.9.6-5.fc21.x86_64 (fedora-rawhide)
    Requires: libedataserver-1.2.so.18()(64bit)
Error: Package: 1:folks-0.9.6-5.fc21.x86_64 (fedora-rawhide)
    Requires: libedata-book-1.2.so.20()(64bit)

Comment 1 Philip Withnall 2014-08-07 16:59:50 UTC
*** Bug 1127850 has been marked as a duplicate of this bug. ***

Comment 2 Philip Withnall 2014-08-09 11:04:35 UTC
*** Bug 1128348 has been marked as a duplicate of this bug. ***

Comment 3 David King 2014-08-11 08:53:41 UTC
Zeitgeist first needed to be built with a fix for its VAPI file (which I reported in bug 1126461). Now, the folks package needs to be updated to include the new dummy backend.

Comment 4 David King 2014-08-11 08:55:08 UTC
Created attachment 925649 [details]
include dummy backend and fix build

Scratch build including the patch: http://koji.fedoraproject.org/koji/taskinfo?taskID=7271807

Comment 5 David King 2014-08-11 21:35:48 UTC
This was fixed in F21 and Rawhide with 0.9.7.1-4.


Note You need to log in before you can comment on or make changes to this bug.