Bug 1127707 - deleting a deployment doesn't delete its hostgroups
Summary: deleting a deployment doesn't delete its hostgroups
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rubygem-staypuft
Version: 5.0 (RHEL 7)
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: z1
: Installer
Assignee: Scott Seago
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-07 11:36 UTC by Ami Jeain
Modified: 2014-09-02 13:13 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-02 13:13:14 UTC


Attachments (Terms of Use)

Description Ami Jeain 2014-08-07 11:36:23 UTC
Description of problem:


Version-Release number of selected component (if applicable):
ruby193-rubygem-staypuft-0.1.22-1.el6ost.noarch

How reproducible:


Steps to Reproduce:
1. have a deployment setup properly
2. create a new deployment
3. delete the first created deployment
4. now, if you go and assign hosts to hostgroups, you will see the old hostgroups which were created as a result of the first deployment, which are invalid anymore

Actual results:

host groups should be deleted after the deployment has been deleted
Expected results:


Additional info:

Comment 1 Scott Seago 2014-08-13 18:23:18 UTC
Ok I have 2 questions:

1) were you trying to add hosts on the Staypuft "assign hosts" view (in that case you're starting from the list of hostgroups currently visible for the deployment, so I'm not sure how you're seeing the old ones); If you're going to the foreman hosts UI to assign a hostgroup, please don't do that -- that misses several required actions (and validation bits) -- in particular, a host added that way will appear to staypuft as "already deployed". I think there's a separate BZ to disable hostgroup assignment from the host edit page.

2) Can you re-try this with the latest build? There was a bug where changing the layout after assigning hosts sometimes resulted in hostgroups that didn't get properly deleted. 

If this is still repeatable with the latest build, can you be a bit more clear on the steps to reproduce? Are hosts assigned to the deployment you're deleting, etc? -- the reason I'm asking for that is we've deleted deployments many times, and this sort of thing doesn't generally happen, so it may be tricky to reproduce and/or an edge case of some sort.

Comment 2 Ami Jeain 2014-09-02 12:58:04 UTC
OK, I was finally able to try it on the latest puddle, and it seems it is fixed (yeahhhhh).
Bug can be closed...

Comment 3 Mike Burns 2014-09-02 13:13:14 UTC
closing per comment 2


Note You need to log in before you can comment on or make changes to this bug.