Bug 1127743 - Yum update broken by RHS-C
Summary: Yum update broken by RHS-C
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc
Version: rhgs-3.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: RHGS 3.0.0
Assignee: Shubhendu Tripathi
QA Contact: Prasanth
URL:
Whiteboard:
Depends On: 1093824
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-07 13:00 UTC by Shubhendu Tripathi
Modified: 2015-05-13 16:58 UTC (History)
8 users (show)

Fixed In Version: rhsc-3.0.0-0.13.el6rhs
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-22 19:11:52 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2014:1277 normal SHIPPED_LIVE Red Hat Storage Console 3.0 enhancement and bug fix update 2014-09-22 23:06:30 UTC

Description Shubhendu Tripathi 2014-08-07 13:00:17 UTC
Description of problem:
Yum update broken by RHS-C

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Shubhendu Tripathi 2014-08-08 07:22:44 UTC
This issue is happens because rhsc is version locked and redhat-access-plugin is not version locked. So during yum update, as the higher version of redhat-access-plugin requires higher version of rhsc it fails for update (the rhsc is version locked so cannot be updated).

If both the packages are version locked so they cannot be updated as part of yum update and no issues.

Comment 3 Shubhendu Tripathi 2014-08-11 11:57:42 UTC
Explicitly adding redhat-access-plugin-rhsc to the version lock and this resolves the issue.

Comment 4 Prasanth 2014-08-28 18:03:37 UTC
Verified in rhsc-3.0.0-0.13.el6rhs

---------
# yum versionlock list
Loaded plugins: product-id, rhnplugin, security, subscription-manager, versionlock
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
This system is receiving updates from RHN Classic or RHN Satellite.
rhsc-3.0.0-0.13.el6rhs.noarch
rhsc-backend-3.0.0-0.13.el6rhs.noarch
rhsc-dbscripts-3.0.0-0.13.el6rhs.noarch
rhsc-restapi-3.0.0-0.13.el6rhs.noarch
rhsc-tools-3.0.0-0.13.el6rhs.noarch
rhsc-webadmin-portal-3.0.0-0.13.el6rhs.noarch
redhat-access-plugin-rhsc-3.0.0-1.el6rhs.noarch
versionlock list done
---------

Comment 5 errata-xmlrpc 2014-09-22 19:11:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-1277.html


Note You need to log in before you can comment on or make changes to this bug.