Bug 1127806 - apply ntp-server from the installer to the configuration
Summary: apply ntp-server from the installer to the configuration
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhel-osp-installer
Version: 5.0 (RHEL 7)
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: z1
: Installer
Assignee: Marek Hulan
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-07 15:21 UTC by Mike Burns
Modified: 2014-10-01 13:26 UTC (History)
4 users (show)

Fixed In Version: rhel-osp-installer-0.3.4-2.el6ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-01 13:26:12 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1350 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Bug Fix Advisory 2014-10-01 17:22:34 UTC

Description Mike Burns 2014-08-07 15:21:28 UTC
Description of problem:
The default kickstart reads ntp-server from the environment.  This should be applied from the installer.  We already ask for the ntp server so it's just a configuration step.

Version-Release number of selected component (if applicable):
0.1.6

How reproducible:
always

Comment 7 Alexander Chuzhoy 2014-09-15 17:45:48 UTC
Failed-qa: rhel-osp-installer-0.3.4-3.el6ost.noarch


I see no reference to clock.redhat.com (nor the resolved IP) in ntp.conf on any of the deployed servers.

Comment 8 Marek Hulan 2014-09-16 09:19:14 UTC
Assigning back to QA, the subject of this BZ was not about configuring ntp.conf but to use configured NTP server during provisioning. It's part of %post task in KS template. You can verify it by looking at generated KS template, search for /usr/sbin/ntpdate.

Comment 9 Alexander Chuzhoy 2014-09-16 14:39:40 UTC
Verified: rhel-osp-installer-0.3.4-3.el6ost.noarch


As per comment #8, checked the anaconda file on the deployed machine - there's a line:

/usr/sbin/ntpdate -sub clock.redhat.com

Comment 11 errata-xmlrpc 2014-10-01 13:26:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1350.html


Note You need to log in before you can comment on or make changes to this bug.