Bug 1127867 - [RFE] Need Pacemaker to control the Mon service on the Controller Nodes, right now Mon would be managed by Systemd, not by Pacemaker
Summary: [RFE] Need Pacemaker to control the Mon service on the Controller Nodes, righ...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: ceph
Version: 5.0 (RHEL 7)
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: 5.0 (RHEL 7)
Assignee: Samuel Just
QA Contact: Warren
URL:
Whiteboard:
Depends On:
Blocks: 1122184
TreeView+ depends on / blocked
 
Reported: 2014-08-07 17:53 UTC by arkady kanevsky
Modified: 2016-08-08 13:17 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-20 08:41:07 UTC


Attachments (Terms of Use)

Description arkady kanevsky 2014-08-07 17:53:40 UTC
Description of problem:
Need Pacemaker to control the Mon service on the Controller Nodes, right now Mon would be managed by Systemd, not by Pacemaker

Version-Release number of selected component (if applicable):
N/A

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Keith Schincke 2014-08-07 21:24:03 UTC
Is the goal to have pacemaker start/restart ceph mon on one node or have the service and IP fail over between nodes?

Comment 3 Federico Lucifredi 2016-07-13 20:37:42 UTC
Hi Arkady,
  Ok to close this, or is this still relevant? I am missing the background on why this was desired.

Comment 4 Andrew Beekhof 2016-07-14 23:31:05 UTC
This bug has just now been brought to my attention.

Are we talking about https://sourceforge.net/projects/mon/ ?
Or ceph-mon Keith thought?
Or something else entirely?

Comment 5 seb 2016-07-19 13:44:21 UTC
Andrew, we are discussing the ceph-mon process from the Ceph project.
This daemon currently runs on the Cloud controllers.

Not sure if this feature is still desired by the Ceph engineering team since we are usually not running Pacemaker on the nodes running Ceph Monitors.
There is no failover mechanism that should be configured for this service. So this will just be a clone in Pacemaker.

I don't think it hurts though to have ceph-mon managed by Pacemaker, where Pacemaker will "simply" act as a watchdog.
We have this process managed by systemd in Red Hat Ceph Storage 2.0. Systemd already knows how to watchdog a process so I think we should just close this one.

Comment 6 Andrew Beekhof 2016-07-19 23:36:04 UTC
On balance, I don't think it makes sense to add it to the (Pacemaker) cluster given that the direction for OSP10 is to drop all the openstack clones out from the cluster and use systemd to watchdog them instead.

If it was an active/passive resource, that might be different.

Comment 7 seb 2016-07-20 08:40:37 UTC
Ok great, so since with have all the necessary unit files for that, I think we can close this one.
Thanks for the prompt reply Andrew.

Comment 8 arkady kanevsky 2016-08-08 13:17:40 UTC
As long as it properly handles upgrade & update I am fine.


Note You need to log in before you can comment on or make changes to this bug.