Bug 112789 - man hangs session!
man hangs session!
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: man (Show other bugs)
1
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-31 17:27 EST by Fred Shaul
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-05 15:56:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fred Shaul 2003-12-31 17:27:55 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. man ls
2. [ hit space a few time ] 
3. Bang!  session hangs
  
Actual results:

may see some strange characters on screen at point of hang

Expected results:

should just work!

Additional info:

# uname -a
Linux neo.scalix.local 2.4.22-1.2135.nptl #1
Mon Dec 15 15:46:09 EST 2003 i586 i586 i386 GNU/Linux

# rpm -qa
kernel-2.4.22-1.2135.nptl
setup-2.5.27-1.1
tzdata-2003d-1
bzip2-libs-1.0.2-10
elfutils-libelf-0.89-2
glib-1.2.10-11
libattr-2.4.1-2
gmp-4.1.2-9
mktemp-1.5.1-1
lvm-1.0.3-13
less-378-11.1
psmisc-21.3-2.RHEL.0
shadow-utils-4.0.3-12
hotplug-2003_08_05-1
file-4.02-2
ed-0.2-34
gzip-1.3.3-11
rhpl-0.121-1
pam-0.77-15
SysVinit-2.85-5
vim-common-6.2.121-1
cyrus-sasl-2.1.15-6
libuser-0.51.7-2
kbd-1.08-11
rmt-0.4b34-1
dosfstools-2.8-11
hesiod-3.0.2-27
attr-2.4.1-2
mailx-8.1.1-31.1
mt-st-0.7-12.1
pax-3.0-7
fbset-2.1-14
rdate-1.3-3
lockdev-1.0.1-1.3
slocate-2.6-10
talk-0.17-21
traceroute-1.4a12-20.1
zip-2.3-18
libgcj-3.3.2-1
man-1.5k-12
nano-1.2.1-3
pam_krb5-2.0.4-1
python-optik-1.4.1-1
stunnel-4.04-6
tcsh-6.12-5
acpid-1.0.2-5
dhclient-3.0pl2-6.16
libpcap-0.7.2-7.1
nss_ldap-207-3
pciutils-2.1.10-8
redhat-config-securitylevel-tui-1.2.11-1
up2date-4.1.16-1
wvdial-1.53-12
slrn-0.9.7.4-10
apr-0.9.4-2
freetype-2.1.4-5
hwcrypto-1.0-14
mod_python-3.0.3-3
php-ldap-4.3.3-6
webalizer-2.01_10-14
htmlview-2.0.0-11
perl-DateManip-5.40-30
perl-URI-1.21-7
perl-XML-Dumper-0.4-25
psutils-1.17-20
m4-1.4.1-14
ttfprint-0.9-10
XFree86-font-utils-4.3.0-42
XFree86-truetype-fonts-4.3.0-42
hpijs-1.4-11
gnome-mime-data-2.4.0-2
linc-1.0.3-2
libbonobo-2.4.0-1
GConf2-2.4.0-1
pygtk2-2.0.0-1
startup-notification-0.5-2
fam-2.6.8-12
libgnome-2.4.0-1
gnome-python2-2.0.0-2
libogg-1.0-5
comps-extras-9.0.3-2
authconfig-gtk-4.3.8-1
redhat-config-users-1.2.4-1
gdk-pixbuf-0.22.0-3.0
cdrecord-2.01-0.a19.2
mkisofs-2.01-0.a19.2
intltool-0.27.2-1
cpp-3.3.2-1
mikmod-3.1.6-23
openjade-1.3.2-8
libungif-4.1.0-16
emacs-21.3-7
arts-1.1.4-3
XFree86-75dpi-fonts-4.3.0-42
gnome-panel-2.4.0-3
librsvg2-2.4.0-3
xinitrc-3.35-1
gpdf-0.110-1
docbook-dtds-1.0-22.1
firstboot-1.2.4-1
XFree86-twm-4.3.0-42
oaf-0.6.10-8
nautilus-2.4.0-7
libgtop2-2.0.3-1
gtk2-engines-2.2.0-3
gnome-system-monitor-2.4.0-1
libgail-gnome-1.0.2-2
libgnomeprintui-1.116.0-5
gnome-applets-2.4.1-1
gthumb-2.0.2-1
printman-0.0.1-1.20021202.15
gnome-vfs-1.0.5-15
switchdesk-gnome-3.9.8-18
byacc-1.9-26
hesiod-devel-3.0.2-27
libgnat-3.3.2-1
db4-devel-4.1.25-14
libvorbis-devel-1.0-8
dialog-0.9b-20031002.1
pkgconfig-0.14.0-6
splint-3.1.1-2
automake-1.7.8-1
e2fsprogs-devel-1.34-1
gmp-devel-4.1.2-9
libgcj-devel-3.3.2-1
curl-devel-7.10.6-7
rpm-build-4.2.1-0.30
newt-devel-0.51.6-1
glibc-kernheaders-2.4-8.36
gcc-c++-3.3.2-1
openldap-devel-2.1.22-8
zlib-devel-1.2.0.7-2
gpg-pubkey-db42a60e-37ea5438
bash-2.05b-34
sed-4.0.8-2
lftp-2.6.10-1
redhat-config-packages-1.2.7-1
strace-4.5.1-1
fedora-logos-1.1.20-1
libgcc-3.3.2-1
filesystem-2.2.1-5
termcap-11.0.1-17
beecrypt-3.0.1-0.20030630.1
chkconfig-1.3.9-1
e2fsprogs-1.34-1
ethtool-1.8-2.1
gdbm-1.8.0-21
glib2-2.2.3-1.1
iputils-20020927-9.1
libacl-2.2.7-2
db4-4.1.25-14
libtermcap-2.0.8-36
mingetty-1.06-2
iproute-2.4.7-11
MAKEDEV-3.3.8-2
ncurses-5.3-9
net-tools-1.60-20.1
popt-1.8.1-0.30
raidtools-1.00.3-6
setserial-2.17-13
slang-1.4.5-18.1
usbutils-0.11-2.1
words-2-21
zlib-1.2.0.7-2
info-4.5-2
diffutils-2.8.1-9
findutils-4.1.7-17
gpm-1.20.1-38
coreutils-5.0-24
grub-0.93-7
krb5-libs-1.3.1-6
openssl-0.9.7a-23
readline-4.3-7
pyxf86config-0.3.12-1
rpm-4.2.1-0.30
dev-3.3.8-2
authconfig-4.3.8-1
sysklogd-1.4.1-13
tar-1.13.25-12
util-linux-2.11y-29
vim-minimal-6.2.121-1
cyrus-sasl-md5-2.1.15-6
openldap-2.1.22-8
passwd-0.68-4
usermode-1.69-1
redhat-config-mouse-1.1.2-1
man-pages-1.60-4
dump-0.4b34-1
dos2unix-3.1-16
eject-2.0.13-3
finger-0.17-18.1
jfsutils-1.1.3-1
lha-1.14i-12
acl-2.2.7-2
lsof-4.68-1
bzip2-1.0.2-10
anacron-2.3-29
mtr-0.52-3
parted-1.6.3-31
perl-5.8.1-92
aspell-en-0.51-6
perl-Filter-1.29-8
procmail-3.22-11
rdist-6.1.5-30.1
rsh-0.17-19
run-2.0-3
setarch-1.0-1
netconfig-0.8.19-2
setuptool-1.13-2
star-1.5a18-2
symlinks-1.2-20
tcp_wrappers-7.6-34.as21.1
tmpwatch-2.9.0-2
unix2dos-2.2-20
wireless-tools-26-1
at-3.1.8-46.1
jwhois-3.2.2-1.1
libxml2-2.5.11-1
make-3.79.1-18
minicom-2.00.0-17
mtools-3.9.9-4
libwvstreams-3.70-12
pinfo-0.6.7-2
ftp-0.17-18
gettext-0.12.1-1
pyOpenSSL-0.5.1-11
rhnlib-1.4-1
ppp-2.4.1-15
sudo-1.6.7p5-2
mkbootdisk-1.5.1-1
time-1.7-22
wget-1.8.2-15.3
apmd-3.0.2-20
devlabel-0.42.05-2
iptables-1.2.8-13
kernel-utils-2.4-9.1.101.fedora
isdn4k-utils-3.2-5.p1
openssh-3.6.1p2-19
openssh-server-3.6.1p2-19
portmap-4.0-57
quota-3.06-11
rp-pppoe-3.5-8
tcpdump-3.7.2-7.1
redhat-config-network-tui-1.3.10-1
vixie-cron-3.0.1-76
ypbind-1.12-3
yum-2.0.4-2
fetchmail-6.2.0-8
httpd-manual-2.0.47-10
libjpeg-6b-29
XFree86-libs-data-4.3.0-42
fontconfig-2.2.1-6.1
curl-7.10.6-7
apr-util-0.9.4-2
mod_perl-1.99_09-10
mod_ssl-2.0.47-10
php-imap-4.3.3-6
squid-2.5.STABLE3-0
gd-2.0.15-1
XFree86-Mesa-libGL-4.3.0-42
cups-libs-1.1.19-13
redhat-menus-0.40-1
dbus-glib-0.13-6
mpage-2.5.3-6
enscript-1.6.1-25
perl-HTML-Tagset-3.03-28
perl-Parse-Yapp-1.05-30
perl-libwww-perl-5.65-6
perl-libxml-perl-0.07-28
perl-XML-Encoding-1.01-23
pnm2ppa-1.04-8
ghostscript-fonts-5.50-9
libxslt-1.0.33-2
alchemist-1.0.27-3
4Suite-1.0-0.0.a3
ttmkfdir-3.0.9-7
Omni-foomatic-0.9.0-4
XFree86-xfs-4.3.0-42
urw-fonts-2.1-5.1
VFlib2-2.25.6-18
gimp-print-4.2.5-2
xinetd-2.3.12-4.10.0
atk-1.4.0-1
libIDL-0.8.2-1
audiofile-0.2.3-7
ORBit2-2.8.2-1
pyorbit-2.0.0-1
gtk2-2.2.4-5.1
libglade2-2.0.1-5.1
gail-1.4.0-1
gnome-python2-canvas-2.0.0-2
redhat-config-securitylevel-1.2.11-1
libwnck-2.4.0.1-1
XFree86-xauth-4.3.0-42
gnome-vfs2-2.4.1-1
gnome-python2-gtkhtml2-2.0.0-2
libbonoboui-2.4.0-1
libgnomeui-2.4.0.1-1
libcap-1.10-16
libvorbis-1.0-8
libxml-1.8.17-9
ntp-4.1.2-5
redhat-config-keyboard-1.1.5-2
redhat-config-language-1.0.16-1
redhat-config-soundcard-1.0.8-2
redhat-logviewer-0.9.3-6
gtk+-1.2.10-28.1
desktop-backgrounds-extra-2.0-18
libghttp-1.0.9-8
libusb-0.1.7-3
bitstream-vera-fonts-1.10-2
patch-2.5.4-18
desktop-file-utils-0.3-9
bitmap-fonts-0.3-2
libmng-1.0.4-4
gstreamer-0.6.3-1
ORBit-0.5.17-10.3
sgml-common-0.6.3-14
switchdesk-3.9.8-18
Glide3-20010520-25
openssh-askpass-3.6.1p2-19
SDL-1.2.5-9
vte-0.11.10-4
Xaw3d-1.5-19
emacs-leim-21.3-7
qt-3.1.2-14
redhat-artwork-0.88-1
XFree86-100dpi-fonts-4.3.0-42
XFree86-base-fonts-4.3.0-42
gnome-desktop-2.4.0-1
gnome-pilot-2.0.10-4
libgsf-1.8.2-1
eel2-2.4.0-1
XFree86-4.3.0-42
libgnomeprintui22-2.4.0-1
XFree86-tools-4.3.0-42
xml-common-0.6.3-14
scrollkeeper-0.3.12-2
xsri-2.1.0-6
gdm-2.4.4.5-1
xterm-179-5
imlib-1.9.13-14
libtool-libs-1.5-8
gnome-vfs2-extras-0.99.10-3.1
eog-2.4.0-1
GConf-1.0.9-11
gnome-audio-1.4.0-6
gconf-editor-2.4.0-1
gnome-mag-0.10.3-1
gnome-themes-2.4.0-1
gimp-print-utils-4.2.5-2
gnome-terminal-2.4.0.1-1
hwbrowser-0.12-1
magicdev-1.1.4-7
gtksourceview-0.6.0-2
xloadimage-4.1-29
gedit-2.4.0-3
gnome-media-2.4.0-2
gok-0.7.1-4
control-center-2.4.0-3
nautilus-media-0.3.1-1
desktop-printing-0.1.10-18
yelp-2.4.0-1
gnome-vfs-extras-0.2.0-7
mtr-gtk-0.52-3
modutils-devel-2.4.25-13
kudzu-devel-1.1.36-1
diffstat-1.31-3
flex-2.5.4a-30
krbafs-devel-1.2.2-1
libf2c-3.3.2-1
libogg-devel-1.0-5
boost-devel-1.30.2-2
db4-utils-4.1.25-14
libstdc++-devel-3.3.2-1
ltrace-0.3.29-1
libusb-devel-0.1.7-3
automake14-1.4p6-7
patchutils-0.2.24-2
rcs-5.7-21
lockdev-devel-1.0.1-1.3
automake16-1.6.3-1
automake15-1.5-9
bison-1.875-5
gdbm-devel-1.8.0-21
gpm-devel-1.20.1-38
krb5-devel-1.3.1-6
autoconf-2.57-3
openssl-devel-0.9.7a-23
python-devel-2.2.3-7
readline-devel-4.3-7
rpm-devel-4.2.1-0.30
slang-devel-1.4.5-18.1
cvs-1.11.5-3
cyrus-sasl-devel-2.1.15-6
gcc-3.3.2-1
gcc-g77-3.3.2-1
libuser-devel-0.51.7-2
oprofile-0.7cvs-0.20030829.6
memprof-0.5.1-3
gcc-java-3.3.2-1
comps-1-0.20031103
gpg-pubkey-db42a60e-37ea5438
glibc-2.3.2-101.1
procps-2.0.17-5
grep-2.5.1-17.4
initscripts-7.42.2-1
binutils-2.14.90.0.6-4
glibc-devel-2.3.2-101.1
nscd-2.3.2-101.1
redhat-config-printer-gui-0.6.79.2-1
rsync-2.5.7-2
vnc-server-4.0-0.beta4.3.2
hwdata-0.101-1
basesystem-8.0-2
cracklib-2.7-23
expat-1.95.5-3
hdparm-5.4-3
libstdc++-3.3.2-1
losetup-2.11y-29
fedora-release-1-3
mount-2.11y-29
pcre-4.4-1
rootfiles-7.2-6
newt-0.51.6-1
cracklib-dicts-2.7-23
cpio-2.5-5
gawk-3.1.3-3
ash-0.3.8-15
modutils-2.4.25-13
python-2.2.3-7
kudzu-1.1.36-1
mkinitrd-3.5.14-1
which-2.16-1
kernel-2.4.22-1.2115.nptl
prelink-0.3.0-13
mailcap-2.1.14-1.1
specspo-9.0.92-1
elfutils-0.89-2
krbafs-1.2.2-1
lrzsz-0.12.20-17
crontabs-1.10-5
pam_smb-1.1.7-2
aspell-0.50.3-16
logrotate-3.6.10-1
reiserfs-utils-3.6.8-1.1
schedutils-1.3.0-4
ntsysv-1.3.9-1
statserial-1.1-33
telnet-0.17-26.2
unzip-5.50-35
groff-1.18.1-29
logwatch-4.3.2-2.1
irda-utils-0.9.15-1.1
bind-utils-9.2.2.P3-9
bc-1.06-15.1
libxml2-python-2.5.11-1
rpm-python-4.2.1-0.30
syslinux-2.06-1
utempter-0.5.3-2
cyrus-sasl-plain-2.1.15-6
kernel-pcmcia-cs-3.1.31-13
autofs-3.1.7-42
openssh-clients-3.6.1p2-19
nfs-utils-1.0.6-1
sendmail-8.12.10-1.1.1
vconfig-1.8-1
yp-tools-2.8-2
mutt-1.4.1-4
tux-3.2.12-2
libpng-1.2.2-17
httpd-2.0.47-10
php-4.3.3-6
XFree86-libs-4.3.0-42
libtiff-3.5.7-14
dbus-0.13-6
Omni-0.9.0-4
perl-HTML-Parser-3.26-18
perl-XML-Parser-2.31-16
perl-libxml-enno-1.02-29
a2ps-4.13b-30
PyXML-0.8.3-1
foomatic-3.0.0-9
chkfontpath-1.9.10-2
ghostscript-7.07-11
cups-1.1.19-13
libart_lgpl-2.3.16-1
esound-0.2.31-1
pango-1.2.5-1.1
libgnomecanvas-2.4.0-1
pygtk2-libglade-2.0.0-1
usermode-gtk-1.69-1
gtkhtml2-2.4.0-1
gnome-python2-bonobo-2.0.0-2
redhat-config-services-0.8.5-23
sox-12.17.4-1
redhat-config-date-1.5.25-1
redhat-config-rootpassword-1.0.6-2
redhat-config-network-1.3.10-1
desktop-backgrounds-basic-2.0-18
libraw1394-0.9.0-12
cdparanoia-libs-alpha9.8-18
XFree86-Mesa-libGLU-4.3.0-42
gstreamer-tools-0.6.3-1
pilot-link-0.11.8-1
vim-enhanced-6.2.121-1
openssh-askpass-gnome-3.6.1p2-19
rhgb-0.11.2-1
psgml-1.2.5-1
metacity-2.6.3-1
gstreamer-plugins-0.6.3-3
libcroco-0.3.0-1
up2date-gnome-4.1.16-1
libgnomeprint22-2.4.0-1
xisdnload-3.2-5.p1
ggv-2.4.0.1-1
redhat-config-xfree86-0.9.15-1
gnome-icon-theme-1.0.9-2
nautilus-cd-burner-0.5.3-1
ctags-5.5.2-1
gftp-2.0.14-5
at-spi-1.3.7-1
gnome-utils-2.4.0-1
libgnomeprint-1.116.0-7
file-roller-2.4.0.1-1
gnome-user-docs-2.0.1-3
gnome-session-2.4.0-1
xscreensaver-4.14-2
gtk-engines-0.12-1
pciutils-devel-2.1.10-8
expat-devel-1.95.5-3
libcap-devel-1.10-16
boost-1.30.2-2
doxygen-1.3.4-1
libtermcap-devel-2.0.8-36
ncurses-devel-5.3-9
redhat-rpm-config-8.0.28-1.1
swig-1.3.19-5
gdb-5.3.90-0.20030710.41
indent-2.2.9-3
libtool-1.5-8
cdecl-2.5-28
pam-devel-0.77-15
texinfo-4.5-2
gcc-gnat-3.3.2-1
fam-devel-2.6.8-12
libxml2-devel-2.5.11-1
glibc-common-2.3.2-101.1
glibc-headers-2.3.2-101.1
redhat-config-printer-0.6.79.2-1
gnupg-1.2.3-2
rhn-applet-2.1.4-3
Comment 1 Eido Inoue 2004-01-02 09:52:43 EST
Unable to reproduce this bug with the instructions given on any Fedora
machine I have access to. Scrolling with the pager works as expected.
And if there is a problem with this person's machine, the bug should
be filed under the component 'less', the pager for man, not man
itself, because that's what's displaying the man page and taking his
spacebar input.
Comment 2 Fred Shaul 2004-01-05 15:01:04 EST
The same crash happens with ...
   man -P more ls
   man -P cat ls

That would suggest it is not a pager issue, but something about man is
going nutty.  I noticed this after up2dating the system, though I
don't recall whether this was an issue before up2dating.  Note, the
system is an older pentium system - which means its running a more
'basic' kernel, yes?
Comment 3 Eido Inoue 2004-01-05 15:56:11 EST
Thanks for the info. Unfortunately, I'm still not able to reproduce
this bug using the instructions given on any of the Fedora machines in
house. They work.

The only thing I can think of is: 1) are you running in an unusual
(defined as non-UTF-8) locale? ("locale" at the command line returning
an Eastern Europe [ISO-8859-2] etc). 2) have you attempted to change
your encoding charset from the supported UTF-8 to something not/no
longer supported (ISO-8859-1 aka Latin-1, ISO-8859-15, etc)

P.S. We don't need a dump of every RPM on the system-- simply put the
version of man in the "Version-Release number of selected component
(if applicable)" section and perhaps the version of the pager and any
components that man touches (gotten through ldd). I appreciate the
attempt at thoroughness, but it's a little overkill. ;)

Note You need to log in before you can comment on or make changes to this bug.