Bug 1127890 - Effectively impossible to install on software RAID
Summary: Effectively impossible to install on software RAID
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-07 18:46 UTC by digimer
Modified: 2014-12-04 14:26 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-07 19:04:49 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description digimer 2014-08-07 18:46:58 UTC
Description of problem:

Trying to install RHEL 7.0 on a machine with a six-disk system intended to use software RAID appears to be effectively impossible (or if possible, extremely difficult).

I've got a NAS system with 6x 3TB drives with gpt labels. It requires a BIOSBOOT partition, which can not be on a RAID array. There seems to be no way to setup biosboot on multiple disks, so in essence, /dev/sda becomes irreplaceable if it fails (or at least, the system will fail to boot).

In general, installing on a system with software RAID is extremely unintunitive... Having to create a mount point and then alter it, with no mention of this on screen, is hardly user friendly.

In the end, I had to give up and go back to EL6.


Version-Release number of selected component (if applicable):

RHEL 7.0 install disk


How reproducible:

For me, 100%


Steps to Reproduce:
1. Setup a system with 2+ disks
2. Try to setup software RAID in such a way that either/any disk is bootable
3.

Actual results:


Expected results:


Additional info:

Comment 2 David Shea 2014-08-07 19:04:49 UTC
While Red Hat welcomes bug reports on Red Hat products here in our public
bugzilla database, please keep in mind that bugzilla is not a support tool or
means of accessing support.  If you would like technical support please visit
our support portal at access.redhat.com or call us for information on
subscription offerings to suit your needs.

Comment 3 digimer 2014-08-07 19:10:55 UTC
I wasn't asking for support, for the record.

Comment 4 Jaromír Cápík 2014-12-04 13:35:14 UTC
Hello Madison.

Yesterday I created a very similar anaconda usability report and I'll try to keep it alive a bit longer than this report was. The partitioning tool design is really hardly digestible for people who work with servers and storages on a daily basis and the new approach (going from mountpoints to partitions) is not very lucky decision.

Regards,
Jaromir.

Comment 5 digimer 2014-12-04 14:26:52 UTC
Thanks, Jaromir.

I found it rather odd that this was closed as "notabug"... At least a mention of where to report usability problems would have been helpful. Do you have a link to your report? I would love to follow it.


Note You need to log in before you can comment on or make changes to this bug.