Bug 112790 - An Unhandled exception occurred.
An Unhandled exception occurred.
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
9
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-31 17:54 EST by Eric
Modified: 2007-04-18 13:00 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-03 16:16:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Crash Dump that was saved from the error. (63.47 KB, text/plain)
2003-12-31 17:56 EST, Eric
no flags Details

  None (edit)
Description Eric 2003-12-31 17:54:45 EST
I'm trying to install Red Hat 9.0 on a Compaq Deskpro DP2000 (model: 
5200).  Currently I have a 10GB hard drive installed and 384MB of RAM.

I am trying to install RH using the graphical interface.  After I 
select the packages to install, the installation begins,partitions 
and formats the drive.  After this is where I have the problem.

The title bar of the error says "Exception Occurred".

The message is "An unhandled exception has occurred.  This is most 
likely a bug.  Please copy the full text of this exception or save 
the crash dump to a floppy then file a detailed bug report against 
anaconda at http://bugzilla.redhat.com/bugzilla/"

Then there is a scrolling text box that reads:

Traceback (most recent call last):
File "/usr/lib/anaconda/gui.py",line 936, in handleRenderCallback
  self.currentWindow.renderCallback()
File "/usr/lib/anaconda/iw/progress_gui.py",line 155, In 
renderCallback
  self.intf.icw.nextClickd()
File "/usr/lib/anaconda/gui.py",line 761, in nextClicked
  self.dispatc.gotoNext()
File "/usr/lib/anaconda/dispatch.py",line 157, in gotoNext
  self.moveStep()
File "/usr/lib/anaconda/dispatch.py",line 255, in moveStep
  rc = apply(func,self.bindArgs(args))
File "/tmp/updates/packages.py",line 583, in doPreinstall
  method.mergeFullHeaders(id.hdList)
File "/user/lib/anaconda/image.py",line 50, in mergeFullHeaders
  hdlist.mergeFullHeaders(self.tree + "/RedHat/base/hdlist2")
File "/usr/lib/anaconda/comps.py",line 180, in mergeFullHeaders
  rpm.mergeHeaderListFromFD(self.hdlist, fd, 1000004)
error: match tag missing in new header


Reproducibility:  Every time.



Steps to Reproduce:

1.boot from cd
2.hit enter to use graphical install
3.select defaults for language, keyboard layout, and mouse
4.let red hat partition hard drive
5.erase all partitions on hard drive
6.hard code the ip address information
7.select no firewall
8.select custom install
9.accept default options and change these:
remove gnome, add kde, add editors, and add system tools with tsclient

Normal: It's a bug that should be fixed.
Comment 1 Eric 2003-12-31 17:56:41 EST
Created attachment 96736 [details]
Crash Dump that was saved from the error.
Comment 2 Jeremy Katz 2004-01-03 15:44:16 EST
Can you verify your installation media by booting with 'linux mediacheck'?
Comment 3 Eric 2004-01-03 15:53:38 EST
Yes, the media works fine.  I hooked up another computer and 
installed with the same options and had no problems.  I don't know if 
this will make a difference or not, but the computer I was having 
this problem with has a riser board in it that all the PCI and ISA 
slots are on. Should RH recognize this?  It has to be there or I 
can't install anything.

Thanks.
Comment 4 Jeremy Katz 2004-01-03 15:58:40 EST
Checking a different machine doesn't really say much, unfortunately. 
The tolerances between different CD drives and different media is
fairly bad these days :(
Comment 5 Eric 2004-01-03 16:12:08 EST
I agree, and I suspected bad hardware so I replaced the memory, hard 
drive, and the cd drive.  All three of these are what I ended up 
putting in the box that is running now.  That's one reason I was 
wondering about that riser board.

I'm not going to be to concerned about this now since I have it 
running on another machine.  I just thought I would pass it along and 
see if you had any suggestions.

I also forgot to mention before that I tried RH 8.0 also and got the 
same thing.

Anyway thanks for taking the time to respond.

Note You need to log in before you can comment on or make changes to this bug.