Bug 1128011 - [Nagios] - Nagios caches the state of the services when discovery.py was run using the host which was monitored by nagios previously.
Summary: [Nagios] - Nagios caches the state of the services when discovery.py was run ...
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: nagios-server-addons
Version: rhgs-3.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: ---
Assignee: Sahina Bose
QA Contact: RHS-C QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-08 06:10 UTC by RamaKasturi
Modified: 2018-01-30 11:47 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-01-30 11:47:40 UTC


Attachments (Terms of Use)

Description RamaKasturi 2014-08-08 06:10:06 UTC
Description of problem:
When discovery.py is run using the host which was monitored by nagios previously, it caches the state of the services.

Version-Release number of selected component (if applicable):
nagios-server-addons-0.1.5-1.el6rhs.noarch

How reproducible:
Always

Steps to Reproduce:
1. Install nagios on RHS Node.
2. Now run discovery.py with a host called host1 and ip ip1
3. Now delete the cluster completely.
4. Run discovery.py using the same host host1 and ip ip1.

Actual results:
All the service states are cached.

Expected results:
Service states should not be cached instead it should all the services as pending since it is a new node which has been added to nagios.

Additional info:

Comment 5 Sahina Bose 2018-01-30 11:47:40 UTC
Thank you for your bug report. However, this bug is being closed as it's on a component where no further new development is being undertaken.


Note You need to log in before you can comment on or make changes to this bug.