Bug 1128018 - Can't run script bz_webservice_demo.pl caused by lost a comma behind "\$debug"
Summary: Can't run script bz_webservice_demo.pl caused by lost a comma behind "\$debug"
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Bugzilla
Classification: Community
Component: Internal Tools
Version: 4.4
Hardware: Unspecified
OS: Unspecified
low
low vote
Target Milestone: 4.4
Assignee: Matt Tyson 🤬
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-08 06:26 UTC by Rony Gong 🔥
Modified: 2018-12-09 06:29 UTC (History)
3 users (show)

Fixed In Version: 4.4.5025
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-10 02:47:42 UTC


Attachments (Terms of Use)

Description Rony Gong 🔥 2014-08-08 06:26:23 UTC
Description of problem:
Can't run script bz_webservice_demo.pl caused by lost a comma behind "\$debug"

Version-Release number of selected component (if applicable):
4.4.5023

How reproducible:
Always

Steps to Reproduce:
1. In the server side, cd <your-bugzilla-directory>
2. Execut: perl  ./contrib/bz_webservice_demo.pl 
3.

Actual results:
# perl  ./contrib/bz_webservice_demo.pl
String found where operator expected at ./contrib/bz_webservice_demo.pl line 65, near "$debug
           'quicksearch:s'"
	(Missing operator before 'quicksearch:s'?)
syntax error at ./contrib/bz_webservice_demo.pl line 65, near "$debug
           'quicksearch:s'"
Execution of ./contrib/bz_webservice_demo.pl aborted due to compilation errors.

Expected results:
Could run this script
[root@bzweb01-qe bugzilla]# perl  ./contrib/bz_webservice_demo.pl
Error: URI unspecified
Usage:
    "bz_webservice_demo.pl [options]"

    "bz_webservice_demo.pl --help" for detailed help

Additional info:
seems lost a comma in line 64 
'debug'          => \$debug
==>
'debug'          => \$debug,

Comment 1 Rony Gong 🔥 2014-08-26 03:27:27 UTC
Verified on QA environment(bzweb01-qe) with version(4.4.5025-1)
Result: Pass
Steps:
1. In the server side, cd <your-bugzilla-directory>
2. Execut: perl  ./contrib/bz_webservice_demo.pl
3. No error message shown.

Comment 2 Matt Tyson 🤬 2014-09-10 02:47:42 UTC
This change is now live. If there are any issues, do not reopen this bug.
Instead, you should create a new bug and reference this bug.


Note You need to log in before you can comment on or make changes to this bug.