Bug 1128043 - with more than 74 scsi data disks,windows guests cannot boot up("no bootable device") while system disk is ide
Summary: with more than 74 scsi data disks,windows guests cannot boot up("no bootable ...
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: seabios
Version: 6.6
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Gerd Hoffmann
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-08 07:24 UTC by lijin
Modified: 2014-09-03 12:31 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Known Issue
Doc Text:
The SeaBIOS application runs in real mode for compatibility with BIOS interfaces. This limits the amount of memory available. As a consequence, SeaBIOS is only able to handle a limited number of disks. Currently, the supported number of disks is: virtio-scsi — 64 virtio-blk — 4 usb-storage — 4 As a workaround for this problem, when attaching a large number of disks to your virtual machine, make sure that your system disk has a small pci slot number, so SeaBIOS sees it first when scanning the pci bus. It is also recommended to use the virtio-scsi device instead of virtio-blk as the per-disk memory overhead is smaller.
Clone Of:
Environment:
Last Closed: 2014-09-03 12:31:15 UTC


Attachments (Terms of Use)
no bootable device screenshot (18.72 KB, image/png)
2014-08-08 07:24 UTC, lijin
no flags Details
the seabios log (34.99 KB, text/plain)
2014-08-11 06:22 UTC, lijin
no flags Details

Description lijin 2014-08-08 07:24:35 UTC
Created attachment 925100 [details]
no bootable device screenshot

Description of problem:
boot win2012 guest with ide system disk and 75 scsi-hd data disk on one virtio-scsi-pci controller,guest cannot boot up successfully,it shows "no bootable device"

Version-Release number of selected component (if applicable):
seabios-0.6.1.2-28.el6.x86_64
kernel-2.6.32-492.el6.x86_64
qemu-kvm-0.12.1.2-2.435.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.boot win2012 guest with ide system disk and ***75*** scsi-hd data disk on one virtio-scsi-pci controller:
/usr/libexec/qemu-kvm  \
-drive file=win2k12.qcow2,if=none,cache=none,media=disk,format=qcow2,werror=stop,rerror=stop,id=drive-scsi-0 -device ide-drive,id=disk-scsi-0,drive=drive-scsi-0,bootindex=1 -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -usb -device usb-tablet -monitor stdio -chardev file,path=/root/console.log,id=serial1 -device isa-serial,chardev=serial1,id=s1 -cpu SandyBridge -M rhel6.6.0 -smp 4 -m 4G -enable-kvm -qmp tcp:0:4444,server,nowait -vnc :0 -vga cirrus \
-device virtio-scsi-pci,id=scsi0 \
-drive file='/tmp/stg0.raw',if=none,id=virtio-scsi2-id1,media=disk,cache=none,snapshot=off,format=raw,aio=native \
-device scsi-disk,drive=virtio-scsi2-id1 \
-drive file='/tmp/stg1.raw',if=none,id=virtio-scsi3-id2,media=disk,cache=none,snapshot=off,format=raw,aio=native \
......
......
-drive file='/tmp/stg74.raw',if=none,id=virtio-scsi76-id75,media=disk,cache=none,snapshot=off,format=raw,aio=native \
-device scsi-disk,drive=virtio-scsi76-id75 \

Actual results:
guest cannot boot up

Expected results:
guest can boot up correctly

Additional info:
1.boot win2012 guest with ide system disk and ***74*** scsi-hd data disks will not hit this issue,guest can boot up;
2.guest can boot up when change system disk to virtio-blk-pci/scsi-hd.

Comment 2 Xu Han 2014-08-11 02:47:29 UTC
Would you please append seabios debug console into the command line, get a log and make a comment here?
    -chardev socket,id=seabioslog,path=/tmp/seabios-debugport,server,nowait \
    -device isa-debugcon,chardev=seabioslog,iobase=0x402 \

Thanks.

Comment 3 lijin 2014-08-11 06:22:42 UTC
Created attachment 925622 [details]
the seabios log

the attached is the seabios log,please have a check.

Comment 4 Xu Han 2014-08-11 06:51:36 UTC
(In reply to lijin from comment #3)
> Created attachment 925622 [details]
> the seabios log
> 
> the attached is the seabios log,please have a check.

Thanks for providing the info.

The system disk(ide) could not be initialized since seabios ran out of memory:
WARNING - Unable to allocate resource at init_atadrive:743!

Comment 5 Ronen Hod 2014-08-11 18:31:06 UTC
Gerd, is this something for a known-issue tech note?

lijin, is is also a RHEL7 issue?

Comment 6 lijin 2014-08-12 02:18:43 UTC
(In reply to Ronen Hod from comment #5)
> Gerd, is this something for a known-issue tech note?
> 
> lijin, is is also a RHEL7 issue?

guest works fine on rhel7 host
# rpm -qa | grep seabios
seabios-1.7.2.2-12.el7.x86_64

Comment 8 Gerd Hoffmann 2014-08-25 14:39:23 UTC
(In reply to Ronen Hod from comment #5)
> Gerd, is this something for a known-issue tech note?
> 
> lijin, is is also a RHEL7 issue?

For rhel7 we have documented disk count limits, exactly because the number of disks seabios is able to manage is constrained by the limited real mode address space.  Makes sense to do the same for rhel6.

Comment 9 Ronen Hod 2014-09-02 12:29:06 UTC
(In reply to Gerd Hoffmann from comment #8)
> (In reply to Ronen Hod from comment #5)
> > Gerd, is this something for a known-issue tech note?
> > 
> > lijin, is is also a RHEL7 issue?
> 
> For rhel7 we have documented disk count limits, exactly because the number
> of disks seabios is able to manage is constrained by the limited real mode
> address space.  Makes sense to do the same for rhel6.

Gerd, can you provide the exact text, so that we can close this bug?

Comment 10 Gerd Hoffmann 2014-09-03 06:37:19 UTC
(In reply to Ronen Hod from comment #9)

> Gerd, can you provide the exact text, so that we can close this bug?

rhel7 bug is 1034072, I think we can simply reuse the text (with s/rhel7/rhel6/ of course, and also drop ahci/sata as we don't have this in rhel6).


Note You need to log in before you can comment on or make changes to this bug.