Bug 1128178 - Rubygem-Staypuft: HA-nova deployment fails - /tmp/ha-all-in-one-util.bash all_members_include memcached returned 1 instead of one of [0] [NEEDINFO]
Summary: Rubygem-Staypuft: HA-nova deployment fails - /tmp/ha-all-in-one-util.bash al...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-foreman-installer
Version: 5.0 (RHEL 7)
Hardware: x86_64
OS: Linux
urgent
urgent
Target Milestone: ga
: Installer
Assignee: Jason Guiditta
QA Contact: Leonid Natapov
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-08 13:59 UTC by Alexander Chuzhoy
Modified: 2014-08-12 20:04 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-12 20:04:02 UTC
morazi: needinfo?


Attachments (Terms of Use)

Description Alexander Chuzhoy 2014-08-08 13:59:40 UTC
Rubygem-Staypuft:  HA-nova deployment fails - /tmp/ha-all-in-one-util.bash all_members_include memcached returned 1 instead of one of [0]


Environment:
rhel-osp-installer-0.1.6-5.el6ost.noarch
openstack-foreman-installer-2.0.16-1.el6ost.noarch
ruby193-rubygem-foreman_openstack_simplify-0.0.6-8.el6ost.noarch
openstack-puppet-modules-2014.1-19.9.el6ost.noarch

Steps to reproduce:
1. Install rhel-osp-installer
2. Configure/run a deployment of HA nova (3 controllers +2 compute)

Result:
The deployment gets stuck on 60% installing the controllers.
Looking at the puppet report I see the following errors on 2 controllers:

/tmp/ha-all-in-one-util.bash all_members_include memcached returned 1 instead of one of [0]
change from notrun to 0 failed: /tmp/ha-all-in-one-util.bash all_members_include memcached returned 1 instead of one of [0]

change from notrun to 0 failed: /tmp/ha-all-in-one-util.bash i_am_vip 192.168.0.99 || /tmp/ha-all-in-one-util.bash property_exists rabbitmq returned 1 instead of one of [0]


One the third controller I get this:
change from notrun to 0 failed: /usr/sbin/pcs status | grep -q 'partition with quorum' > /dev/null 2>&1 returned 1 instead of one of [0]
/usr/sbin/pcs status | grep -q 'partition with quorum' > /dev/null 2>&1 returned 1 instead of one of [0]
Expected result:
The deployment should complete 100%.

Comment 3 Mike Orazi 2014-08-12 20:04:02 UTC
Sasha is reporting this is known working.  Please reopen if we hit this issue again.


Note You need to log in before you can comment on or make changes to this bug.