Bug 112818 - Samba mounted FS hangs for ever after an I/O error.
Samba mounted FS hangs for ever after an I/O error.
Status: CLOSED DUPLICATE of bug 110892
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Fenlason
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-02 15:37 EST by Guðmundur D. H.
Modified: 2014-08-31 19:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Guðmundur D. H. 2004-01-02 15:37:38 EST
Description of problem:
Samba mounted filesystem hangs after an I/O error.

/var/log/messages shows: 
Jan  2 20:21:15 yztiklettur kernel: smb_get_length: recv error = 5
Jan  2 20:21:15 yztiklettur kernel: smb_trans2_request: result=-5,
setting invalid

Please note that this only happens with this particular mount, but
other mounts from the same server on the same client work fine!

The FS hangs forever and cannot be unmounted - a reboot is needed to
get rid of this mounted FS.

Version-Release number of selected component (if applicable):
Samba 3.0.0-15 both on server and client.

This started when I upgraded to Fedora Core 1 from Red Hat 8.0. I'm
running the same kernel as I did when running Red Hat 8.0.

How reproducible:
The mount might work for hours or even days before this happens!

Steps to Reproduce:
1. Mount a Samba-FS from a server
2. Use the FS 
3. Wait for the hang to happen.
Comment 1 Guðmundur D. H. 2004-01-03 23:01:28 EST
I came across at this:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=110892
and then I figured, looked at the logs on the server and saw this:

Jan  2 20:21:15 binhex smbd[12100]: [2004/01/02 20:21:15, 0]
lib/fault.c:fault_report(36) 
Jan  2 20:21:15 binhex smbd[12100]:  
=============================================================== 
Jan  2 20:21:15 binhex smbd[12100]: [2004/01/02 20:21:15, 0]
lib/fault.c:fault_report(37) 
Jan  2 20:21:15 binhex smbd[12100]:   INTERNAL ERROR: Signal 11 in pid
12100 (3.0.0-15) 
Jan  2 20:21:15 binhex smbd[12100]:   Please read the appendix Bugs of
the Samba HOWTO collection 
Jan  2 20:21:15 binhex smbd[12100]: [2004/01/02 20:21:15, 0]
lib/fault.c:fault_report(39) 
Jan  2 20:21:15 binhex smbd[12100]:  
=============================================================== 
Jan  2 20:21:15 binhex smbd[12100]: [2004/01/02 20:21:15, 0]
lib/util.c:smb_panic(1422) 
Jan  2 20:21:15 binhex smbd[12100]:   PANIC: internal error 
Jan  2 20:21:15 binhex smbd[12100]: [2004/01/02 20:21:15, 0]
lib/util.c:smb_panic(1429) 
Jan  2 20:21:15 binhex smbd[12100]:   BACKTRACE: 17 stack frames: 
Jan  2 20:21:15 binhex smbd[12100]:    #0 smbd(smb_panic+0x110)
[0x43f430] 
Jan  2 20:21:15 binhex smbd[12100]:    #1 smbd [0x42b3e4] 
Jan  2 20:21:15 binhex smbd[12100]:    #2 /lib/libc.so.6 [0x666b78] 
Jan  2 20:21:15 binhex smbd[12100]:    #3 smbd(vfswrap_readdir+0x1f)
[0x32415f] 
Jan  2 20:21:15 binhex smbd[12100]:    #4 smbd(vfs_readdirname+0x29)
[0x322a89] 
Jan  2 20:21:15 binhex smbd[12100]:    #5 smbd(OpenDir+0x422) [0x2e66b2] 
Jan  2 20:21:15 binhex smbd[12100]:    #6 smbd [0x2e50d5] 
Jan  2 20:21:15 binhex smbd[12100]:    #7 smbd(dptr_create+0x2d)
[0x2e525d] 
Jan  2 20:21:15 binhex smbd[12100]:    #8 smbd [0x30fb4b] 
Jan  2 20:21:15 binhex smbd[12100]:    #9 smbd(reply_trans2+0x665)
[0x3185a5] 
Jan  2 20:21:15 binhex smbd[12100]:    #10 smbd [0x32e1bf] 
Jan  2 20:21:15 binhex smbd[12100]:    #11 smbd [0x32e463] 
Jan  2 20:21:15 binhex smbd[12100]:    #12 smbd(process_smb+0xa4)
[0x32e6b4] 
Jan  2 20:21:15 binhex smbd[12100]:    #13 smbd(smbd_process+0x19f)
[0x32f40f] 
Jan  2 20:21:15 binhex smbd[12100]:    #14 smbd(main+0x4fd) [0x4b2f4d] 
Jan  2 20:21:15 binhex smbd[12100]:    #15
/lib/libc.so.6(__libc_start_main+0xac) [0x655b84] 
Jan  2 20:21:15 binhex smbd[12100]:    #16 smbd [0x2d42e2] 
Jan  2 20:21:15 binhex smbd[12100]: 

So the server crashes, the client is unable to mount the share again
and the mountpoint is fucked forever. 

-G.


Comment 2 Guðmundur D. H. 2004-01-03 23:03:00 EST

*** This bug has been marked as a duplicate of 110892 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:00:32 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.