This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 112821 - ks.cfg problems with --disable verses --disabled
ks.cfg problems with --disable verses --disabled
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
3.0
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-02 16:28 EST by Joshua Jensen
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-02 01:39:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Jensen 2004-01-02 16:28:51 EST
Description of problem:

In a ks.cfg file, disabling firewall and firstboot don't use the same
syntax.  firewall wants --disabled, and firstboot wants --disable


Version-Release number of selected component (if applicable):

RHEL3


Expected results:

In a perfect world, both directives would use one or the other
options.  Since each -- option already exists, please make it so that
both directives will take *both* options... --disabled and --disable

Additional info:

Also note this change, if you make it, to the Kickstart Options
chapter in the docs
Comment 1 Jeremy Katz 2004-02-12 12:59:06 EST
Added so that both have both. 
Comment 2 John Flanagan 2004-05-11 22:48:51 EDT
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-195.html
Comment 3 Joshua Jensen 2004-05-14 16:10:56 EDT
firstboot --disable has been broken as of the RHEL3 U2 update
kickstart doesn't accept this anymore

I thought you said that both firstboot and firewall would support for
--disable and --disabled

??
Comment 4 Joshua Jensen 2004-06-11 17:59:00 EDT
Ping... ???
Comment 5 Jeremy Katz 2004-06-14 11:01:51 EDT
Oops, I can't type.  Fixed in CVS
Comment 6 Joshua Jensen 2004-07-13 10:29:56 EDT
Might this be fixed in RHEL3 U3 anaconda?
Comment 7 Jeremy Katz 2004-07-13 10:38:16 EDT
Yes, should be.  When the beta's available, you should be able to
verify it.
Comment 8 John Flanagan 2004-09-02 01:39:48 EDT
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-417.html

Note You need to log in before you can comment on or make changes to this bug.