Bug 1128260 - ERROR [org.rhq.enterprise.server.installer.Installer] The installer will now exit due to previous errors
Summary: ERROR [org.rhq.enterprise.server.installer.Installer] The installer will now ...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Installer
Version: JON 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: JON 3.3.0
Assignee: RHQ Project Maintainer
QA Contact: Mike Foley
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-08 17:41 UTC by Matt Mahoney
Modified: 2014-09-04 12:31 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-04 12:31:08 UTC
Type: Bug


Attachments (Terms of Use)
rhqctl install console output (20.54 KB, text/plain)
2014-08-08 17:41 UTC, Matt Mahoney
no flags Details
rhq-installer.log (11.68 KB, text/plain)
2014-08-08 17:58 UTC, Matt Mahoney
no flags Details
server.log (167.01 KB, text/plain)
2014-08-08 17:58 UTC, Matt Mahoney
no flags Details

Description Matt Mahoney 2014-08-08 17:41:02 UTC
Created attachment 925272 [details]
rhqctl install console output

Description of problem:
The following error occurred during installation:

10:46:54,284 ERROR [org.rhq.enterprise.server.installer.Installer] The installer will now exit due to previous errors: java.lang.RuntimeException: Timed out before being able to successfully connect to the server
    at org.rhq.enterprise.server.installer.InstallerServiceImpl.testModelControllerClient(InstallerServiceImpl.java:1037) [rhq-installer-util-4.12.0.JON330DR01.jar:4.12.0.JON330DR01]
    at org.rhq.enterprise.server.installer.InstallerServiceImpl.testModelControllerClient(InstallerServiceImpl.java:1051) [rhq-installer-util-4.12.0.JON330DR01.jar:4.12.0.JON330DR01]
    at org.rhq.enterprise.server.installer.InstallerServiceImpl.install(InstallerServiceImpl.java:367) [rhq-installer-util-4.12.0.JON330DR01.jar:4.12.0.JON330DR01]
    at org.rhq.enterprise.server.installer.Installer.doInstall(Installer.java:118) [rhq-installer-util-4.12.0.JON330DR01.jar:4.12.0.JON330DR01]
    at org.rhq.enterprise.server.installer.Installer.main(Installer.java:59) [rhq-installer-util-4.12.0.JON330DR01.jar:4.12.0.JON330DR01]


Version-Release number of selected component (if applicable):
JON 3.3 DR01

How reproducible:


Steps to Reproduce:
1. Unzip the JON 3.3 DR01 bundle.
2. Run rhqctl install
3.

Actual results:

Expected results:
No Errors should occur during installation.

Additional info:

Comment 1 Matt Mahoney 2014-08-08 17:58:18 UTC
Created attachment 925279 [details]
rhq-installer.log

Comment 2 Matt Mahoney 2014-08-08 17:58:52 UTC
Created attachment 925280 [details]
server.log

Comment 3 Jay Shaughnessy 2014-09-02 21:17:20 UTC
Has this been a problem in subsequent builds?  I haven't heard of install issues like this in ER01.


Note You need to log in before you can comment on or make changes to this bug.