Bug 1128329 - Our .spec file does not protect admin.conf during upgrades
Summary: Our .spec file does not protect admin.conf during upgrades
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Pulp
Classification: Retired
Component: documentation
Version: 2.4.0
Hardware: All
OS: Linux
high
medium
Target Milestone: ---
: 2.4.1
Assignee: Randy Barlow
QA Contact: Preethi Thomas
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-09 06:19 UTC by Randy Barlow
Modified: 2014-09-23 17:54 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-23 17:54:23 UTC


Attachments (Terms of Use)

Description Randy Barlow 2014-08-09 06:19:30 UTC
Description of problem:
I just did an update to 2.4.0-1 from 2.3.1-1. I noticed that I got a .rpmnew file for consumer.conf, but I did not get one for admin.conf. The new admin.conf clobbered the existing one.


Version-Release number of selected component (if applicable):
2.4.0-1

How reproducible:
Every time

Steps to Reproduce:
1. Upgrade from 2.3.1 to 2.4.0

Actual results:
Observe that your admin.conf customizations were clobbered.

Expected results:
There should have been an admin.conf.rpmnew created.

Comment 1 Sayli Karmarkar 2014-08-13 16:14:01 UTC
This is most likely due to re-packaging of the package. We just need to confirm that and then close it.

Comment 2 Sayli Karmarkar 2014-08-13 16:46:25 UTC
Confirmed above comment#1. Moving it to docs bug so that we can add a quick note about it in 2.4 release notes.

Comment 3 Randy Barlow 2014-08-14 18:39:02 UTC
https://github.com/pulp/pulp/pull/1110

Comment 4 Randy Barlow 2014-08-20 03:31:40 UTC
We are rebasing pulp-2.4.1, and so all of these bugs can no longer be considered MODIFIED. We will need to recheck them against the rebased build to make sure the cherry picking strategy did not introduce any regressions.

Comment 5 Randy Barlow 2014-08-20 03:33:24 UTC
We are rebasing pulp-2.4.1, and so all of these bugs can no longer be considered ON_QA. We will need to recheck them against the rebased build to make sure the cherry picking strategy did not introduce any regressions.

Comment 6 Randy Barlow 2014-08-25 19:42:42 UTC
This is actually already fixed in Read the Docs. Preethi, can you verify that the warning about admin.conf is published to QE this one?

Comment 8 Randy Barlow 2014-09-23 17:54:23 UTC
This is fixed in Pulp-2.4.1-1.


Note You need to log in before you can comment on or make changes to this bug.