Bug 1128349 - libgadu dependency issue
Summary: libgadu dependency issue
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: libgadu
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dominik 'Rathann' Mierzejewski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-09 10:38 UTC by Ali Akcaagac
Modified: 2014-08-13 11:27 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-13 11:27:55 UTC


Attachments (Terms of Use)

Description Ali Akcaagac 2014-08-09 10:38:47 UTC
--> Finished Dependency Resolution
Error: Package: 1:folks-0.9.6-5.fc21.i686 (fedora)
           Requires: libedataserver-1.2.so.18
Error: Package: gnome-contacts-3.13.3-1.fc21.i686 (fedora)
           Requires: libebackend-1.2.so.7
Error: Package: libgadu-1.12.0-1.fc22.i686 (fedora)
           Requires: libprotobuf-c.so.0
Error: Package: gnome-contacts-3.13.3-1.fc21.i686 (fedora)
           Requires: libedata-book-1.2.so.20
Error: Package: gnome-contacts-3.13.3-1.fc21.i686 (fedora)
           Requires: libcamel-1.2.so.49
Error: Package: 1:folks-0.9.6-5.fc21.i686 (fedora)
           Requires: libedata-book-1.2.so.20
Error: Package: gnome-contacts-3.13.3-1.fc21.i686 (fedora)
           Requires: libedataserver-1.2.so.18
Error: Package: 1:folks-0.9.6-5.fc21.i686 (fedora)
           Requires: libebackend-1.2.so.7
Error: Package: 1:folks-0.9.6-5.fc21.i686 (fedora)
           Requires: libebook-1.2.so.14
Error: Package: gnome-contacts-3.13.3-1.fc21.i686 (fedora)
           Requires: libebook-1.2.so.14
Error: Package: 1:folks-0.9.6-5.fc21.i686 (fedora)
           Requires: libcamel-1.2.so.49
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Please fix if possible. Reports for gnome-contacts and folks follows separate.

Comment 1 javierwilson 2014-08-09 22:22:16 UTC
Same here when trying to install pidgin or similar packages, libgadu requires libprotobuf-c.so.0 which is no longer provided:

--> Running transaction check
---> Package pidgin.x86_64 0:2.10.9-3.fc21 will be installed
--> Processing Dependency: libpurple(x86-64) = 2.10.9-3.fc21 for package: pidgin-2.10.9-3.fc21.x86_64
--> Processing Dependency: libpurple.so.0()(64bit) for package: pidgin-2.10.9-3.fc21.x86_64
--> Running transaction check
---> Package libpurple.x86_64 0:2.10.9-3.fc21 will be installed
--> Processing Dependency: libgadu.so.3()(64bit) for package: libpurple-2.10.9-3.fc21.x86_64
--> Running transaction check
---> Package libgadu.x86_64 0:1.12.0-1.fc21 will be installed
--> Processing Dependency: libprotobuf-c.so.0()(64bit) for package: libgadu-1.12.0-1.fc21.x86_64
--> Finished Dependency Resolution
Error: Package: libgadu-1.12.0-1.fc21.x86_64 (fedora)
           Requires: libprotobuf-c.so.0()(64bit)

Comment 2 Dominik 'Rathann' Mierzejewski 2014-08-13 11:27:55 UTC
I don't know why you're getting 1.12.0-1.fc21. 1.12.0-3.fc22/fc21 were built a week ago against the new libprotobuf-c:
http://koji.fedoraproject.org/koji/buildinfo?buildID=551348
http://koji.fedoraproject.org/koji/buildinfo?buildID=551356

Please check if your mirrors are up to date.

I'm able to install libgadu in both F21 and rawhide mock buildroots.


Note You need to log in before you can comment on or make changes to this bug.