Bug 1128466 - Unable to sort hammer repository list
Summary: Unable to sort hammer repository list
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Adam Price
QA Contact: Og Maciel
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-10 16:47 UTC by sthirugn@redhat.com
Modified: 2017-08-01 20:33 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 20:33:21 UTC


Attachments (Terms of Use)

Description sthirugn@redhat.com 2014-08-10 16:47:02 UTC
Description of problem:


Version-Release number of selected component (if applicable):
GA Snap 4 - Satellite-6.0.4-RHEL-6-20140806.0

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.19-1.el6_5.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.9.19-1.el6_5.noarch
* candlepin-tomcat6-0.9.19-1.el6_5.noarch
* elasticsearch-0.90.10-4.el6sat.noarch
* foreman-1.6.0.38-1.el6sat.noarch
* foreman-compute-1.6.0.38-1.el6sat.noarch
* foreman-gce-1.6.0.38-1.el6sat.noarch
* foreman-libvirt-1.6.0.38-1.el6sat.noarch
* foreman-ovirt-1.6.0.38-1.el6sat.noarch
* foreman-postgresql-1.6.0.38-1.el6sat.noarch
* foreman-proxy-1.6.0.23-1.el6sat.noarch
* foreman-selinux-1.6.0.4-1.el6sat.noarch
* foreman-vmware-1.6.0.38-1.el6sat.noarch
* katello-1.5.0-28.el6sat.noarch
* katello-ca-1.0-1.noarch
* katello-certs-tools-1.5.6-1.el6sat.noarch
* katello-installer-0.0.57-1.el6sat.noarch
* openldap-2.4.23-34.el6_5.1.x86_64
* pulp-katello-0.3-3.el6sat.noarch
* pulp-nodes-common-2.4.0-0.30.beta.el6sat.noarch
* pulp-nodes-parent-2.4.0-0.30.beta.el6sat.noarch
* pulp-puppet-plugins-2.4.0-0.30.beta.el6sat.noarch
* pulp-puppet-tools-2.4.0-0.30.beta.el6sat.noarch
* pulp-rpm-plugins-2.4.0-0.30.beta.el6sat.noarch
* pulp-selinux-2.4.0-0.30.beta.el6sat.noarch
* pulp-server-2.4.0-0.30.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.1.0-2.el6sat.noarch
* sssd-ldap-1.11.5.1-3.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
I tried a lot of combinations to make hammer repository list order work but nothing worked

hammer> repository list --product='morerepos' --organization-id=3 --per-page=40 --order='NAME'
Cannot sort by ''

hammer> repository list --product='morerepos' --organization-id=3 --per-page=40 --order='NAME ASC'
Cannot sort by 'NAME'

hammer> repository list --product='morerepos' --organization-id=3 --per-page=40 --order='NAME DESC'
Cannot sort by 'NAME'

hammer> repository list --product='morerepos' --organization-id=3 --per-page=40 --order='ID DESC'
Cannot sort by 'ID'

hammer> repository list --product='morerepos' --organization-id=3 --per-page=40 --order='ID'
Cannot sort by ''



Actual results:
sorting does not work for repository list

Expected results:
sorting should work for repository list

Additional info:

Comment 2 Adam Price 2015-06-25 20:00:04 UTC
the --order option seems to be fairly picky with regards to case-sensitivity, etc.

--order="field ORDER" is the general format. take the following examples

--order="name ASC"

--order="name DESC"

the field is case-sensitive so NAME will return an error saying 'NAME' is not a valid field to search.

Comment 3 sthirugn@redhat.com 2015-08-03 16:27:00 UTC
Failed in Sat 6.1 GA Snap 15 - when tested as per Comment 2 - see both 'id ASC' and 'id DESC' giving same results below:

hammer> repository list --organization-id=4 --per-page=10 --product-id=495 --order='id ASC'
---|------------|--------------|--------------|----
ID | NAME       | PRODUCT      | CONTENT TYPE | URL
---|------------|--------------|--------------|----
29 | testrepo1  | testproduct1 | puppet       |    
39 | testrepo10 | testproduct1 | yum          |    
31 | testrepo2  | testproduct1 | yum          |    
32 | testrepo3  | testproduct1 | yum          |    
33 | testrepo4  | testproduct1 | yum          |    
34 | testrepo5  | testproduct1 | yum          |    
35 | testrepo6  | testproduct1 | yum          |    
36 | testrepo7  | testproduct1 | yum          |    
37 | testrepo8  | testproduct1 | yum          |    
38 | testrepo9  | testproduct1 | yum          |    
---|------------|--------------|--------------|----

hammer> repository list --organization-id=4 --per-page=10 --product-id=495 --order='id DESC'
---|------------|--------------|--------------|----
ID | NAME       | PRODUCT      | CONTENT TYPE | URL
---|------------|--------------|--------------|----
29 | testrepo1  | testproduct1 | puppet       |    
39 | testrepo10 | testproduct1 | yum          |    
31 | testrepo2  | testproduct1 | yum          |    
32 | testrepo3  | testproduct1 | yum          |    
33 | testrepo4  | testproduct1 | yum          |    
34 | testrepo5  | testproduct1 | yum          |    
35 | testrepo6  | testproduct1 | yum          |    
36 | testrepo7  | testproduct1 | yum          |    
37 | testrepo8  | testproduct1 | yum          |    
38 | testrepo9  | testproduct1 | yum          |    
---|------------|--------------|--------------|----

Comment 4 Adam Price 2015-08-10 16:38:46 UTC
This only occurs downstream.

The reason for this is because upstream Katello has switched repositories_controller's searching and sorting to scoped_search whereas those changes are not present in downstream Satellite6 utilizing the previous search/sort code.

Comment 5 Og Maciel 2016-03-24 14:08:22 UTC
[root@cloud-qe-10 ~]# hammer -u admin -p changeme repository list --organization-id 1 --product 'Red Hat Enterprise Linux Server' --per-page=3
---|--------------------------------------------------------|---------------------------------|--------------|-----------------------------------------------------------------------
ID | NAME                                                   | PRODUCT                         | CONTENT TYPE | URL
---|--------------------------------------------------------|---------------------------------|--------------|-----------------------------------------------------------------------
6  | Red Hat Enterprise Linux 7 Server RPMs x86_64 7Server  | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/7/7Server/x86_64/os
1  | Red Hat Enterprise Linux 7 Server Kickstart x86_64 7.2 | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/7/7.2/x86_64/kickstart
8  | Red Hat Enterprise Linux 6 Server RPMs x86_64 6Server  | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/6/6Server/x86_64/os
---|--------------------------------------------------------|---------------------------------|--------------|-----------------------------------------------------------------------
[root@cloud-qe-10 ~]# hammer -u admin -p changeme repository list --organization-id 1 --product 'Red Hat Enterprise Linux Server' --per-page=3 --order='ID'
---|---------------------------------------------------------|---------------------------------|--------------|------------------------------------------------------------------------
ID | NAME                                                    | PRODUCT                         | CONTENT TYPE | URL
---|---------------------------------------------------------|---------------------------------|--------------|------------------------------------------------------------------------
5  | Red Hat Enterprise Linux 6 Server Kickstart x86_64 6.7  | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/6/6.7/x86_64/kickstart
8  | Red Hat Enterprise Linux 6 Server RPMs x86_64 6Server   | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/6/6Server/x86_64/os
1  | Red Hat Enterprise Linux 7 Server Kickstart x86_64 7.2  | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/7/7.2/x86_64/kickstart
4  | Red Hat Enterprise Linux 6 Server Kickstart i386 6.7    | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/6/6.7/i386/kickstart
3  | Red Hat Enterprise Linux 5 Server Kickstart x86_64 5.11 | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/5/5.11/x86_64/kickstart
10 | Red Hat Enterprise Linux 5 Server RPMs x86_64 5Server   | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/5/5Server/x86_64/os
9  | Red Hat Enterprise Linux 5 Server RPMs i386 5Server     | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/5/5Server/i386/os
2  | Red Hat Enterprise Linux 5 Server Kickstart i386 5.11   | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/5/5.11/i386/kickstart
6  | Red Hat Enterprise Linux 7 Server RPMs x86_64 7Server   | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/7/7Server/x86_64/os
7  | Red Hat Enterprise Linux 6 Server RPMs i386 6Server     | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/6/6Server/i386/os
---|---------------------------------------------------------|---------------------------------|--------------|------------------------------------------------------------------------
[root@cloud-qe-10 ~]# hammer -u admin -p changeme repository list --organization-id 1 --product 'Red Hat Enterprise Linux Server' --per-page=3 --order='ID ASC'
---|---------------------------------------------------------|---------------------------------|--------------|------------------------------------------------------------------------
ID | NAME                                                    | PRODUCT                         | CONTENT TYPE | URL
---|---------------------------------------------------------|---------------------------------|--------------|------------------------------------------------------------------------
5  | Red Hat Enterprise Linux 6 Server Kickstart x86_64 6.7  | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/6/6.7/x86_64/kickstart
8  | Red Hat Enterprise Linux 6 Server RPMs x86_64 6Server   | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/6/6Server/x86_64/os
1  | Red Hat Enterprise Linux 7 Server Kickstart x86_64 7.2  | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/7/7.2/x86_64/kickstart
4  | Red Hat Enterprise Linux 6 Server Kickstart i386 6.7    | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/6/6.7/i386/kickstart
3  | Red Hat Enterprise Linux 5 Server Kickstart x86_64 5.11 | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/5/5.11/x86_64/kickstart
10 | Red Hat Enterprise Linux 5 Server RPMs x86_64 5Server   | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/5/5Server/x86_64/os
9  | Red Hat Enterprise Linux 5 Server RPMs i386 5Server     | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/5/5Server/i386/os
2  | Red Hat Enterprise Linux 5 Server Kickstart i386 5.11   | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/5/5.11/i386/kickstart
6  | Red Hat Enterprise Linux 7 Server RPMs x86_64 7Server   | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/7/7Server/x86_64/os
7  | Red Hat Enterprise Linux 6 Server RPMs i386 6Server     | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/6/6Server/i386/os
---|---------------------------------------------------------|---------------------------------|--------------|------------------------------------------------------------------------
[root@cloud-qe-10 ~]# hammer -u admin -p changeme repository list --organization-id 1 --product 'Red Hat Enterprise Linux Server' --per-page=3 --order='NAME'
---|---------------------------------------------------------|---------------------------------|--------------|------------------------------------------------------------------------
ID | NAME                                                    | PRODUCT                         | CONTENT TYPE | URL
---|---------------------------------------------------------|---------------------------------|--------------|------------------------------------------------------------------------
5  | Red Hat Enterprise Linux 6 Server Kickstart x86_64 6.7  | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/6/6.7/x86_64/kickstart
8  | Red Hat Enterprise Linux 6 Server RPMs x86_64 6Server   | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/6/6Server/x86_64/os
1  | Red Hat Enterprise Linux 7 Server Kickstart x86_64 7.2  | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/7/7.2/x86_64/kickstart
4  | Red Hat Enterprise Linux 6 Server Kickstart i386 6.7    | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/6/6.7/i386/kickstart
3  | Red Hat Enterprise Linux 5 Server Kickstart x86_64 5.11 | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/5/5.11/x86_64/kickstart
10 | Red Hat Enterprise Linux 5 Server RPMs x86_64 5Server   | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/5/5Server/x86_64/os
9  | Red Hat Enterprise Linux 5 Server RPMs i386 5Server     | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/5/5Server/i386/os
2  | Red Hat Enterprise Linux 5 Server Kickstart i386 5.11   | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/5/5.11/i386/kickstart
6  | Red Hat Enterprise Linux 7 Server RPMs x86_64 7Server   | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/7/7Server/x86_64/os
7  | Red Hat Enterprise Linux 6 Server RPMs i386 6Server     | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/6/6Server/i386/os
---|---------------------------------------------------------|---------------------------------|--------------|------------------------------------------------------------------------
[root@cloud-qe-10 ~]# hammer -u admin -p changeme repository list --organization-id 1 --product 'Red Hat Enterprise Linux Server' --per-page=3 --order='NAME DESC'
---|---------------------------------------------------------|---------------------------------|--------------|------------------------------------------------------------------------
ID | NAME                                                    | PRODUCT                         | CONTENT TYPE | URL
---|---------------------------------------------------------|---------------------------------|--------------|------------------------------------------------------------------------
5  | Red Hat Enterprise Linux 6 Server Kickstart x86_64 6.7  | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/6/6.7/x86_64/kickstart
8  | Red Hat Enterprise Linux 6 Server RPMs x86_64 6Server   | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/6/6Server/x86_64/os
1  | Red Hat Enterprise Linux 7 Server Kickstart x86_64 7.2  | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/7/7.2/x86_64/kickstart
4  | Red Hat Enterprise Linux 6 Server Kickstart i386 6.7    | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/6/6.7/i386/kickstart
3  | Red Hat Enterprise Linux 5 Server Kickstart x86_64 5.11 | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/5/5.11/x86_64/kickstart
10 | Red Hat Enterprise Linux 5 Server RPMs x86_64 5Server   | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/5/5Server/x86_64/os
9  | Red Hat Enterprise Linux 5 Server RPMs i386 5Server     | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/5/5Server/i386/os
2  | Red Hat Enterprise Linux 5 Server Kickstart i386 5.11   | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/5/5.11/i386/kickstart
6  | Red Hat Enterprise Linux 7 Server RPMs x86_64 7Server   | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/7/7Server/x86_64/os
7  | Red Hat Enterprise Linux 6 Server RPMs i386 6Server     | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/6/6Server/i386/os
---|---------------------------------------------------------|---------------------------------|--------------|------------------------------------------------------------------------
[root@cloud-qe-10 ~]# hammer -u admin -p changeme repository list --organization-id 1 --product 'Red Hat Enterprise Linux Server' --order='NAME DESC'
---|---------------------------------------------------------|---------------------------------|--------------|------------------------------------------------------------------------
ID | NAME                                                    | PRODUCT                         | CONTENT TYPE | URL
---|---------------------------------------------------------|---------------------------------|--------------|------------------------------------------------------------------------
5  | Red Hat Enterprise Linux 6 Server Kickstart x86_64 6.7  | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/6/6.7/x86_64/kickstart
8  | Red Hat Enterprise Linux 6 Server RPMs x86_64 6Server   | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/6/6Server/x86_64/os
1  | Red Hat Enterprise Linux 7 Server Kickstart x86_64 7.2  | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/7/7.2/x86_64/kickstart
4  | Red Hat Enterprise Linux 6 Server Kickstart i386 6.7    | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/6/6.7/i386/kickstart
3  | Red Hat Enterprise Linux 5 Server Kickstart x86_64 5.11 | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/5/5.11/x86_64/kickstart
10 | Red Hat Enterprise Linux 5 Server RPMs x86_64 5Server   | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/5/5Server/x86_64/os
9  | Red Hat Enterprise Linux 5 Server RPMs i386 5Server     | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/5/5Server/i386/os
2  | Red Hat Enterprise Linux 5 Server Kickstart i386 5.11   | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/5/5.11/i386/kickstart
6  | Red Hat Enterprise Linux 7 Server RPMs x86_64 7Server   | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/7/7Server/x86_64/os
7  | Red Hat Enterprise Linux 6 Server RPMs i386 6Server     | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/6/6Server/i386/os
---|---------------------------------------------------------|---------------------------------|--------------|------------------------------------------------------------------------
[root@cloud-qe-10 ~]# hammer -u admin -p changeme repository list --organization-id 1 --product 'Red Hat Enterprise Linux Server' --order='ID DESC'
---|---------------------------------------------------------|---------------------------------|--------------|------------------------------------------------------------------------
ID | NAME                                                    | PRODUCT                         | CONTENT TYPE | URL
---|---------------------------------------------------------|---------------------------------|--------------|------------------------------------------------------------------------
5  | Red Hat Enterprise Linux 6 Server Kickstart x86_64 6.7  | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/6/6.7/x86_64/kickstart
8  | Red Hat Enterprise Linux 6 Server RPMs x86_64 6Server   | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/6/6Server/x86_64/os
1  | Red Hat Enterprise Linux 7 Server Kickstart x86_64 7.2  | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/7/7.2/x86_64/kickstart
4  | Red Hat Enterprise Linux 6 Server Kickstart i386 6.7    | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/6/6.7/i386/kickstart
3  | Red Hat Enterprise Linux 5 Server Kickstart x86_64 5.11 | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/5/5.11/x86_64/kickstart
10 | Red Hat Enterprise Linux 5 Server RPMs x86_64 5Server   | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/5/5Server/x86_64/os
9  | Red Hat Enterprise Linux 5 Server RPMs i386 5Server     | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/5/5Server/i386/os
2  | Red Hat Enterprise Linux 5 Server Kickstart i386 5.11   | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/5/5.11/i386/kickstart
6  | Red Hat Enterprise Linux 7 Server RPMs x86_64 7Server   | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/7/7Server/x86_64/os
7  | Red Hat Enterprise Linux 6 Server RPMs i386 6Server     | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/6/6Server/i386/os
---|---------------------------------------------------------|---------------------------------|--------------|------------------------------------------------------------------------
[root@cloud-qe-10 ~]# clear
[root@cloud-qe-10 ~]#
[root@cloud-qe-10 ~]#
[root@cloud-qe-10 ~]#
[root@cloud-qe-10 ~]#
[root@cloud-qe-10 ~]#
[root@cloud-qe-10 ~]# hammer -u admin -p changeme repository list --organization-id 1 --product 'Red Hat Enterprise Linux Server' --per-page=3 --order='id DESC'
---|---------------------------------------------------------|---------------------------------|--------------|------------------------------------------------------------------------
ID | NAME                                                    | PRODUCT                         | CONTENT TYPE | URL
---|---------------------------------------------------------|---------------------------------|--------------|------------------------------------------------------------------------
5  | Red Hat Enterprise Linux 6 Server Kickstart x86_64 6.7  | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/6/6.7/x86_64/kickstart
8  | Red Hat Enterprise Linux 6 Server RPMs x86_64 6Server   | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/6/6Server/x86_64/os
1  | Red Hat Enterprise Linux 7 Server Kickstart x86_64 7.2  | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/7/7.2/x86_64/kickstart
4  | Red Hat Enterprise Linux 6 Server Kickstart i386 6.7    | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/6/6.7/i386/kickstart
3  | Red Hat Enterprise Linux 5 Server Kickstart x86_64 5.11 | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/5/5.11/x86_64/kickstart
10 | Red Hat Enterprise Linux 5 Server RPMs x86_64 5Server   | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/5/5Server/x86_64/os
9  | Red Hat Enterprise Linux 5 Server RPMs i386 5Server     | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/5/5Server/i386/os
2  | Red Hat Enterprise Linux 5 Server Kickstart i386 5.11   | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/5/5.11/i386/kickstart
6  | Red Hat Enterprise Linux 7 Server RPMs x86_64 7Server   | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/7/7Server/x86_64/os
7  | Red Hat Enterprise Linux 6 Server RPMs i386 6Server     | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/6/6Server/i386/os
---|---------------------------------------------------------|---------------------------------|--------------|------------------------------------------------------------------------
[root@cloud-qe-10 ~]# hammer -u admin -p changeme repository list --organization-id 1 --product 'Red Hat Enterprise Linux Server' --per-page=3 --order='id'
---|---------------------------------------------------------|---------------------------------|--------------|------------------------------------------------------------------------
ID | NAME                                                    | PRODUCT                         | CONTENT TYPE | URL
---|---------------------------------------------------------|---------------------------------|--------------|------------------------------------------------------------------------
5  | Red Hat Enterprise Linux 6 Server Kickstart x86_64 6.7  | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/6/6.7/x86_64/kickstart
8  | Red Hat Enterprise Linux 6 Server RPMs x86_64 6Server   | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/6/6Server/x86_64/os
1  | Red Hat Enterprise Linux 7 Server Kickstart x86_64 7.2  | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/7/7.2/x86_64/kickstart
4  | Red Hat Enterprise Linux 6 Server Kickstart i386 6.7    | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/6/6.7/i386/kickstart
3  | Red Hat Enterprise Linux 5 Server Kickstart x86_64 5.11 | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/5/5.11/x86_64/kickstart
10 | Red Hat Enterprise Linux 5 Server RPMs x86_64 5Server   | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/5/5Server/x86_64/os
9  | Red Hat Enterprise Linux 5 Server RPMs i386 5Server     | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/5/5Server/i386/os
2  | Red Hat Enterprise Linux 5 Server Kickstart i386 5.11   | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/5/5.11/i386/kickstart
6  | Red Hat Enterprise Linux 7 Server RPMs x86_64 7Server   | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/7/7Server/x86_64/os
7  | Red Hat Enterprise Linux 6 Server RPMs i386 6Server     | Red Hat Enterprise Linux Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/6/6Server/i386/os
---|---------------------------------------------------------|---------------------------------|--------------|------------------------------------------------------------------------

Comment 6 Og Maciel 2016-03-24 14:10:20 UTC
As per comment #5 I was not able to sort my repository list by any combination. Also, the --per-page seems to stop working when you use --order.

This failed on Satellite 6.2.0 SNAP 5.1.

Comment 8 Bryan Kearney 2017-08-01 20:33:21 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and we do not expect this to be implemented in product in the foreseeable future. We are therefore closing this out as WONTFIX. If you have any concerns about this, please feel free to contact Rich Jerrido or Bryan Kearney. Thank you.


Note You need to log in before you can comment on or make changes to this bug.