Bug 1128494 - flickr plugin: cannot login anymore, flickr API now requires HTTPS
Summary: flickr plugin: cannot login anymore, flickr API now requires HTTPS
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: digikam
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1119036
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-10 21:16 UTC by Victor Stinner
Modified: 2014-08-24 02:54 UTC (History)
6 users (show)

Fixed In Version: digikam-4.2.0-5.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-24 02:54:42 UTC


Attachments (Terms of Use)
Partial (but enough) backport of https://projects.kde.org/projects/extragear/graphics/kipi-plugins/repository/revisions/1d4a95bc3d36060a025b8950aaaca467253532bc (773 bytes, patch)
2014-08-10 21:16 UTC, Victor Stinner
no flags Details | Diff
Patch for the Fedora SPEC file (618 bytes, patch)
2014-08-10 21:17 UTC, Victor Stinner
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
KDE Software Compilation 336835 None None None Never

Description Victor Stinner 2014-08-10 21:16:42 UTC
Created attachment 925592 [details]
Partial (but enough) backport of https://projects.kde.org/projects/extragear/graphics/kipi-plugins/repository/revisions/1d4a95bc3d36060a025b8950aaaca467253532bc

Description of problem:
It is no more possible to login into Flickr with the Flickr plugin, because Flickr API now requires HTTPS whereas URLs are hardcoded to HTTP.

Upstream bug report:
https://bugs.kde.org/show_bug.cgi?id=336835


Version-Release number of selected component (if applicable):
kipi-plugins 4.0.0 with digikam 4.0.0

How reproducible:
Always

Steps to Reproduce:
1. Start Digikam
2. Select a photo
3. Menu Exportation > Export to Flickr ...

Actual results:
"Unknown error" popup with another "Frob" popup frozen at 50%.


Expected results:
Flickr plugin should open a web browser page to create a token for digikam.

Additional info:
I wrote manually a patch which backports the fix from Git.

Comment 1 Victor Stinner 2014-08-10 21:17:21 UTC
Created attachment 925593 [details]
Patch for the Fedora SPEC file

Comment 2 Victor Stinner 2014-08-10 23:01:12 UTC
> nucleo 2014-08-10 17:22:55 EDT
> Depends On: 1114377

Would it be possible to fix Digikam in Fedora 20? I mean just include my fix without upgrading to Digikam 4.2.

Comment 3 Rex Dieter 2014-08-13 12:28:20 UTC
Possible, we're hoping to just upgrade to 4.2.  We'll see.  If that doesn't happen soon, then sure.

Comment 4 Fedora Update System 2014-08-17 22:09:56 UTC
digikam-4.2.0-5.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/digikam-4.2.0-5.fc20

Comment 5 Fedora Update System 2014-08-19 07:07:49 UTC
Package digikam-4.2.0-5.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing digikam-4.2.0-5.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-9563/digikam-4.2.0-5.fc20
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2014-08-24 02:54:42 UTC
digikam-4.2.0-5.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.