Bug 112850 - Bind slave grab from other linux distro or win2k-as fails
Bind slave grab from other linux distro or win2k-as fails
Product: Fedora
Classification: Fedora
Component: redhat-config-bind (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Depends On:
  Show dependency treegraph
Reported: 2004-01-03 21:51 EST by trinity sabre
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-01-05 15:56:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description trinity sabre 2004-01-03 21:51:12 EST
Description of problem:
Bind fails to properly get entries for zones it is slaved to:

Jan  2 23:58:53 reaper named[4126]: dumping master file:
tmp-XXXXsCHOOl: open: permission denied
Jan  2 23:58:53 reaper named[4126]: transfer of 'ibdhi.com/IN' from
66.xx.xx.xx#53: failed while receiving responses: permission denied
Jan  2 23:58:53 reaper named[4126]: transfer of 'ibdhi.com/IN' from
66.xx.xx.xx#53: end of transfer

uninstalled bind, all utils, dev, cached server, and chroot

reinstalled all but cached

using redhat-config-bind creates the right files where they should
be... still fails to update

; <<>> DiG 9.2.2-P3 <<>> @66.xx.xx.xx axfr re-tv.tv
;; global options:  printcmd
re-tv.tv.               3600    IN      SOA     ns1.deviantsin.org.
admin.deviantsin.org. 322 900 600 86400 3600
re-tv.tv.               3600    IN      A
re-tv.tv.               3600    IN      NS      ns1.deviantsin.org.
re-tv.tv.               3600    IN      NS      ns2.deviantsin.org.
re-tv.tv.               3600    IN      MX      10 mail.re-tv.tv.
*.re-tv.tv.             3600    IN      A
mail.re-tv.tv.          3600    IN      A
re-tv.tv.               3600    IN      SOA     ns1.deviantsin.org.
admin.deviantsin.org. 322 900 600 86400 3600
;; Query time: 7 msec
;; SERVER: 66.xx.xx.xx#53(66.xx.xx.xx)
;; WHEN: Sat Jan  3 18:56:44 2004
;; XFR size: 9 records

tried a slave from a linux box, same probs....

updated all default paths in /var/named/chroot/etc/named.conf to

Version-Release number of selected component (if applicable):

How reproducible:
always with default install

Steps to Reproduce:
1. install fedora core
2. uninstall && reinstall bind, bind-chroot, and redhat-config-bind
3. add slave zones
4. restart server
5. check system logs
Actual results:
slave zone propogation fails

Expected results:
slave zone propogation expected

Additional info:
Comment 1 Kaj J. Niemi 2004-01-03 22:47:32 EST
Your bind complains of permissions while creating a temporary file.

The bind package owns /var/named/slaves (notice the trailing "s"), not
/var/named/slave. Could it be a typo in your configuration?

Is your slave directory owned by named:named like below?

% ls -ld /var/named/slaves
drwxrwx---    2 named    named        4096 Nov 13 02:56 /var/named/slaves

If you're running bind as chrooted /var/named/slaves (or
/var/named/slave for you?) needs to be located within
/var/named/chroot, eg. the path you should be looking for is
/var/named/chroot/var/named/slaves. The access permissions still need
to be correct.

Comment 2 trinity sabre 2004-01-04 03:25:15 EST
sorry, i meant /var/named/slaves/ (long nyte) ;) 
the point was more that when installing fedora core, select bind, it 
installs the chroot dir, and seems to load from it, yet the 
redhat-config-bind setup doesnt set the correct paths by default for 
It creates the slave zones in the correct chrooted dir, but doesnt 
set the paths correctly. 
this in turn creates the permission errors until the paths are 
corrected, i havent tried to reproduce this on any other machines as 
i am lacking a ps for my test system right now. 
i will hopefully have a new ps for the test system next week, so, 
will see if its reproduceable on other hardware... 
as far as the setup, its 
setting the redhat-config-bind generated file to 
/var/named/slaves/whatever.dom.zone worked fine 
like i said, more of an annoyance than a bug really, i am not sure 
if fedora runs bindchrooted by default, but the install i ran set it 
up by default, so i figured the redhat-config-bind should have 
worked with the default install 
Comment 3 trinity sabre 2004-01-04 03:41:34 EST
if what i typed doesnt make total sense, please bear with me, i'm a 
windows user and am working on migrating every comp in the office to 
linux by 2005.... so am learning as i go, some ppl rec'd gentoo but 
i had some experience with redhat as a desktop environment, and 
decided to go with something i trusted, plus bugzilla had 
workarounds for the aic7xxx/i440gx irq issues. 
Comment 4 trinity sabre 2004-01-04 03:43:46 EST
heh and have been up now for about 4 days with no sleep making sure 
everything is working, testing subsystems, and drinking a mad amount 
of jolt mixed with starbucks doubleshots.. ie, brain has been fried 
for the last 48 or so hours, hitting bed..... 
Comment 5 Daniel Walsh 2004-01-05 15:56:57 EST
system-config-bind now defaults to the slaves directory.



Note You need to log in before you can comment on or make changes to this bug.