Bug 1128578 - [JBossFuse] Creating multiple openshift containers at once overcommits nodes / exceeds node capacity
Summary: [JBossFuse] Creating multiple openshift containers at once overcommits nodes ...
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Fuse
Version: 2.2.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: Marek Schmidt
QA Contact: David Simansky
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-11 07:09 UTC by Marek Schmidt
Modified: 2016-05-25 13:25 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-01-07 02:13:59 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
JBoss Issue Tracker ENTESB-1877 Critical Resolved Creating multiple openshift containers at once overcommits nodes / exceeds node capacity 2016-05-25 13:53:11 UTC

Description Marek Schmidt 2014-08-11 07:09:37 UTC
Description of problem:

Creating new openshift containers via Fuse console allows creation of multiple containers at once. This will create multiple node creation requests and the broker will attempt to assign all of these requests to the same node. This will fail with

2014-08-11 02:50:03.643 [ERROR] Gear creation failed.  The server node2.hosts.sample.com that was chosen to run your gear has already exceeded its capacity.  Try your request again. 

Since Fuse does not appear to understand this message, the container creation will not be attempted again and the container is not created.

Version-Release number of selected component (if applicable):
OpenShift Enterprise 2.1.3
openshift-origin-cartridge-fuse-6.1.0.redhat.387-6.el6op.noarch.rpm


How reproducible:
always

Steps to Reproduce:
1. Setup two OSE nodes, edit their /etc/openshift/resource_limits.conf 

max_active_gears=2
no_overcommit_active=true

2. Create a fuse gear

3. Login into the fuse console, attempt to create 3 new openshift containers

Actual results:
Only 1 or 2 of the three requested containers are created. And the "
Gear creation failed.  The server .* that was chosen to run your gear has already exceeded its capacity.  Try your request again. " message can be seen in the broker logs.

Expected results:
3 new containers should be created.

Additional info:

I am not sure whether this counts as a broker issue (should try to evenly distribute the new gear creation requests), or the Fuse cartridge (fuse not understanding the "Try your request again." error. 

Note that if "no_overcommit_active=false", the node will turn out to be overcommited in this case (which for a fuse cart is problematic, as it uses most of the assigned memory, so it will likely fail with out of memory issues)

Comment 2 Anne-Louise Tangring 2014-08-29 20:08:06 UTC
This issue has been moved to JBoss Fuse (ENTESB) in JIRA at issues.jira.org. See link under external trackers.

Comment 3 JBoss JIRA Server 2014-09-05 14:17:12 UTC
Grzegorz Grzybek <ggrzybek@redhat.com> updated the status of jira ENTESB-1877 to Resolved

Comment 4 xjia 2015-01-07 02:13:59 UTC
According to jira ENTESB-1877, close this bug.


Note You need to log in before you can comment on or make changes to this bug.