Bug 1128641 - The package consistency test between 'package manifest' and 'repo metadata' FAILED for the repo 'rhel-scalefs-for-rhel-6-workstation-htb-debug-rpms'
Summary: The package consistency test between 'package manifest' and 'repo metadata' F...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: releng
Version: 6.6
Hardware: x86_64
OS: Linux
urgent
urgent
Target Milestone: rc
: ---
Assignee: Lubos Kocman
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-11 09:27 UTC by haiwang
Modified: 2015-04-13 22:33 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-14 04:30:49 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1405 normal SHIPPED_LIVE redhat-release-server bug fix and enhancement update 2014-10-14 00:54:58 UTC

Description haiwang 2014-08-11 09:27:44 UTC
Description of problem:
The package consistency test between 'package manifest' and 'repo metadata' FAILED for the repo 'rhel-scalefs-for-rhel-6-workstation-htb-debug-rpms'

Version-Release number of selected component (if applicable):

RHEL6.6 Beta HTB -Workstation(x86-64)

How reproducible:


Steps to Reproduce:
1.
2.get repolist with repoquery: 
#repoquery --show-dupes --all --repoid=rhel-scalefs-for-rhel-6-workstation-htb-debug-rpms --qf "%{name}-%{version}-%{release}.%{arch}" --releasever=6.6|sort -u
Could not match packages: Cannot retrieve repository metadata (repomd.xml) for repository: rhel-scalefs-for-rhel-6-workstation-htb-debug-rpms. get '0' packages by repoquery for the repo 'rhel-scalefs-for-rhel-6-workstation-htb-debug-rpms'.
3.get '3' packages from the package manifest under the repo of '/155/x86_64/rhel-scalefs-for-rhel-6-workstation-htb-debug-rpms'
Below '3' pkgs in 'package manifest' could not be found in 'repo metadata':
xfsdump-debuginfo-3.0.4-4.el6.x86_64
xfsprogs-debuginfo-3.1.1-16.el6.i686
xfsprogs-debuginfo-3.1.1-16.el6.x86_64

Actual results:

The package consistency test between 'package manifest' and 'repo metadata' comparison failed for the repo 'rhel-scalefs-for-rhel-6-workstation-htb-debug-rpms'

Expected results:
The package consistency test between 'package manifest' and 'repo metadata' comparison successfully for the repo 'rhel-scalefs-for-rhel-6-workstation-htb-debug-rpms'

Additional info:

command of get content from the url 'https://cdn.redhat.com/content/htb/rhel/workstation/6/6.6/x86_64/scalablefilesystem/debug/Packages/':
# curl -s --cert /etc/pki/entitlement/6203226872518089795.pem --key /etc/pki/entitlement/6203226872518089795-key.pem -k --proxy http://squid.corp.redhat.com:3128 https://cdn.redhat.com/content/htb/rhel/workstation/6/6.6/x86_64/scalablefilesystem/debug/Packages/ && echo

result of get content from the url 'https://cdn.redhat.com/content/htb/rhel/workstation/6/6.6/x86_64/scalablefilesystem/debug/Packages/': 0
File not found."

Comment 1 haiwang 2014-08-11 09:32:25 UTC
(In reply to haiwang from comment #0)
> Description of problem:
> The package consistency test between 'package manifest' and 'repo metadata'
> FAILED for the repo 'rhel-scalefs-for-rhel-6-workstation-htb-debug-rpms'
> 
> Version-Release number of selected component (if applicable):
> 
> RHEL6.6 Beta HTB -Workstation(x86-64)
> 
> How reproducible:
> 
> 
> Steps to Reproduce:
> 1.register and subscribe
> #subscription-manager register --username=stage_test_34 --password='redhat'
The system has been registered with ID: a90ea191-1944-4289-b598-adde10fee8de 
> #subscription-manager subscribe --pool=8a99f98146b4fa9d0146b5723ff6239e
Successfully attached a subscription for: High Touch Beta for Red Hat Enterprise Linux Server (8 sockets) (L3-only)
> 2.get repolist with repoquery: 
> #repoquery --show-dupes --all
> --repoid=rhel-scalefs-for-rhel-6-workstation-htb-debug-rpms --qf
> "%{name}-%{version}-%{release}.%{arch}" --releasever=6.6|sort -u
> Could not match packages: Cannot retrieve repository metadata (repomd.xml)
> for repository: rhel-scalefs-for-rhel-6-workstation-htb-debug-rpms. get '0'
> packages by repoquery for the repo
> 'rhel-scalefs-for-rhel-6-workstation-htb-debug-rpms'.
> 3.get '3' packages from the package manifest under the repo of
> '/155/x86_64/rhel-scalefs-for-rhel-6-workstation-htb-debug-rpms'
> Below '3' pkgs in 'package manifest' could not be found in 'repo metadata':
> xfsdump-debuginfo-3.0.4-4.el6.x86_64
> xfsprogs-debuginfo-3.1.1-16.el6.i686
> xfsprogs-debuginfo-3.1.1-16.el6.x86_64
> 
> Actual results:
> 
> The package consistency test between 'package manifest' and 'repo metadata'
> comparison failed for the repo
> 'rhel-scalefs-for-rhel-6-workstation-htb-debug-rpms'
> 
> Expected results:
> The package consistency test between 'package manifest' and 'repo metadata'
> comparison successfully for the repo
> 'rhel-scalefs-for-rhel-6-workstation-htb-debug-rpms'
> 
> Additional info:
> 
> command of get content from the url
> 'https://cdn.redhat.com/content/htb/rhel/workstation/6/6.6/x86_64/
> scalablefilesystem/debug/Packages/':
> # curl -s --cert /etc/pki/entitlement/6203226872518089795.pem --key
> /etc/pki/entitlement/6203226872518089795-key.pem -k --proxy
> http://squid.corp.redhat.com:3128
> https://cdn.redhat.com/content/htb/rhel/workstation/6/6.6/x86_64/
> scalablefilesystem/debug/Packages/ && echo
> 
> result of get content from the url
> 'https://cdn.redhat.com/content/htb/rhel/workstation/6/6.6/x86_64/
> scalablefilesystem/debug/Packages/': 0
> File not found."

Comment 2 Lubos Kocman 2014-08-11 10:06:46 UTC
Yes for some reason addons were missing. I'm pushing re-staged htb structure now.

Comment 4 errata-xmlrpc 2014-10-14 04:30:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1405.html


Note You need to log in before you can comment on or make changes to this bug.