Bug 1128647 - volume info files are not updated with the op-version and client-op-version
Summary: volume info files are not updated with the op-version and client-op-version
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd
Version: rhgs-3.0
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
: RHGS 3.0.0
Assignee: Avra Sengupta
QA Contact: SATHEESARAN
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-11 09:48 UTC by Rahul Hinduja
Modified: 2015-05-13 16:56 UTC (History)
7 users (show)

Fixed In Version: glusterfs-3.6.0.28-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-22 19:45:25 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2014:1278 normal SHIPPED_LIVE Red Hat Storage Server 3.0 bug fix and enhancement update 2014-09-22 23:26:55 UTC

Description Rahul Hinduja 2014-08-11 09:48:17 UTC
Description of problem:
=======================

With the latest code, observed that the volume information files are missing two fields "op-version" and "client-op-version" which might lead to client disconnects.

[root@inception ~]# gluster v list 
vol0
vol1
vol2
vol3
[root@inception ~]# cat /var/lib/glusterd/vols/vol1/info | grep op-version
[root@inception ~]# 



Version-Release number of selected component (if applicable):
=============================================================

glusterfs-3.6.0.27-1.el6rhs.x86_64


How reproducible:
=================
1/1


Steps to Reproduce:
=====================
1. Create a volume
2. Check the info file


Actual results:
===============
op-version and client-op-version is missing


Expected results:
=================
op-version and client-op-version should be updated.

Comment 1 Avra Sengupta 2014-08-11 09:51:28 UTC
This is a down-stream only issue, introduced as part of some backward compatibility fixes for 2.1.

A function call to write the said options is missed. The fix is quite trivial and non-intrusive

Comment 2 Avra Sengupta 2014-08-11 10:08:10 UTC
Fix at https://code.engineering.redhat.com/gerrit/30623

Comment 4 Rahul Hinduja 2014-09-08 13:07:18 UTC
verified with build: glusterfs-3.6.0.28-1.el6rhs.x86_64

op-version and client-op-version are updated in the info 

[root@inception ~]# cat /var/lib/glusterd/vols/vol0/info | grep version
version=2
op-version=30000
client-op-version=30000
[root@inception ~]# 

[root@inception ~]# cat /var/lib/glusterd/vols/vol0/info
type=2
count=4
status=1
sub_count=2
stripe_count=1
replica_count=2
version=2
transport-type=0
volume-id=fa39214a-12d9-4d84-bbbc-7db3f7d3a3f6
username=79cdeb28-bcf0-44ba-ab22-488228356e78
password=2a21bd57-8546-42ee-bc23-084167fe1f96
op-version=30000
client-op-version=30000
parent_volname=N/A
restored_from_snap=00000000-0000-0000-0000-000000000000
snap-max-hard-limit=256
performance.readdir-ahead=on
brick-0=inception.lab.eng.blr.redhat.com:-rhs-brick1-b1
brick-1=rhs-arch-srv2.lab.eng.blr.redhat.com:-rhs-brick1-b1
brick-2=rhs-arch-srv3.lab.eng.blr.redhat.com:-rhs-brick1-b1
brick-3=rhs-arch-srv4.lab.eng.blr.redhat.com:-rhs-brick1-b1
[root@inception ~]# 
[root@inception ~]# 
[root@inception ~]# 


Moving the bug to verified state

Comment 6 errata-xmlrpc 2014-09-22 19:45:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-1278.html


Note You need to log in before you can comment on or make changes to this bug.