Bug 112868 - Several relevant directories not owned by libselinux
Several relevant directories not owned by libselinux
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: selinux-policy-strict (Show other bugs)
1.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-04 16:27 EST by W. Michael Petullo
Modified: 2007-04-18 13:00 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-09 13:54:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description W. Michael Petullo 2004-01-04 16:27:01 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.4.1)
Gecko/20031114 Epiphany/1.0.4

Description of problem:
The following directories are not owned by any RPM.  I propose that
libselinux install and own them:

/etc/security/selinux
/etc/security/selinux/src
/etc/security/selinux/src/policy
/etc/security/selinux/src/policy/domains
/etc/security/selinux/src/policy/domains/program
/etc/security/selinux/src/policy/file_contexts
/etc/security/selinux/src/policy/file_contexts/program

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
[mike@imp mike]$ rpm -qif /etc/security/selinux/
file /etc/security/selinux is not owned by any package
[mike@imp mike]$ rpm -q libselinux
libselinux-1.3-3


Additional info:
Comment 1 Miloslav Trmac 2004-01-05 04:11:27 EST
Triage->Easyfix
Comment 2 Daniel Walsh 2004-01-05 17:02:56 EST
These directories are now owned by policy-1.4.4

Dan
Comment 3 W. Michael Petullo 2004-08-22 11:57:21 EDT
There has been somewhat of a regression on this bug since the policy
has been split into targeted and strict.  The following files now have
no owners:

/etc/selinux
/etc/selinux/config
/etc/selinux/strict/contexts
/etc/selinux/strict/contexts/files
/etc/selinux/strict/contexts/users
/etc/selinux/strict/policy
/etc/selinux/strict/src/policy/file_contexts
/etc/selinux/strict/src/policy/file_contexts/file_contexts
/etc/selinux/strict/src/policy/policy.conf
/etc/selinux/strict/src/policy/tmp
/etc/selinux/strict/src/policy/tmp/load
/etc/selinux/strict/src/policy/tmp/program_used_flags.te
/etc/selinux/strict/src/policy/tunables

These files should be installed or %ghost'ed by the policy packages.
Comment 4 Daniel Walsh 2004-08-25 15:39:20 EDT
fixed in selinux-policy-*-1.17.4-3
Comment 5 W. Michael Petullo 2004-08-31 20:14:48 EDT
/etc/selinux/strict/src/policy/file_contexts/file_contexts

and

/etc/selinux/strict/src/policy/policy.conf

are still not owned.  Should they be %ghosted at least?

The files in (and including) /etc/selinux/strict/src/policy/tmp as
also still not owned.
Comment 6 Daniel Walsh 2005-02-09 13:54:19 EST
Fixed in current release

Note You need to log in before you can comment on or make changes to this bug.