Bug 112870 - Freezes before entering runlevel 3
Freezes before entering runlevel 3
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: sysvinit (Show other bugs)
1
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-04 17:37 EST by Davide Bolcioni
Modified: 2014-03-16 22:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-28 01:29:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Davide Bolcioni 2004-01-04 17:37:56 EST
Description of problem: Boot procedure freezes between setting
parameters for hda and entering runlevel 3


Version-Release number of selected component (if applicable):
2.85-5

How reproducible: Frequently on cold boot


Steps to Reproduce:
1. Turn PC on
2. Wait for OK to setting parameters for hda
3. Boot sequence hangs ...
  
Actual results: hangs with cursor in lower left corner


Expected results: message saying "Entering runlevel 3"


Additional info: The machine is somewhat functional; Ctrl-Alt-Canc
reboots and the problem does not occur after reboot. Empirically, the
problem seems to occur when booting with kernel-2.4.22-1.2135.nptl
but not with kernel-2.4.22-1.2115.nptl, although it might just be
luck on my part. The machine has both SCSI and IDE disks.
Comment 1 Davide Bolcioni 2004-05-14 15:49:47 EDT
More information on this: SysVInit does not ACTUALLY freeze.

It looks like a freeze because there is no output to the console: if I
wait long enough, I get to the login: prompt (still runlevel 3) and
all daemons have been started, just without the usual OK output.

This is the behavior I am experiencing with kernel-2.4.22-1.2174.nptl
and glibc-2.3.2-101.4.
Comment 2 Bill Nottingham 2005-01-28 01:29:54 EST
This sounds like a problem with the console= for the kernel
pointing at the wrong device.
Closing out bugs on older, unsupported releases.
Apologies for any lack of response.
Comment 3 David Lawrence 2007-06-21 22:10:37 EDT
Package name is now sysvinit in Fedora.

Note You need to log in before you can comment on or make changes to this bug.