Bug 1128752 - Incorrect message with ovirt optimizer for provided solution
Summary: Incorrect message with ovirt optimizer for provided solution
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: General
Version: ---
Hardware: All
OS: All
medium
medium vote
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Martin Sivák
QA Contact: Shira Maximov
URL:
Whiteboard: sla
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-11 13:17 UTC by Lukas Svaty
Modified: 2016-02-10 19:19 UTC (History)
7 users (show)

Fixed In Version: ovirt-optimizer-0.9
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-04 13:34:58 UTC
oVirt Team: SLA
rule-engine: ovirt-3.6.0+
rule-engine: blocker+
ylavi: planning_ack+
rule-engine: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)

Description Lukas Svaty 2014-08-11 13:17:45 UTC
Description of problem:
When only  host exists in cluster ovirt optimizer provides message:

Status: Solution is not doable! There are hard constraint violations.

Which is incorrect as optimal solution is having all VMs on this host.

Version-Release number of selected component (if applicable):
ovirt-rc1

How reproducible:
100%

Steps to Reproduce:
1. Start 3 VMs on 1 host
2. Run optimizer
3.

Actual results:
Status: Solution is not doable! There are hard constraint violations.

Expected results:
Data recieved.

Additional info:
At least inform admin what hard constraint are violated. Without this information the status of optimizer if useless.

Comment 1 Lukas Svaty 2014-08-11 14:49:38 UTC
It seems the same behaviour appears with multiple hosts as well. Steps are provided by optimizer but status is always 'Solution is not doable...' if at least 1 VM is running.

Comment 2 Martin Sivák 2014-08-26 11:40:08 UTC
This was caused by some missing rules. I do not think we will be able to improve this for 3.5 as the Drools rule names won't tell the admin anything either.

Comment 3 Martin Sivák 2015-08-06 09:52:32 UTC
Fixed by the rebase that happened past 3.5.

Comment 4 Red Hat Bugzilla Rules Engine 2015-09-22 07:43:25 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 5 Shira Maximov 2015-10-11 15:30:50 UTC
verified on : Red Hat Enterprise Virtualization Manager Version: 3.6.0-0.18.el6

Comment 6 Sandro Bonazzola 2015-11-04 13:34:58 UTC
oVirt 3.6.0 has been released on November 4th, 2015 and should fix this issue.
If problems still persist, please open a new BZ and reference this one.


Note You need to log in before you can comment on or make changes to this bug.